Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 569152 - =app-editors/jedit-5.2.0 - jedit: .../work/glib-2.44.1/gobject/gtype.c:1235:type_data_ref_Wm: assertion failed: (node->plugin != NULL)
Summary: =app-editors/jedit-5.2.0 - jedit: .../work/glib-2.44.1/gobject/gtype.c:1235:t...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: PPC64 Linux
: Normal normal (vote)
Assignee: Java team
Depends on:
Reported: 2015-12-22 12:05 UTC by Jeroen Roovers (RETIRED)
Modified: 2023-04-05 13:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers (RETIRED) gentoo-dev 2015-12-22 12:05:20 UTC
$ jedit 

(process:23844): GLib-GObject-WARNING **: cannot instantiate 'GBoxed' as non-instantiatable fundamental
GLib-GObject:ERROR:/var/tmp/portage/dev-libs/glib-2.44.1-r1/work/glib-2.44.1/gobject/gtype.c:1235:type_data_ref_Wm: assertion failed: (node->plugin != NULL)
Comment 1 James Le Cuirot gentoo-dev 2015-12-22 12:11:08 UTC
Were you using CACAO in this case? The GCC bug report mentions it.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2015-12-22 12:47:45 UTC
That's with icedtea-bin, so I guess that's USE=cacao.
Comment 3 James Le Cuirot gentoo-dev 2015-12-22 13:15:19 UTC
It's possibly specific to that then. Hopefully icedtea-3 will work, as it seemed okay with HotSpot when I briefly tried it. With so much glib stuff going on here, it's hard to see what the real problem is so hopefully we can just sidestep this one. Try icedtea-3 from java-overlay if you're curious otherwise you'll have to wait for me.
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2015-12-23 10:56:44 UTC
I haven't had much luck with dev-java/icedtea yet because of bug #568950 so I have no other vm to test against right now.
Comment 5 James Le Cuirot gentoo-dev 2015-12-23 11:00:50 UTC
(In reply to Jeroen Roovers from comment #4)
> I haven't had much luck with dev-java/icedtea yet because of bug #568950 so
> I have no other vm to test against right now.

I suspect you won't see that issue with icedtea-3 as HotSpot appeared to work fine there, though it's been a while since I tried it. It also has a totally different build system.
Comment 6 Volkmar W. Pogatzki 2023-04-05 13:21:20 UTC
The affected version is gone. Closing.