Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 568850 - media-video/xvideoservicethief-2.4.1-r2 fails build with gcc-5.3
Summary: media-video/xvideoservicethief-2.4.1-r2 fails build with gcc-5.3
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Markos Chandras (RETIRED)
: 570846 (view as bug list)
Depends on:
Blocks: gcc-5
  Show dependency tree
Reported: 2015-12-20 05:48 UTC by Duncan
Modified: 2016-10-01 07:53 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info xvideoservicethief (,7.22 KB, text/plain)
2015-12-20 05:48 UTC, Duncan
full build log (media-video:xvideoservicethief-2.4.1-r2:20151220-053644.log,37.54 KB, text/plain)
2015-12-20 06:07 UTC, Duncan
xvideoservicethief-2.4.1-gcc47.patch (xvideoservicethief-2.4.1-gcc47.patch,289 bytes, patch)
2015-12-22 07:10 UTC, Ryan Hill (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Duncan 2015-12-20 05:48:25 UTC
Created attachment 419878 [details]
emerge --info xvideoservicethief

After upgrading to gcc-5.3, I did the rebuild C++ progs as suggested.  With all of them now rebuilt but xvideoservicethief, it still fails to rebuild.

In addition to the c(xx)flags in the attached emerge -info xvideoservicethief, I tried with a simple "-pipe -O2" (no native or other fancy flags) and with -std=gnu++11 (which worked with a different package I had problems with, bug #568606), to no avail, and there's no USE flags besides doc and debug, already disabled, to try disabling, and I tried a MAKEOPTS=-j1 build as well, so I've tried the non-patch fixes I can think of.

Log-excerpt showing the error ([...] indicate elisions):

>>> Compiling source in /tmp/portage/media-video/xvideoservicethief-2.4.1-r2/work ...
make -j10 -l8 
/usr/lib64/qt4/bin/uic ui/addvideo.ui -o build/ui/ui_addvideo.h


/usr/lib64/qt4/bin/uic ui/multiurls.ui -o build/ui/ui_multiurls.h
x86_64-pc-linux-gnu-g++ -c -march=native -pipe -O2 -frename-registers -fweb -fmerge-all-constants -fgcse-sm -fgcse-las -fgcse-after-reload -ftree-vectorize -Wall -W -D_REENTRANT -DxVST_DEBUG_PLUGINS_OFF -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SCRIPT_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/share/qt4/mkspecs/linux-g++ -I. -I/include/qt4/QtCore -I/include/qt4/QtNetwork -I/include/qt4/QtGui -I/include/qt4/QtScript -I/include/qt4/QtWebKit -I/include/qt4 -Isrc/qtsingleapplication/src -Ibuild/moc -Ibuild/ui -o build/o/unix/searchvideositemimpl.o src/forms/searchvideositemimpl.cpp


x86_64-pc-linux-gnu-g++ -c -march=native -pipe -O2 -frename-registers -fweb -fmerge-all-constants -fgcse-sm -fgcse-las -fgcse-after-reload -ftree-vectorize -Wall -W -D_REENTRANT -DxVST_DEBUG_PLUGINS_OFF -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SCRIPT_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/share/qt4/mkspecs/linux-g++ -I. -I/include/qt4/QtCore -I/include/qt4/QtNetwork -I/include/qt4/QtGui -I/include/qt4/QtScript -I/include/qt4/QtWebKit -I/include/qt4 -Isrc/qtsingleapplication/src -Ibuild/moc -Ibuild/ui -o build/o/unix/qtlocalpeer.o src/qtsingleapplication/src/qtlocalpeer.cpp
/usr/lib64/qt4/bin/moc -DxVST_DEBUG_PLUGINS_OFF -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SCRIPT_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/share/qt4/mkspecs/linux-g++ -I. -I/include/qt4/QtCore -I/include/qt4/QtNetwork -I/include/qt4/QtGui -I/include/qt4/QtScript -I/include/qt4/QtWebKit -I/include/qt4 -Isrc/qtsingleapplication/src -Ibuild/moc -Ibuild/ui src/forms/addvideoimpl.h -o build/moc/moc_addvideoimpl.cpp
/usr/lib64/qt4/bin/moc -DxVST_DEBUG_PLUGINS_OFF -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SCRIPT_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/share/qt4/mkspecs/linux-g++ -I. -I/include/qt4/QtCore -I/include/qt4/QtNetwork -I/include/qt4/QtGui -I/include/qt4/QtScript -I/include/qt4/QtWebKit -I/include/qt4 -Isrc/qtsingleapplication/src -Ibuild/moc -Ibuild/ui src/forms/searchvideositemimpl.h -o build/moc/moc_searchvideositemimpl.cpp
/usr/lib64/qt4/bin/moc -DxVST_DEBUG_PLUGINS_OFF -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_SCRIPT_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/share/qt4/mkspecs/linux-g++ -I. -I/include/qt4/QtCore -I/include/qt4/QtNetwork -I/include/qt4/QtGui -I/include/qt4/QtScript -I/include/qt4/QtWebKit -I/include/qt4 -Isrc/qtsingleapplication/src -Ibuild/moc -Ibuild/ui src/forms/bugreportimpl.h -o build/moc/moc_bugreportimpl.cpp
src/qtsingleapplication/src/qtlocalpeer.cpp: In constructor 'QtLocalPeer::QtLocalPeer(QObject*, const QString&)':
src/qtsingleapplication/src/qtlocalpeer.cpp:104:54: error: '::getuid' has not been declared
     socketName += QLatin1Char('-') + QString::number(::getuid(), 16);
src/qtsingleapplication/src/qtlocalpeer.cpp:104:54: note: suggested alternative:
In file included from src/qtsingleapplication/src/qtlockedfile_unix.cpp:49:0,
                 from src/qtsingleapplication/src/qtlocalpeer.cpp:67:
/include/unistd.h:678:16: note:   'QtLP_Private::getuid'
 extern __uid_t getuid (void) __THROW;
Makefile:1190: recipe for target 'build/o/unix/qtlocalpeer.o' failed
make: *** [build/o/unix/qtlocalpeer.o] Error 1

~amd64/nomultilib.  I'm attaching emerge --info xvideoservicethief with this posting, and will then attach the full build log.

Comment 1 Duncan 2015-12-20 06:07:05 UTC
Created attachment 419880 [details]
full build log

Based on the existing binpkg timestamp, I last emerged xvideoservicethief (same version 2.4.1-r2) on January 20, 2015.
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2015-12-22 07:10:13 UTC
Created attachment 420144 [details, diff]

This error should look familiar to you (bug #427066). :)

The problem is the patch that was committed uses the broken code if __GNUC__ >= 4 and __GNUC_MINOR__ <=6.  This includes GCC 5.*.

Try this instead.
Comment 3 Toralf Förster gentoo-dev 2016-01-04 13:22:39 UTC
*** Bug 570846 has been marked as a duplicate of this bug. ***
Comment 4 Duncan 2016-01-16 12:38:17 UTC
(In reply to Ryan Hill from comment #2)
> Created attachment 420144 [details, diff] [details, diff]
> xvideoservicethief-2.4.1-gcc47.patch

> Try this instead.

Builds fine with patch. =:^)  Runs, but I've not downloaded anything yet.

2.4.1 is very old, 2010, the qt5-based 2.5.1 was current... as of 2013(!!), and a lot of sites are broken with 2.4.1 now.  Youtube has certainly changed since 2010, and seems broken now.  Of course gentoo took a very long time to get qt5 in-tree and unmasked to ~arch, but now that it is... I guess a bump-request is my next request... unless it's already filed.
Comment 5 Pacho Ramos gentoo-dev 2016-10-01 07:53:53 UTC