Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 568646 - kde-base/pykde4-4.14.3 failed to compile with gcc-5.3.0
Summary: kde-base/pykde4-4.14.3 failed to compile with gcc-5.3.0
Status: RESOLVED DUPLICATE of bug 567022
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: Normal minor (vote)
Assignee: Gentoo KDE team
Depends on:
Blocks: gcc-5
  Show dependency tree
Reported: 2015-12-18 15:45 UTC by Geoff Madden
Modified: 2015-12-20 16:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emerge info core2 quad (emerg.inf,4.76 KB, text/plain)
2015-12-18 15:47 UTC, Geoff Madden
environment file (environment,191.21 KB, text/plain)
2015-12-18 15:47 UTC, Geoff Madden
build log prior to aplying patch (build.log,125.36 KB, text/x-log)
2015-12-18 15:48 UTC, Geoff Madden

Note You need to log in before you can comment on or make changes to this bug.
Description Geoff Madden 2015-12-18 15:45:54 UTC
following instructions from the news mesages,the revdep-rebuild script worked a treat to find all the affected files after the upgrade to gcc-5.3.0,all worked as expected up till pykde4. restarted compile excluding pykde4,and all completed. searched the bug list and found the missing libs patch by eric Zeek.
applied the patch,recompiled ,problem gone.

Reproducible: Always

Steps to Reproduce:
1.rebuild system after gcc upgrade & apply patch
3.recompile successful
Actual Results:  
pykde4 completed compile

Expected Results:  
successful  completion
Comment 1 Geoff Madden 2015-12-18 15:47:02 UTC
Created attachment 419602 [details]
emerge info core2 quad
Comment 2 Michael Palimaka (kensington) gentoo-dev 2015-12-18 15:47:28 UTC
Is this a dup of bug #567022?
Comment 3 Geoff Madden 2015-12-18 15:47:35 UTC
Created attachment 419604 [details]
environment file
Comment 4 Geoff Madden 2015-12-18 15:48:51 UTC
Created attachment 419606 [details]
build log prior to aplying patch
Comment 5 Geoff Madden 2015-12-18 15:50:49 UTC
as an aside the following news item script did not work for me.
Comment 6 Geoff Madden 2015-12-18 15:54:26 UTC
(In reply to Michael Palimaka (kensington) from comment #2)
> Is this a dup of bug #567022?

possibly I did not make a note of the message No. when I found the patch
Comment 7 Geoff Madden 2015-12-18 15:56:18 UTC
just brought up that number and the answer is yes
Comment 8 Michael Palimaka (kensington) gentoo-dev 2015-12-20 16:36:55 UTC

*** This bug has been marked as a duplicate of bug 567022 ***