Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 568382 - www-client/google-chrome ebuilds present in tree need *.deb mirrored by Gentoo
Summary: www-client/google-chrome ebuilds present in tree need *.deb mirrored by Gentoo
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mike Gilbert
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-16 05:37 UTC by Oleh
Modified: 2015-12-16 16:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleh 2015-12-16 05:37:20 UTC
Currently it is quite unfortunate user experience to stand with non-fetching releases. Idea of an ebuild is to always fetch, compile and install. Not to fail from start. While, it's agreed that google chrome is quite often releasing their version, ebuild version that is present in tree should always fetch. That means, when releases added to tree, its *.deb tarball need gentoo mirror and it's always available. When new release added, remove old and mirror newer one. This is very good from a user perspective. Now,that 47.0.2526.80_p1 released 7 days ago, i had chance to update only today and it's not available:
!!! Couldn't download 'google-chrome-stable_47.0.2526.80-1_amd64.deb'. Aborting.
 * Fetch failed for 'www-client/google-chrome-47.0.2526.80_p1'
Now user need to wait uncertain period of time from "0 to 1440 minutes" to get this fixed. This is against users. Downside: need space for all tree releases. However, for example, gcc tarballs, despite size, always available. Fixing this eliminates bad policy and silly message about waiting 24 hours.


Reproducible: Always
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2015-12-16 13:36:08 UTC
Unfortunately, Google does not permit mirroring of their releases.
Comment 2 Mike Gilbert gentoo-dev 2015-12-16 15:53:39 UTC
Citing the google-chrome EULA:

> 9.2 Subject to section 1.2, you may not (and you may not permit anyone else to) copy, modify, create a derivative work of, reverse engineer, decompile or otherwise attempt to extract the source code of the Software or any part thereof, unless this is expressly permitted or required by law, or unless you have been specifically told that you may do so by Google, in writing.

I interpret this to mean that mirroring the deb files would be a violation of copyright since I do not have permission to do so in writing from Google.

Additionally, I believe we have requested such permission in the past, and were told "no". I would have to dig through my email to find that.
Comment 3 Richard Freeman gentoo-dev 2015-12-16 16:44:19 UTC
Besides the specific prohibition on copying, we actually need to go a step further and have specific permission TO copy.

That is under most legal systems works are copyrighted by default, and the presumption is that you aren't allowed to copy them.  You need an explicit grant of a license to copy at all.  It isn't enough to not be forbidden to copy a file.

Of course, we're all used to working with open source licenses which clearly grant permission to copy.  The problem is that chrome isn't open-source, or freely redistributable.

In short, in order to mirror a file we need a license somewhere (either available to everybody or at least to Gentoo) that gives us explicit permission to redistribute the file, at least in unmodified form.  Without that, we cannot mirror it, though if there is a stable URL for the file from somebody who can distribute the file we can still fetch it.