Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 568058 - dev-libs/boost-1.57.0: fails to build with app-eselect/eselect-python-20151117-r1
Summary: dev-libs/boost-1.57.0: fails to build with app-eselect/eselect-python-2015111...
Status: RESOLVED DUPLICATE of bug 565090
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: C++ Team [disbanded]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-12 09:51 UTC by Gangræna Gorgeous
Modified: 2016-01-20 06:48 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (dev-libs:boost-1.57.0:20151212-092346.log,458.04 KB, text/x-log)
2015-12-12 09:52 UTC, Gangræna Gorgeous
Details
emerge --info (emerge.info,18.80 KB, text/plain)
2015-12-13 23:01 UTC, Gangræna Gorgeous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gangræna Gorgeous 2015-12-12 09:51:52 UTC
Boost can't find pyconfig.h with app-eselect/eselect-python-20151117-r1

In file included from ./boost/python/detail/prefix.hpp:13:0,
                 from ./boost/python/ssize_t.hpp:9,
                 from ./boost/python/object.hpp:8,
                 from ./boost/python/exec.hpp:8,
                 from libs/python/src/exec.cpp:6:
./boost/python/detail/wrap_python.hpp:50:23: fatal error: pyconfig.h: No such file or directory
compilation terminated.

Reproducible: Always

Steps to Reproduce:
1. update eselect-python to =app-eselect/eselect-python-20151117-r1
2. emerge -1 =dev-libs/boost-1.57.0
Comment 1 Gangræna Gorgeous 2015-12-12 09:52:16 UTC
Created attachment 419022 [details]
build.log
Comment 2 Stefan Triller 2015-12-12 18:35:35 UTC
I can confirm the issue with trying to build boost, for me version dev-libs/boost-1.56.0-r1 though.

I tried to mask eselect-python-20151117-r1 and use an older one, but the older one conflicts with python-exec-2.1 which you definitely should NOT unmerge (breaks emerge command)...
Comment 3 Justin Lecher gentoo-dev 2015-12-13 09:36:21 UTC
Which python versions do you have installed? Which pyhton did you eselect?

I am not able to reproduce it here.
Comment 4 Franz Trischberger 2015-12-13 09:56:29 UTC
Same issue here.
Installed python versions:
2.7.11 and 3.4.3-r5
eselected python version is 3.4
IMHO the issue could be the location of the pyconfig.h from the 3.4 install:
/usr/include/python3.4m/pyconfig.h
Note the "m" in the version.
Comment 5 Gangræna Gorgeous 2015-12-13 23:01:40 UTC
Created attachment 419136 [details]
emerge --info
Comment 6 Franz Trischberger 2015-12-14 08:20:50 UTC
The issue is python itself.
$ python3.4-config --includes
-I/usr/include/python3.4 -I/usr/include/python3.4
There is no "python3.4m" in that line, so boost passes that wrong line to the compiler.
Comment 7 Franz Trischberger 2015-12-14 08:38:53 UTC
Eeek, sorry for the noise...
Fired the command on the wrong terminal, the laptop does not yet have the update to "python:3.4/3.4m".
On the already updated machine the command returns valid include dirs:
$ python3.4-config --includes
-I/usr/include/python3.4m -I/usr/include/python3.4m
Comment 8 Sergey Popov gentoo-dev Security 2016-01-20 06:48:12 UTC

*** This bug has been marked as a duplicate of bug 565090 ***