Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 568004 - app-office/libreoffice-5.0.3.2, net-print/cups-2.0.3: printing serial letters with 2 ore more sides one paper is broken
Summary: app-office/libreoffice-5.0.3.2, net-print/cups-2.0.3: printing serial letters...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-11 17:55 UTC by Kai Wüstermann
Modified: 2016-12-30 16:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Wüstermann 2015-12-11 17:55:57 UTC
Printing a serial letter form libreoffice writer by using 2 sides on one paper I is broken.

Printing to net-print/hplip-3.14.10 I get the first letter and than empty papers.

Printing to net-print/cups-pdf-2.6.1 I get one empty side and the job must be deleted from the cups queue.

Printing one side per paper works correctly. 


Reproducible: Always

Steps to Reproduce:
1.create/use a libreoffice database
2.create a writer document with serial field(s) from the database
3.print it by using 2 ore more sides per paper



Portage 2.2.24 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.21-r1, 4.1.12-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.1.12-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q8200_@_2.33GHz-with-gentoo-2.2
KiB Mem:     4046588 total,   2011180 free
KiB Swap:    4194300 total,   4194300 free
Timestamp of repository gentoo: Thu, 10 Dec 2015 14:15:01 +0000
sh dash 0.5.8.2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p39::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.4::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage
    priority: -1000

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE PUEL dlj-1.1 AdobeFlash-11.x"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib/latex2html /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /usr/share/texmf-site/tex/latex/html /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=" -j3  --load-average 2"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://de-mirror.org/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://mirror.netcologne.de/gentoo/"
LANG="de_DE@euro"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 amr apache2 avahi berkdb branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cupsddk cxx dbus dri dts dvd dvdr dvi emboss encode exif fam firefox flac fortran g3dvl gd gdbm gif gimp glamor gnutls gpm gstreamer gtk gtk3 hddtemp hpcups hunspell iconv icu ipv6 java jpeg jpg latex lcdfilter lcms libnotify lm_sensors lyx mad midi mime mmx mmxext mng modules mono mp3 mp4 mpeg mtp multilib ncurses nls nptl nsplugin nvidia odbc odf ogg opencl opengl openmp pam pango pcre pdf png policykit ppds python qt3support qt5 quicktime raw readline scanner sdl seccomp session smp snmp spell sse sse2 ssl startup-notification svg symlink system-cairo system-icu system-jpeg system-sqlite tcpd theora thunar thunderbird tiff truetype udev udisks unicode upower usb uvm vorbis win32codecs wmf wxwidgets x264 xattr xcb xinerama xml xpm xscreensaver xv xvid xvmc zip zlib zsh-completion" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" SANE_BACKENDS="hp" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

app-office/libreoffice-5.0.3.2::gentoo was built with the following:
USE="branding cups dbus gstreamer gtk java (-aqua) -bluetooth (-coinmp) -collada -debug -eds (-firebird) -gltf -gnome (-gtk3) -jemalloc -kde (-libressl) -mysql -odk -postgres (-telepathy) -test -vlc" ABI_X86="64" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_4 -python3_5" PYTHON_TARGETS="python2_7 python3_4 -python3_5"


net-print/cups-2.0.3::gentoo was built with the following:
USE="X acl dbus java pam python ssl threads usb -debug -kerberos -lprng-compat (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="32 64 -x32" LINGUAS="de -ca -cs -es -fr -it -ja -pt_BR -ru" PYTHON_TARGETS="python2_7"


net-print/cups-pdf-2.6.1::gentoo was built with the following:
USE=""
CFLAGS="-march=nocona -O2 -pipe -g"
CXXFLAGS="-march=nocona -O2 -pipe -g"


net-print/hplip-3.14.10::gentoo was built with the following:
USE="X hpcups libnotify policykit qt4 scanner snmp -doc -fax -hpijs -kde -libusb0 -minimal -parport -static-ppds" ABI_X86="64" PYTHON_TARGETS="python2_7"
Comment 1 Andreas K. Hüttel gentoo-dev 2015-12-26 22:20:45 UTC
There seems to be more brokenness in recent releases, see link. 
Worst case you can downgrade to 4.4.6.3, we'll keep it for a while
Comment 2 Andreas K. Hüttel gentoo-dev 2016-03-27 21:32:54 UTC
Any news here?
Comment 3 Kai Wüstermann 2016-03-28 07:09:50 UTC
Now using app-office/libreoffice-5.0.5.2 the problem is the same.
Comment 4 Andreas Sturmlechner gentoo-dev 2016-06-07 09:36:59 UTC
What about 5.1.2.2 (stable) or 5.1.3.2 (just recently entered tree)?
Comment 5 Kai Wüstermann 2016-06-07 12:37:47 UTC
(In reply to Andreas Sturmlechner from comment #4)
> What about 5.1.2.2 (stable) or 5.1.3.2 (just recently entered tree)?

There is no change in app-office/libreoffice-5.1.2.2.
Comment 6 Andreas K. Hüttel gentoo-dev 2016-12-30 16:50:14 UTC
I fear there's not much we can do here. 

If you still have problems with newest libreoffice, please report it upstream and add a link to the upstream bug here.