Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 567980 - >=games-emulation/higan-106: version bump
Summary: >=games-emulation/higan-106: version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-11 09:25 UTC by Dan Douglas
Modified: 2018-01-21 12:36 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Douglas 2015-12-11 09:25:49 UTC
Hi, looks like there have been quite a few changes. The makefile patch needs updating and probably several other things. SRC_URI is now "http://download.byuu.org/${MY_P}.7z"

Reproducible: Always
Comment 1 Thomas 2016-01-02 18:22:44 UTC
Upstream is at 096 now.
Comment 2 Nathan Zachary gentoo-dev 2016-06-02 03:10:02 UTC
Upstream is now at 098 as of 09 April 2016.  There are also some hotfixes incorporated into the git source.
Comment 3 YumeWizard 2016-07-11 19:01:47 UTC
v100 is out as of 3 days ago.

Announcment/Changelog:
http://board.byuu.org/phpbb3/viewtopic.php?f=4&t=1165

Download:
http://download.byuu.org/higan_v100-source.7z
Comment 4 Nathan Zachary gentoo-dev 2016-07-11 19:21:00 UTC
Looks like v099 was added by Andrea Blankenstijn on Thursday, 07 July 2016, but I get compile errors due to an issue with Cairo.  I don't see that problem being fixed in v100, though.
Comment 5 Henrik Wennergren 2016-07-12 09:55:03 UTC
emerge =games-emulation/higan-099::gentoo

>Package gtksourceview-2.0 was not found in the pkg-config search path.
>Perhaps you should add the directory containing `gtksourceview-2.0.pc'
>to the PKG_CONFIG_PATH environment variable
>Package 'gtksourceview-2.0', required by 'world', not found
>x86_64-pc-linux-gnu-g++ -x c++ -std=c++14  -fwrapv -I.. -march=corei7 -O2 -pipe -DHIRO_GTK  -o obj/hiro.o -c ../hiro/hiro.cpp
>x86_64-pc-linux-gnu-g++ -x c++ -std=c++14  -fwrapv -I.. -march=corei7 -O2 -pipe -o obj/icarus.o -c icarus.cpp
>In file included from ../hiro/core/core.cpp:8:0,
>                 from ../hiro/hiro.cpp:5:
>../hiro/core/../gtk/header.hpp:36:21: fatal error: cairo.h: No such file or directory
>   #include <cairo.h>

> * ERROR: games-emulation/higan-099::gentoo failed (compile phase):
> *   emake failed
> * 
> * If you need support, post the output of `emerge --info '=games-emulation/higan-099::gentoo'`,
> * the complete build log and the output of `emerge -pqv '=games-emulation/higan-099::gentoo'`.
> * The complete build log is located at '/var/tmp/portage/games-emulation/higan-099/temp/build.log'.
> * The ebuild environment file is located at '/var/tmp/portage/games-emulation/higan-099/temp/environment'.
> * Working directory: '/var/tmp/portage/games-emulation/higan-099/work/higan_v099-source/icarus'
> * S: '/var/tmp/portage/games-emulation/higan-099/work/higan_v099-source'
> 
> >>> Failed to emerge games-emulation/higan-099, Log file:
> 
> >>>  '/var/tmp/portage/games-emulation/higan-099/temp/build.log'
> 
> * Messages for package games-emulation/higan-099:
> 
> * ERROR: games-emulation/higan-099::gentoo failed (compile phase):
> *   emake failed
> * 
> * If you need support, post the output of `emerge --info '=games-emulation/higan-099::gentoo'`,
> * the complete build log and the output of `emerge -pqv '=games-emulation/higan-099::gentoo'`.
> * The complete build log is located at '/var/tmp/portage/games-emulation/higan-099/temp/build.log'.
> * The ebuild environment file is located at '/var/tmp/portage/games-emulation/higan-099/temp/environment'.
> * Working directory: '/var/tmp/portage/games-emulation/higan-099/work/higan_v099-source/icarus'
> * S: '/var/tmp/portage/games-emulation/higan-099/work/higan_v099-source'

Error with cairo.h was fixed for me by installing gtksourceview before installing higan:
emerge -1 gtksourceview:2.0

It seems to be required by the icarus use flag of higan.
Comment 6 Nathan Zachary gentoo-dev 2016-07-12 17:42:28 UTC
Agreed, and it should be noted that a version in slot 2 needs to be used:

***
Package gtksourceview-2.0 was not found in the pkg-config search path.
***

It also looks like icarus may be required for >=097 because it allows for importing games directly from the Higan menu.
Comment 7 Nathan Zachary gentoo-dev 2016-07-12 17:44:51 UTC
It should also be noted that the binary name changed from 'higan-balanced' to just 'higan'.
Comment 8 Patrick McMunn 2016-07-13 00:08:35 UTC
I can verify that emerging gtksourceview:2.0 fixes the compile error regarding cairo for me as well.

Higan, at least v099, also needs media-libs/libcanberra[gtk] as a runtime dependency. Otherwise, it emits the error message "Gtk-Message: Failed to load module "canberra-gtk-module"" when you run Higan. the gtk3 use flag doesn't meet the requirements since it uses gtk2.

So both of these dependencies need to be added to the Higan ebuild.
Comment 9 Nathan Zachary gentoo-dev 2016-07-18 18:41:15 UTC
Since the source package is 7z, it also requires p7zip.  That should also be added to the ebuild.
Comment 10 Oleh 2016-08-27 16:51:53 UTC
all of mentioned fixes are good, why there is a delay in getting ebuild fixed?
Comment 11 Coacher 2017-01-26 12:31:58 UTC
higan-102 is out: https://gitlab.com/higan/higan/tags/v102
Comment 12 Nathan Zachary gentoo-dev 2017-01-26 16:47:07 UTC
Looks like 099 is the current version in the tree, but we should be going to 102 and addressing build issues there.  Is anyone currently maintaining this package in-tree?
Comment 13 Nathan Zachary gentoo-dev 2017-05-30 21:30:19 UTC
(In reply to Nathan Zachary from comment #12)
> Looks like 099 is the current version in the tree, but we should be going to
> 102 and addressing build issues there.  Is anyone currently maintaining this
> package in-tree?

4 months later and no response here regarding active maintainers for the package.
Any way that we can proxy-maintain for the time being?
Comment 14 Denis Dupeyron (RETIRED) gentoo-dev 2017-07-21 14:51:32 UTC
Here's an ebuild for higan-103:

https://github.com/Calchan/ebuilds/blob/master/games-emulation/higan/higan-103.ebuild
Comment 15 Nathan Zachary gentoo-dev 2017-07-21 15:26:58 UTC
(In reply to Denis Dupeyron from comment #14)
> Here's an ebuild for higan-103:
> 
> https://github.com/Calchan/ebuilds/blob/master/games-emulation/higan/higan-
> 103.ebuild

Denis, good sir, you are outstanding!  Hopefully we can get that into the tree at some point in the near future.
Comment 16 Nathan Zachary gentoo-dev 2017-11-28 19:28:48 UTC
Upstream is now at v106.  Is it safe to assume that we don't really have anyone officially maintaining Higan any longer?
Comment 17 Larry the Git Cow gentoo-dev 2018-01-21 12:36:03 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=436f7416de80817975bf5b7b6e06458d26404d68

commit 436f7416de80817975bf5b7b6e06458d26404d68
Author:     Sebastian Pipping <sping@gentoo.org>
AuthorDate: 2018-01-21 12:28:02 +0000
Commit:     Sebastian Pipping <sping@gentoo.org>
CommitDate: 2018-01-21 12:35:47 +0000

    games-emulation/higan: 106_p1
    
    Closes: https://bugs.gentoo.org/567980
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

 games-emulation/higan/Manifest                     |   1 +
 games-emulation/higan/files/higan-106_p1-QA.patch  | 117 ++++++++++++++++++
 .../files/higan-106_p1-header-locations.patch      |  24 ++++
 games-emulation/higan/files/higan-106_p1-wrapper   |   5 +
 games-emulation/higan/higan-106_p1.ebuild          | 134 +++++++++++++++++++++
 5 files changed, 281 insertions(+)