Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 567552 - dev-perl/Locale-gettext still not rebuilt during perl upgrade from 5.20 to 5.22
Summary: dev-perl/Locale-gettext still not rebuilt during perl upgrade from 5.20 to 5.22
Status: RESOLVED DUPLICATE of bug 463976
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-12-04 20:04 UTC by Toralf Förster
Modified: 2016-05-24 21:40 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
config.log (config.log,10.22 KB, text/plain)
2015-12-04 20:04 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,21.53 KB, text/plain)
2015-12-04 20:04 UTC, Toralf Förster
Details
environment (environment,73.42 KB, text/plain)
2015-12-04 20:04 UTC, Toralf Förster
Details
sys-apps:help2man-1.47.3:20151204-192113.log (sys-apps:help2man-1.47.3:20151204-192113.log,2.88 KB, text/plain)
2015-12-04 20:04 UTC, Toralf Förster
Details
/var/log/emerge.log (emerge.log,467.17 KB, text/plain)
2015-12-05 10:08 UTC, Toralf Förster
Details
info.txt (info.txt,5.97 KB, text/plain)
2015-12-20 17:49 UTC, Toralf Förster
Details
config.log (config.log,10.22 KB, text/plain)
2015-12-20 17:49 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,17.64 KB, text/plain)
2015-12-20 17:49 UTC, Toralf Förster
Details
environment (environment,73.46 KB, text/plain)
2015-12-20 17:49 UTC, Toralf Förster
Details
sys-apps:help2man-1.47.3:20151220-174026.log (sys-apps:help2man-1.47.3:20151220-174026.log,2.88 KB, text/plain)
2015-12-20 17:49 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2015-12-04 20:04:44 UTC
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for library containing dlsym... -ldl
checking for library containing bindtextdomain... none required
configure: error: perl module Locale::gettext required

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-apps/help2man-1.47.3/work/help2man-1.47.3/config.log
 * ERROR: sys-apps/help2man-1.47.3::gentoo failed (configure phase):
 *   econf failed


$ cat ./info.txt
  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-plasma-unstable_20151204-112628) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  Portage 2.2.20.1 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/plasma, gcc-4.9.3, glibc-2.22-r1, 4.1.7-hardened-r1 x86_64)
=================================================================
System uname: Linux-4.1.7-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164644 total,   1775720 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Fri, 04 Dec 2015 17:01:57 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.4.3::gentoo
dev-util/cmake:           3.4.1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.de.gentoo.org/gentoo-portage/
    priority: 1

local
    location: /usr/local/portage
    masters: gentoo
    priority: 2

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--deep --color=n --nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alsa amd64 avx avx2 berkdb bindist bluetooth branding btrfs bzip2 cairo cdda cdr cgi clang cli consolekit corefonts cracklib crypt cups cxx dbus declarative designer dri dts dvd dvdr emboss encode exif extraengine fam firefox flac fortran gdbm gif git glamor gnuplot gnutls gpg gpm gtk gudev gui hdf5 hpn iconv imlib ipv6 javascript javaxml jpeg kde kipi kvm lcms ldap libnotify libvirtd mad mmx mmxext mng modules mp3 mp4 mpeg multilib multitarget ncurses nls nptl nscd ogg opengl openmp openmpi pam pango pax_kernel pcre pdf phonon pkcs11 plasma png policykit ppds pyqt4 python qml qt3support qt4 qt5 readline scrypt sdl seccomp semantic-desktop session smartcard spell spice sql sqlite sqlite3 sse sse2 sse4 ssl startup-notification svg system-jpeg system-sqlite tcpd tiff tk truetype udev udisks unicode upower usb vorbis vpx widgets wxwidgets x264 xattr xcb xcomposite xinerama xml xmlreader xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2015-12-04 20:04:46 UTC
Created attachment 418572 [details]
config.log
Comment 2 Toralf Förster gentoo-dev 2015-12-04 20:04:49 UTC
Created attachment 418574 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2015-12-04 20:04:51 UTC
Created attachment 418576 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2015-12-04 20:04:53 UTC
Created attachment 418578 [details]
sys-apps:help2man-1.47.3:20151204-192113.log
Comment 5 Ben Kohler gentoo-dev 2015-12-04 20:10:59 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 6 Toralf Förster gentoo-dev 2015-12-04 20:31:26 UTC
(In reply to Ben Kohler from comment #5)
> 
> *** This bug has been marked as a duplicate of bug 41124 ***

I was told in IRC, that qperl-cleaner is no longer needed nowadays and all related issues should be raised.
Comment 7 Ben Kohler gentoo-dev 2015-12-04 20:36:18 UTC
Locale-gettext should have been auto-rebuilt in the same emerge run where perl was upgraded to 5.22 unless that emerge died before it had a chance (or you explicitly passed --ignore-built-slot-operator-deps=y).  There is probably room for improvement in how emerge handles this case, but it's not a bug in help2man.
Comment 8 Toralf Förster gentoo-dev 2015-12-05 10:08:00 UTC
Created attachment 418598 [details]
/var/log/emerge.log

(In reply to Ben Kohler from comment #7)
> Locale-gettext should have been auto-rebuilt in the same emerge run where
> perl was upgraded to 5.22 

Then we do have here a issue with perl or portage b/c that doesn't happened.
Comment 9 SpanKY gentoo-dev 2015-12-05 20:29:07 UTC
as Ben mentioned, has nothing to do with help2man.  all the perl modules belong to the perl team.
Comment 10 Andreas K. Hüttel gentoo-dev 2015-12-05 20:50:28 UTC
(In reply to SpanKY from comment #9)
> as Ben mentioned, has nothing to do with help2man.  all the perl modules
> belong to the perl team.

ugh... this should not happen. 

1) USE=nls is active, help2man depends on dev-perl/Locale-gettext (correct)
2) your emerge history shows nothing about Locale-gettext (bad)
3) your emerge history does not show help2man (would it be at the end?)
Comment 11 Toralf Förster gentoo-dev 2015-12-05 21:32:46 UTC
(In reply to Andreas K. Hüttel from comment #10)
> 3) your emerge history does not show help2man (would it be at the end?)
No, the history shows only the *made* installation/uninstallation - and therefore a failed package will neever appear (except it is an upgrade) - therefore I attached the plain emerge.log file too here to show that.
Comment 12 Toralf Förster gentoo-dev 2015-12-20 17:48:53 UTC
run today again into this at the tinderbox image amd64-desktop-unstable_20151220-114934 where I test the switch from gcc-4 to gcc-5 (by using emerge -e @world - will attach files asap.
Comment 13 Toralf Förster gentoo-dev 2015-12-20 17:49:19 UTC
Created attachment 419916 [details]
info.txt


  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-desktop-unstable_20151220-114934) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

  Portage 2.2.26 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.22-r1, 4.2.7-hardened x86_64)
Comment 14 Toralf Förster gentoo-dev 2015-12-20 17:49:22 UTC
Created attachment 419918 [details]
config.log
Comment 15 Toralf Förster gentoo-dev 2015-12-20 17:49:24 UTC
Created attachment 419920 [details]
emerge-history.txt
Comment 16 Toralf Förster gentoo-dev 2015-12-20 17:49:26 UTC
Created attachment 419922 [details]
environment
Comment 17 Toralf Förster gentoo-dev 2015-12-20 17:49:29 UTC
Created attachment 419924 [details]
sys-apps:help2man-1.47.3:20151220-174026.log
Comment 18 Andreas K. Hüttel gentoo-dev 2016-02-29 13:50:23 UTC

*** This bug has been marked as a duplicate of bug 463976 ***
Comment 19 Andreas K. Hüttel gentoo-dev 2016-05-24 21:39:31 UTC

*** This bug has been marked as a duplicate of bug 583674 ***
Comment 20 Andreas K. Hüttel gentoo-dev 2016-05-24 21:40:38 UTC

*** This bug has been marked as a duplicate of bug 463976 ***