Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 566698 - media-gfx/inkscape-0.91 fails with dev-libs/libsigc++-2.6.2
Summary: media-gfx/inkscape-0.91 fails with dev-libs/libsigc++-2.6.2
Status: RESOLVED DUPLICATE of bug 566318
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-24 07:37 UTC by Rémi Cardona
Modified: 2015-12-16 11:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
inkscape-0.91.ebuild.diff (inkscape-0.91.ebuild.diff,339 bytes, patch)
2015-11-24 07:48 UTC, Lars Wendler (Polynomial-C)
Details | Diff
Fix libsigc++-2.6 build failure (patch,475 bytes, patch)
2015-11-24 08:04 UTC, Rémi Cardona
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rémi Cardona gentoo-dev 2015-11-24 07:37:58 UTC
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/type_traits:35:0,
                 from /usr/include/sigc++-2.0/sigc++/visit_each.h:22,
                 from /usr/include/sigc++-2.0/sigc++/functors/slot.h:6,
                 from /usr/include/sigc++-2.0/sigc++/signal_base.h:27,
                 from /usr/include/sigc++-2.0/sigc++/signal.h:8,
                 from /usr/include/sigc++-2.0/sigc++/sigc++.h:86,
                 from /usr/include/glibmm-2.4/glibmm/threads.h:29,
                 from /usr/include/glibmm-2.4/glibmm.h:89,
                 from /usr/include/gtkmm-2.4/gtkmm/box.h:7,
                 from ui/widget/panel.h:24,
                 from main.cpp:33:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
 #error This file requires compiler and library support for the \
  ^

Repeated hundreds of times.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2015-11-24 07:48:20 UTC
Created attachment 417728 [details, diff]
inkscape-0.91.ebuild.diff

Possible fix...
Comment 2 Rémi Cardona gentoo-dev 2015-11-24 08:04:12 UTC
Created attachment 417730 [details, diff]
Fix libsigc++-2.6 build failure

This patch builds.

@Lars, I haven't tested your patch though.
Comment 3 Pacho Ramos gentoo-dev 2015-11-24 11:41:23 UTC

*** This bug has been marked as a duplicate of bug 566318 ***