Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 566350 - media-gfx/inkscape-0.91 fails at building with newer version of libsigc++ and c++11
Summary: media-gfx/inkscape-0.91 fails at building with newer version of libsigc++ and...
Status: RESOLVED DUPLICATE of bug 566318
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 566352 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-20 19:05 UTC by jorgicio
Modified: 2015-11-21 02:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The log that shows the problem (build-inkscape.log.gz,75.51 KB, application/gzip)
2015-11-20 19:06 UTC, jorgicio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jorgicio 2015-11-20 19:05:42 UTC
Hi! Since some packages upgraded, like libsigc++, pangomm, glibmm and cairomm, and also Popper upgraded, it forced me to recompile Inkscape. However, since then, build fails.

Here's the log.

Thanks.

Reproducible: Always
Comment 1 jorgicio 2015-11-20 19:06:58 UTC
Created attachment 417476 [details]
The log that shows the problem
Comment 2 Ben Kohler gentoo-dev 2015-11-20 19:13:46 UTC
most likely the same root cause as bug 565342
Comment 3 Ben Kohler gentoo-dev 2015-11-20 19:14:59 UTC
*** Bug 566352 has been marked as a duplicate of this bug. ***
Comment 4 jorgicio 2015-11-20 21:49:31 UTC
I found a workaround for that.

First, create a file in /etc/portage/env called cpp11.conf. Its content must be:

CFLAGS="${CFLAGS} -std=c++11"
CXXFLAGS="${CXXFLAGS} -std=c++11"

then, add this to a /etc/portage/package.env file:

media-gfx/inkscape cpp11.conf

Then, recompile Inkscape. It did the trick.
However, you must remember that c++11 support is sort of experimental. But it works.

You can do the same with gtkmm or *mm packages. Try it.
Comment 5 Mike Auty gentoo-dev 2015-11-21 02:50:58 UTC

*** This bug has been marked as a duplicate of bug 566318 ***