Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 566258 - portage behavior with installed packages removed from portage tree
Summary: portage behavior with installed packages removed from portage tree
Status: RESOLVED DUPLICATE of bug 472208
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-19 19:26 UTC by Lagu
Modified: 2015-11-22 19:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge -pc (emerge-pc.tar.xz,113.36 KB, application/x-xz)
2015-11-19 20:02 UTC, Lagu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lagu 2015-11-19 19:26:04 UTC
From: https://bugs.gentoo.org/show_bug.cgi?id=565980

Note, read the previous bug report can help to understand this.

hi, i have a little question of something like this before write a bug report, its with the portage system, think this like continues of the issue, when the foo-1.1 its removed it continues installed, but there if the package don't have a specification to be installed (any package say a specific version or slot, or is manually installed) portage don't update it (anymore) and don't remove it with depclean, ¿its correctly this function? because it feels like a ghost package.

graph ex. (in experience)

we have a vanilla-sources-4.2.5 slot 4.2.5 so

emerge vanilla-sources

now is installed with that package in world, all fine, then portage remove that slot and put the next version a vanilla-sources-4.2.6 slot 4.2.6 (the ebuild 4.2.5 don't exist now), and portage don't update vanilla-sources and don't is removed from depclean because that package satisfies the package of world, but it can't be updated for the slot differences.

Thx.
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2015-11-19 19:30:57 UTC
Most likely because you specified a specific version in package.{,accept_}keywords.

Please verify what you have in package.keywords and/or package.accept_keywords for sys-kernel/vanilla-sources.
Comment 2 Lagu 2015-11-19 19:36:24 UTC
the vanilla-sources its only an example, this happend with all packages when portage install a slot, and then the slot is removed from portage tree.
Comment 3 Lagu 2015-11-19 19:43:16 UTC
here other:

Keywords for sys-kernel/hardened-sources:
            |                                 | u          |  
            | a a   a         n   p r     s   | n          |  
            | l m   r h i m m i   p i s   p   | u s        | r
            | p d a m p a 6 i o p c s 3   a x | s l        | e
            | h 6 r 6 p 6 8 p s p 6 c 9 s r 8 | e o        | p
            | a 4 m 4 a 4 k s 2 c 4 v 0 h c 6 | d t        | o
------------+---------------------------------+------------+-------
[I]4.1.7-r1 | ~ + ~ o ~ ~ o o o ~ ~ o o o ~ + | o 4.1.7-r1 | gentoo
------------+---------------------------------+------------+-------
[I]4.2.5-r1 | o o o o o o o o o o o o o o o o | o 4.2.5-r1 | gentoo
------------+---------------------------------+------------+-------
[I]4.2.6-r3 | o o o o o o o o o o o o o o o o | o 4.2.6-r3 | gentoo
------------+---------------------------------+------------+-------
[I]4.2.6-r4 | ~ ~ ~ o ~ ~ o o o ~ ~ o o o ~ ~ | o 4.2.6-r4 | gentoo

4.2.5-r1 and 4.2.6-r3 was removed from portage tree, in this example are the 2 ghost packages, and the keywords:

kernel:=sys-kernel/hardened-sources-4.2* ~amd64
Comment 4 Brian Evans Gentoo Infrastructure gentoo-dev 2015-11-19 19:54:54 UTC
Please show the output of `emerge -pvc =sys-kernel/hardened-sources-4.2.5-r1` and `emerge -pc`.  (If the last one is large, please attach it instead of listing as a comment)
Comment 5 Lagu 2015-11-19 20:01:06 UTC
emerge -pvc =sys-kernel/hardened-sources-4.2.5-r1

Calculating dependencies... done!
>>> Calculating removal order...

>>> These are the packages that would be unmerged:

 sys-kernel/hardened-sources
    selected: 4.2.5-r1 
   protected: none 
     omitted: 4.1.7-r1 4.2.6-r3 4.2.6-r4 

All selected packages: =sys-kernel/hardened-sources-4.2.5-r1

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Packages installed:   2354
Packages in world:    156
Packages in system:   48
Required packages:    2353
Number to remove:     1
Comment 6 Lagu 2015-11-19 20:02:05 UTC
Created attachment 417378 [details]
emerge -pc
Comment 7 Lagu 2015-11-19 20:21:50 UTC
Tecnically portage most hold the packages when some package request that version or slot even if the ebuild was removed (in this case most be good idea do a warning), but in this example don't are requested D:
Comment 8 Zac Medico gentoo-dev 2015-11-22 19:10:15 UTC

*** This bug has been marked as a duplicate of bug 472208 ***