Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 565988 - net-p2p/rtorrent[xmlrpc] fails to build - attributes.h:54:2:error: #error "SysV or X/Open-compatible Curses header file required"
Summary: net-p2p/rtorrent[xmlrpc] fails to build - attributes.h:54:2:error: #error "Sy...
Status: RESOLVED DUPLICATE of bug 462788
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jason Zaman
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-16 22:00 UTC by deference
Modified: 2018-01-14 15:27 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
rotrrent build log (build-rtorrent.log,102.76 KB, text/plain)
2015-11-16 22:00 UTC, deference
Details
emergepqv (emergepqv-rtorrent.txt,205 bytes, text/plain)
2015-11-16 22:01 UTC, deference
Details
emerge --info (emergeinfo-G.txt,27.14 KB, text/plain)
2015-11-16 22:04 UTC, deference
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deference 2015-11-16 22:00:24 UTC
Created attachment 417156 [details]
rotrrent build log

The errors are mainly in canvas.h and canvas.cc .
Comment 1 deference 2015-11-16 22:01:28 UTC
Created attachment 417158 [details]
emergepqv
Comment 2 deference 2015-11-16 22:04:38 UTC
Created attachment 417162 [details]
emerge --info
Comment 3 Rafał Mużyło 2015-11-17 04:43:32 UTC
The very first error is "#error "SysV or X/Open-compatible Curses header file required"", which is at very least odd, as the dep is listed in the ebuild, but for some reason not detected by configure.

Attach config.log.
Comment 4 Rafał Mużyło 2015-11-17 04:48:38 UTC
> checking for C++11 support... no

This failure is a bit odd too - IIRC, gcc 4.9 should be OK.

Also, why are your C{XX}FLAGS empty ?
Comment 5 deference 2015-11-20 14:18:30 UTC
My CFLAGS are empty because I tested and found this error to not be due to my CFLAGS so I can report the bug with no CFLAGS and make your life a little easier.
Comment 6 Ben Kohler gentoo-dev 2017-08-17 14:53:19 UTC
Are you still able to reproduce this problem on 0.9.6?
Comment 7 Jason Zaman gentoo-dev 2018-01-14 15:27:37 UTC

*** This bug has been marked as a duplicate of bug 462788 ***