Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 565958 - kde-frameworks/solid request to make dependency on sys-fs/udisks:2 optional
Summary: kde-frameworks/solid request to make dependency on sys-fs/udisks:2 optional
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 591906 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-16 16:41 UTC by Alpha Bravo
Modified: 2016-08-24 13:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alpha Bravo 2015-11-16 16:41:03 UTC
Currently kde-frameworks/solid pulls in udisks and thus polkit etc. As I don't need the latter I'd like to be able to stay clear of it. My system (LXQt+kde-plasma/kwin) has been working as expected for the last few months with solid without udisks.

--- solid-5.16.0.ebuild
+++ 
@@ -10,15 +10,15 @@
 DESCRIPTION="Provider for platform independent hardware discovery, abstraction and management"
 LICENSE="LGPL-2.1+"
 KEYWORDS=" ~amd64 ~x86"
-IUSE="nls"
+IUSE="nls +udisks"
 
 RDEPEND="
        dev-qt/qtdbus:5
        dev-qt/qtdeclarative:5
        dev-qt/qtwidgets:5
        dev-qt/qtxml:5
-       sys-fs/udisks:2
        virtual/udev
+       udisks? ( sys-fs/udisks:2 )
 "
 DEPEND="${RDEPEND}
        nls? ( dev-qt/linguist-tools:5 )

Reproducible: Always
Comment 1 Michael Palimaka (kensington) gentoo-dev 2015-11-16 16:56:50 UTC
The problem is that the udisks backend is built unconditionally. While it certainly works fine without udisks in some cases, there's no telling what might break in others (upstream deliberately made it mandatory for this reason).
Comment 2 Johannes Huber gentoo-dev 2016-03-11 15:55:48 UTC
Please re-open this bug in the case that upstream provided a valid optional build switch.
Comment 3 Andreas Sturmlechner gentoo-dev 2016-08-24 13:36:30 UTC
*** Bug 591906 has been marked as a duplicate of this bug. ***