Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 565826 - media-gfx/exiv2-0.25-r2 stabilisation request
Summary: media-gfx/exiv2-0.25-r2 stabilisation request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks:
 
Reported: 2015-11-15 09:50 UTC by DrSlony
Modified: 2016-07-03 10:45 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2015-11-15 09:50:03 UTC
The version of exiv2 not keyworded ~amd64 in portage is 3 years old, please unkeyword 0.25.

Reproducible: Always
Comment 1 Jeff 2015-12-18 15:19:45 UTC
Request to remove "introspection" flag? Is it necessary?
Comment 2 Michael Palimaka (kensington) gentoo-dev 2015-12-18 15:45:19 UTC
(In reply to Jeff from comment #1)
> Request to remove "introspection" flag? Is it necessary?

Is it causing problems?
Comment 3 DrSlony 2016-01-08 10:05:02 UTC
It just keeps getting older.
Comment 4 Michael Palimaka (kensington) gentoo-dev 2016-01-13 14:48:37 UTC
-r2 was just added with some backported fixes, let's target that instead.
Comment 5 Stuart Longland 2016-02-06 09:54:35 UTC
Another reason for stabalisation, I found that exiv2-0.24-r1 kept failing with the same message:

iptceasy.cpp:5:27: fatal error: exiv2/exiv2.hpp: No such file or directory

whilst building the samples (even though USE had -examples).  I don't have the full log handy, but could unmerge exiv2 and try again if that was wanted.

Adding an entry to accept the ~amd64 keyword for media-gfx/exiv2-0.25-r2 worked however, that I could build (and without the parallel build issue that Hanno experienced in bug #572394).  So rather than filing a bug for the earlier version, I just vote that this package get stabalised.
Comment 6 DrSlony 2016-02-06 11:53:27 UTC
What can I do to speed this up?
Comment 7 Tobias Klausmann gentoo-dev 2016-02-09 16:03:10 UTC
Stable on alpha.
Comment 8 Agostino Sarubbo gentoo-dev 2016-02-13 15:37:24 UTC
amd64 stable
Comment 9 Agostino Sarubbo gentoo-dev 2016-02-14 10:17:55 UTC
x86 stable
Comment 10 Markus Meier gentoo-dev 2016-02-14 17:25:19 UTC
arm stable
Comment 11 Erik Quaeghebeur 2016-02-17 09:30:11 UTC
The stabilization of exiv2-25-r2 has caused some dependency issues, seemingly because not all packages that depend on it were properly adapted first (to the new subslot?).

See forum post https://forums.gentoo.org/viewtopic.php?p=7881406 and bug #574904 for example.

I guess the stabilization cannot be reversed now, even if it feels premature from the perspective of users having to deal with the breakage it causes. I suppose that checking all packages that depend on exiv2 should have been done before stabilization, so that activity's coordination (adding blockers here) is still within the purview of this bug.
Comment 12 Michael Palimaka (kensington) gentoo-dev 2016-02-17 11:29:50 UTC
(In reply to Erik Quaeghebeur from comment #11)
> The stabilization of exiv2-25-r2 has caused some dependency issues,
> seemingly because not all packages that depend on it were properly adapted
> first (to the new subslot?).
> 
> See forum post https://forums.gentoo.org/viewtopic.php?p=7881406 and bug
> #574904 for example.
> 
> I guess the stabilization cannot be reversed now, even if it feels premature
> from the perspective of users having to deal with the breakage it causes. I
> suppose that checking all packages that depend on exiv2 should have been
> done before stabilization, so that activity's coordination (adding blockers
> here) is still within the purview of this bug.

The subslot conflicts in that forum post appear to be some issue with portage and not specific to exiv2.
Comment 13 Agostino Sarubbo gentoo-dev 2016-03-16 11:52:26 UTC
ppc stable
Comment 14 Agostino Sarubbo gentoo-dev 2016-03-17 10:54:12 UTC
ppc64 stable
Comment 15 Agostino Sarubbo gentoo-dev 2016-03-19 12:16:50 UTC
sparc stable
Comment 16 Agostino Sarubbo gentoo-dev 2016-03-20 11:56:27 UTC
ia64 stable
Comment 17 Michael Palimaka (kensington) gentoo-dev 2016-06-02 15:12:34 UTC
@hppa, it looks like the only stable revdep is media-gfx/ufraw so I wonder if there's still interest in having this package stable on your arch?
Comment 18 Jeroen Roovers gentoo-dev 2016-07-03 10:45:51 UTC
Stable for HPPA. Closing.