Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 565710 - autogenerated Manifest files have wrong digest for sys-apps/busybox ebuilds
Summary: autogenerated Manifest files have wrong digest for sys-apps/busybox ebuilds
Status: RESOLVED DUPLICATE of bug 565694
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: CVS/SVN/Git (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Infrastructure
URL:
Whiteboard:
Keywords:
: 565722 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-13 20:13 UTC by Lagu
Modified: 2015-11-16 11:43 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge,21.96 KB, text/plain)
2015-11-13 20:13 UTC, Lagu
Details
Manifest for comment 21 (Manifest,18.83 KB, text/plain)
2015-11-15 14:18 UTC, Sven Schwyn (svoop)
Details
busybox manifest still failing (busybox_manifest_fail,20.24 KB, text/plain)
2015-11-15 19:31 UTC, Ooblick
Details
busybox fail (busybox-1.24.1.fail,20.71 KB, text/plain)
2015-11-15 22:57 UTC, jms
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lagu 2015-11-13 20:13:10 UTC
Hi, here logs and more logs:

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-9999.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8493
!!! Expected: 8580

Cya.
Comment 1 Lagu 2015-11-13 20:13:46 UTC
Created attachment 416872 [details]
emerge --info
Comment 2 Daniel 2015-11-13 20:32:26 UTC
Same here.
Comment 3 Andreas Prieß 2015-11-13 21:18:04 UTC
And now another version of the ebuild fails:

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-1.24.1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8577
!!! Expected: 8579

Hmm, I just wonder why emerge fails for the checksum of an ebuild, that is not going to be merged in the failing version...? Security reasons I guess.
Comment 4 Ben Kohler gentoo-dev 2015-11-13 21:51:28 UTC
This is the same as bug 565694, one user there is reporting it's recently fixed... can you guys try this in another hour or so (sync & try again) and we can either close the bug as fixed or reopen that other one?

Thanks
Comment 5 Lagu 2015-11-13 22:00:03 UTC
mm, i think we use this https://bugs.gentoo.org/show_bug.cgi?id=565694 for the 9999 ebuild, and this bug report for the 1.24.1.

and i'm interested in this comment.

(In reply to Andreas Prieß from comment #3)
> And now another version of the ebuild fails:
> 
> !!! Digest verification failed:
> !!! /usr/portage/sys-apps/busybox/busybox-1.24.1.ebuild
> !!! Reason: Filesize does not match recorded size
> !!! Got: 8577
> !!! Expected: 8579
> 
> Hmm, I just wonder why emerge fails for the checksum of an ebuild, that is
> not going to be merged in the failing version...? Security reasons I guess.
Comment 6 Ben Kohler gentoo-dev 2015-11-13 22:02:18 UTC
It's the same issue.  The manifest for the ebuild files is actually generated when the tree is exported from git to rsync mirrors, something is going wrong with that (automated) process.  There is no human hand involved in that part, so it's not just that the maintainer forgot to update the manifest.
Comment 7 Ben Kohler gentoo-dev 2015-11-13 22:25:54 UTC
I have tried to reproduce this on an up to date rsync tree and the issue seems solved from what I can see.  Does anyone have a tree equal to or newer than..

#cat /usr/portage/metadata/timestamp.chk
Fri, 13 Nov 2015 22:00:01 +0000
#

..which still has the problem?
Comment 8 Ben Kohler gentoo-dev 2015-11-13 22:26:08 UTC
*** Bug 565722 has been marked as a duplicate of this bug. ***
Comment 9 Lagu 2015-11-14 03:28:36 UTC
mm, the other post say its fixed but i still have the error (emaint sync -A)...
Comment 10 Daniel 2015-11-14 08:27:56 UTC
I also still have the issue, also removed busybox from the tree and tried resyning but did not help.

# emerge -auDN system

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-apps/busybox-1.23.1-r1  USE="-pam*" 

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-9999.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8493
!!! Expected: 8580
ironman ~ # cat /usr/portage/metadata/timestamp.chk
Sat, 14 Nov 2015 08:00:01 +0000
Comment 11 jms 2015-11-14 08:33:39 UTC
still has pb
sys-apps/busybox-1.23.1-r1::gentoo

!!! Digest verification failed:
!!! /portage/sys-apps/busybox/busybox-9999.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8493
!!! Expected: 8580


cat /portage/metadata/timestamp.chk
Sat, 14 Nov 2015 07:45:01 +0000
Comment 12 Nikos Chantziaras 2015-11-14 11:26:11 UTC
Or, there IS something fishy going on. busybox would be a prime target to compromise.
Comment 13 Giorgian Borca-Tasciuc 2015-11-14 14:07:20 UTC
I can confirm this problem...I've also tried deleting my whole portage tree, doing emerge-webrsync, and emerge --sync, and it is still telling me digest verification is failing..
Comment 14 Josh Holmer 2015-11-14 16:05:44 UTC
Still happening here, just ran emerge --sync about 3 minutes ago.

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-1.24.1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8577
!!! Expected: 8579
Comment 15 jospezial 2015-11-14 16:31:03 UTC
duplicate of https://bugs.gentoo.org/show_bug.cgi?id=565694

?
Comment 16 ciaran 2015-11-14 20:02:22 UTC
livecd / # emerge =sys-apps/busybox-1.23.2

 * IMPORTANT: 15 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-1.24.1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8577
!!! Expected: 8579
Comment 17 Notis 2015-11-14 20:09:01 UTC
Just tried too, still have the same problem.

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-1.24.1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8577
!!! Expected: 8579
Comment 18 jms 2015-11-15 00:28:38 UTC
could be this?
Bug 565574 - ChangeLogs are not included in Manifest (digest verification fails)
Comment 19 SpanKY gentoo-dev 2015-11-15 01:17:56 UTC
base-system doesn't maintain the busybox package, but that is irrelevant here.  Manifest files are automatically generated by infra scripts wrt ebuilds.
Comment 20 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2015-11-15 03:07:28 UTC
please sync and re-confirm; I have added a further pass to validate all manifests in the tree before it goes out to the mirror fetch directory.

If you do get the problem still:
please attach/paste:
1. metadata/timestamp*
2. Manifest for the failing package
3. ls -lad on the failing directory
4. local checksums on the failing file

P.S.
You can run 'repoman manifest-check' at the toplevel $PORTDIR to check the entire tree locally, and see that everything is good.

*** This bug has been marked as a duplicate of bug 565694 ***
Comment 21 Sven Schwyn (svoop) 2015-11-15 14:17:22 UTC
Still failing here:

1)
Sun, 15 Nov 2015 13:45:01 +0000

2)
see attachment

3)
drwxr-xr-x 3 root root 4096 Nov 14 06:46 busybox/

4)
bafd909df6e48604f3b45978b03c2a130df9a111ebc9a21591d8356489018c09  busybox-1.21.0.ebuild
e7ec5e23cf020fd23a0c9776300b0f0d5806f8805fe837ce23a82ee48264b179  busybox-1.23.1.ebuild
a707b3617b5d29e272b61a086818dccf79c0c558bd8add293d3f07b3786e08f6  busybox-1.23.1-r1.ebuild
136860133f561919db31470600bf258e46f5b7ad41a278949f232936511ccad3  busybox-1.23.2.ebuild
31eaac028521cc6bd5f2b1e65cbc49a46d1e1bb1de5a0bcb52e5f110380ce66d  busybox-1.24.1.ebuild
c63a8a1e692e3db32065b7b6ea8a295815e7f18a8bc8d61467b317d2ba3ad8ce  busybox-9999.ebuild

Checksums match for busybox-1.21.0.ebuild and busybox-1.23.2.ebuild, but differ for all other.
Comment 22 Sven Schwyn (svoop) 2015-11-15 14:18:13 UTC
Created attachment 417016 [details]
Manifest for comment 21
Comment 23 Ooblick 2015-11-15 19:31:54 UTC
Created attachment 417038 [details]
busybox manifest still failing

This has been failing here all day. Attached is the responses to the questions above.
Comment 24 jms 2015-11-15 22:57:00 UTC
Created attachment 417048 [details]
busybox fail
Comment 25 jms 2015-11-15 23:00:14 UTC
(In reply to Robin Johnson from comment #20)
still pb...

repoman -p manifest-check

RepoMan does a once-over of the neighborhood...

!!! Digest verification failed:
!!! /portage/sys-apps/busybox/busybox-1.24.1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8577
!!! Expected: 8579
  manifest.bad [fatal]          1
   sys-apps/busybox/Manifest
Please fix these important QA issues first.
RepoMan sez: "Make your QA payment on time and you'll never see the likes of me."

Sun, 15 Nov 2015 22:15:01 +0000

see attachment  Attachment 417048 [details]
Comment 26 Alex Weiss 2015-11-16 08:20:09 UTC
I'm having the same problem. It's been going on for a few days now.

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-1.24.1.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8577
!!! Expected: 8579

timestamp.chk:
Mon, 16 Nov 2015 08:00:01 +0000

ls -lad:
drwxr-xr-x 3 portage portage 4096 Nov 16 08:12 .

repoman results:
RepoMan does a once-over of the neighborhood...

!!! Digest verification failed:
!!! /usr/portage/sys-apps/busybox/busybox-9999.ebuild
!!! Reason: Filesize does not match recorded size
!!! Got: 8493
!!! Expected: 8580
  manifest.bad [fatal]          1
   sys-apps/busybox/Manifest
Please fix these important QA issues first.
RepoMan sez: "Make your QA payment on time and you'll never see the likes of me."
Comment 27 jms 2015-11-16 11:43:37 UTC
yes!

cat metadata/timestamp
Mon Nov 16 09:48:20 UTC 2015

repoman -p manifest-check

RepoMan does a once-over of the neighborhood...
Note: type "repoman full" for a complete listing.
RepoMan sez: "If everyone were like you, I'd be out of business!"

emerge -fvuND @world
                                                                                              
These are the packages that would be fetched, in order:                                       
                                                                                              
Calculating dependencies... done!                                                             
[ebuild   R    ] sys-apps/busybox-1.23.1-r1::gentoo  USE="ipv6 static syslog -debug -livecd -make-symlinks -math -mdev -pam* -savedconfig (-selinux) -sep-usr -systemd" 0 KiB               
                                                                                              
Total: 1 package (1 reinstall), Size of downloads: 0 KiB                                      
                                                                                              
                                                                                              
>>> Fetching (1 of 1) sys-apps/busybox-1.23.1-r1::gentoo                                      
 * busybox-1.23.1.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...                         [ ok ]