Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 565574 - ChangeLogs are not included in Manifest (digest verification fails)
Summary: ChangeLogs are not included in Manifest (digest verification fails)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Infrastructure
Classification: Unclassified
Component: CVS/SVN/Git (show other bugs)
Hardware: All Linux
: Highest blocker (vote)
Assignee: Gentoo Infrastructure
URL:
Whiteboard:
Keywords:
: 565604 565610 565620 565622 (view as bug list)
Depends on: 565626
Blocks:
  Show dependency tree
 
Reported: 2015-11-12 07:43 UTC by Patrick Lauer
Modified: 2015-11-15 03:04 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2015-11-12 07:43:51 UTC
# grep "ChangeLog "  app-shells/*/Manifest -R
#

So none of the Manifests include the ChangeLogs.
Comment 1 Kristian Fiskerstrand (RETIRED) gentoo-dev 2015-11-12 14:53:50 UTC
To the extent it is related, a user reports

!!! Digest verification failed:
!!! /usr/portage/dev-libs/libxml2/ChangeLog
!!! Reason: Filesize does not match recorded size
!!! Got: 5038
!!! Expected: 4685

in bug 560524 comment 9
Comment 2 Michael Palimaka (kensington) gentoo-dev 2015-11-12 16:16:40 UTC
*** Bug 565610 has been marked as a duplicate of this bug. ***
Comment 3 Michael Palimaka (kensington) gentoo-dev 2015-11-12 16:17:26 UTC
*** Bug 565604 has been marked as a duplicate of this bug. ***
Comment 4 Alex Barker 2015-11-12 16:36:25 UTC
Would it be possible to add something about the digest verification failing to the description so others know this bug is related?
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2015-11-12 17:57:15 UTC
*** Bug 565620 has been marked as a duplicate of this bug. ***
Comment 6 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2015-11-12 18:22:27 UTC
portage-dev:
egencache's update_manifests runs BEFORE update_changeslogs, so if the ChangeLog is updated, the Manifest is WRONG.

I've put a workaround in place, to force regen of the Manifests after this, and opened bug 565626 to get egencache fixed properly.
Comment 7 Michael Palimaka (kensington) gentoo-dev 2015-11-12 18:30:34 UTC
*** Bug 565622 has been marked as a duplicate of this bug. ***
Comment 8 jms 2015-11-15 00:29:18 UTC
Bug 565710 - sys-apps/busybox - digest varification failed 
duplicate?
Comment 9 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2015-11-15 03:04:19 UTC
This is fixed in the copy of portage, people need to sync more and confirm