Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 565562 - dev-python/dulwich implicit declaration of PyString functions under python3
Summary: dev-python/dulwich implicit declaration of PyString functions under python3
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-12 05:19 UTC by Mike Gilbert
Modified: 2017-10-30 10:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Gilbert gentoo-dev 2015-11-12 05:19:35 UTC
* Messages for package dev-python/dulwich-0.11.2:

 * QA Notice: Package triggers severe warnings which indicate that it
 *            may exhibit random runtime failures.
 * dulwich/_objects.c:52:9: warning: implicit declaration of function ‘PyString_FromStringAndSize’ [-Wimplicit-function-declaration]
 * dulwich/_objects.c:191:8: warning: implicit declaration of function ‘PyString_Check’ [-Wimplicit-function-declaration]
 * dulwich/_objects.c:202:8: warning: implicit declaration of function ‘PyInt_Check’ [-Wimplicit-function-declaration]
 * dulwich/_objects.c:212:27: warning: implicit declaration of function ‘PyString_AS_STRING’ [-Wimplicit-function-declaration]
 * dulwich/_objects.c:213:27: warning: implicit declaration of function ‘PyInt_AsLong’ [-Wimplicit-function-declaration]
 * dulwich/_objects.c:256:6: warning: implicit declaration of function ‘Py_InitModule3’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:27:7: warning: implicit declaration of function ‘PyString_CheckExact’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:30:6: warning: implicit declaration of function ‘PyString_Size’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:55:19: warning: implicit declaration of function ‘PyString_FromString’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:60:12: warning: implicit declaration of function ‘_PyString_Join’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:66:13: warning: implicit declaration of function ‘PyString_Check’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:99:23: warning: implicit declaration of function ‘PyString_AS_STRING’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:100:16: warning: implicit declaration of function ‘PyString_GET_SIZE’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:115:8: warning: implicit declaration of function ‘PyString_FromStringAndSize’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:122:19: warning: implicit declaration of function ‘PyString_AsString’ [-Wimplicit-function-declaration]
 * dulwich/_pack.c:229:11: warning: implicit declaration of function ‘PyInt_FromLong’ [-Wimplicit-function-declaration]
Comment 1 Mike Gilbert gentoo-dev 2015-11-12 05:24:04 UTC
I think the extension modules have not been ported to python3. We should consider dropping python3_4 from PYTHON_COMPAT here.
Comment 2 Fabian Groffen gentoo-dev 2017-10-30 10:22:21 UTC
is this still an issue? 0.11.2 isn't in the tree anymore.