Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 565342 - dev-cpp/gtkmm-2.24.4-r2 - -std=c++11 required
Summary: dev-cpp/gtkmm-2.24.4-r2 - -std=c++11 required
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: GNOME C++ Bindings Maintainers (OBSOLETE)
URL: https://git.gnome.org/browse/gtkmm/co...
Whiteboard:
Keywords:
: 566780 (view as bug list)
Depends on:
Blocks: libsigc++-2.6
  Show dependency tree
 
Reported: 2015-11-10 08:29 UTC by tman
Modified: 2015-12-06 21:57 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/mnt/portage/logs/dev-cpp:gtkmm-2.24.4-r2:20151110-082709.log (dev-cpp:gtkmm-2.24.4-r2:20151110-082709.log.tar.gz,552.49 KB, application/gzip)
2015-11-10 08:32 UTC, tman
Details
log (dev-cpp:gtkmm-2.24.4-r2:20151110-145053.log.tar.gz,550.03 KB, application/gzip)
2015-11-10 14:55 UTC, tman
Details
Temporary solution (file_565342.txt,123 bytes, text/plain)
2015-11-25 09:47 UTC, Rinaldus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tman 2015-11-10 08:29:37 UTC
^
/usr/include/glibmm-2.4/glibmm/refptr.h:101:19: warning: inline function ‘Glib::RefPtr<T_CppObject>::RefPtr(T_CppObject*) [with T_CppObject = Gdk::DragContext]’ used but never defined
   explicit inline RefPtr(T_CppObject* pCppObject) noexcept;
                   ^
/usr/include/glibmm-2.4/glibmm/refptr.h:98:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::~RefPtr() [with T_CppObject = Gdk::DragContext]’ used but never defined
   inline ~RefPtr() noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:107:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::RefPtr(const Glib::RefPtr<T_CppObject>&) [with T_CppObject = Gdk::DragContext]’ used but never defined
   inline RefPtr(const RefPtr& src) noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:107:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::RefPtr(const Glib::RefPtr<T_CppObject>&) [with T_CppObject = Gdk::Window]’ used but never defined
/usr/include/glibmm-2.4/glibmm/refptr.h:170:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::operator bool() const [with T_CppObject = Gdk::Window]’ used but never defined
   inline operator bool() const noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:160:23: warning: inline function ‘T_CppObject* Glib::RefPtr<T_CppObject>::operator->() const [with T_CppObject = Glib::ByteArray]’ used but never defined
   inline T_CppObject* operator->() const noexcept;
                       ^
/usr/include/glibmm-2.4/glibmm/refptr.h:170:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::operator bool() const [with T_CppObject = Glib::ByteArray]’ used but never defined
   inline operator bool() const noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:160:23: warning: inline function ‘T_CppObject* Glib::RefPtr<T_CppObject>::operator->() const [with T_CppObject = Pango::LayoutLine]’ used but never defined
   inline T_CppObject* operator->() const noexcept;
                       ^
/usr/include/glibmm-2.4/glibmm/refptr.h:170:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::operator bool() const [with T_CppObject = Pango::LayoutLine]’ used but never defined
   inline operator bool() const noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:160:23: warning: inline function ‘T_CppObject* Glib::RefPtr<T_CppObject>::operator->() const [with T_CppObject = Gdk::Colormap]’ used but never defined
   inline T_CppObject* operator->() const noexcept;
                       ^
/usr/include/glibmm-2.4/glibmm/refptr.h:170:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::operator bool() const [with T_CppObject = Gdk::Colormap]’ used but never defined
   inline operator bool() const noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:160:23: warning: inline function ‘T_CppObject* Glib::RefPtr<T_CppObject>::operator->() const [with T_CppObject = Gdk::Pixmap]’ used but never defined
   inline T_CppObject* operator->() const noexcept;
                       ^
/usr/include/glibmm-2.4/glibmm/refptr.h:170:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::operator bool() const [with T_CppObject = Gdk::Pixmap]’ used but never defined
   inline operator bool() const noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:160:23: warning: inline function ‘T_CppObject* Glib::RefPtr<T_CppObject>::operator->() const [with T_CppObject = Gdk::Bitmap]’ used but never defined
   inline T_CppObject* operator->() const noexcept;
                       ^
/usr/include/glibmm-2.4/glibmm/refptr.h:170:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::operator bool() const [with T_CppObject = Gdk::Bitmap]’ used but never defined
   inline operator bool() const noexcept;
          ^
/usr/include/glibmm-2.4/glibmm/refptr.h:160:23: warning: inline function ‘T_CppObject* Glib::RefPtr<T_CppObject>::operator->() const [with T_CppObject = Gdk::Pixbuf]’ used but never defined
   inline T_CppObject* operator->() const noexcept;
                       ^
/usr/include/glibmm-2.4/glibmm/refptr.h:170:10: warning: inline function ‘Glib::RefPtr<T_CppObject>::operator bool() const [with T_CppObject = Gdk::Pixbuf]’ used but never defined
   inline operator bool() const noexcept;
          ^
/var/tmp/portage/dev-cpp/gtkmm-2.24.4-r2/work/gtkmm-2.24.4/gdk/gdkmm/dragcontext.cc: In member function ‘Glib::RefPtr<const Gdk::Window> Gdk::DragContext::get_source_window() const’:
/var/tmp/portage/dev-cpp/gtkmm-2.24.4-r2/work/gtkmm-2.24.4/gdk/gdkmm/dragcontext.cc:248:1: warning: control reaches end of non-void function [-Wreturn-type]
 }
 ^
Makefile:528: recipe for target 'dragcontext.lo' failed
make[2]: *** [dragcontext.lo] Error 1
make[2]: Leaving directory '/var/tmp/portage/dev-cpp/gtkmm-2.24.4-r2/work/gtkmm-2.24.4-abi_x86_32.x86/gdk/gdkmm'
Makefile:682: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-cpp/gtkmm-2.24.4-r2/work/gtkmm-2.24.4-abi_x86_32.x86'
Makefile:467: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: dev-cpp/gtkmm-2.24.4-r2::gentoo failed (compile phase):


Reproducible: Always




Portage 2.2.24 (python 3.5.0-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.22-r1, 4.3.0-gentoo x86_64)
=================================================================
System uname: Linux-4.3.0-gentoo-x86_64-Intel-R-_Core-TM-_i7-3740QM_CPU_@_2.70GHz-with-gentoo-2.2
KiB Mem:    24627044 total,  20008568 free
KiB Swap:   26488828 total,  26488828 free
Timestamp of repository gentoo: Tue, 10 Nov 2015 07:00:01 +0000
Timestamp of repository poly-c: Mon, 09 Nov 2015 15:58:16 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10-r2::gentoo, 3.4.3-r2::gentoo, 3.5.0-r1::gentoo
dev-util/cmake:           3.4.0_rc3::poly-c
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.3::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /mnt/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

bumblebee
    location: /mnt/portage/local/layman/bumblebee
    masters: gentoo
    priority: 0

dotnet
    location: /mnt/portage/local/layman/dotnet
    masters: gentoo
    priority: 1

steam-overlay
    location: /mnt/portage/local/layman/steam-overlay
    masters: gentoo
    priority: 2

media-overlay
    location: /mnt/portage/local/layman/media-overlay
    masters: gentoo
    priority: 3

dr
    location: /mnt/portage/local/layman/dr
    masters: gentoo
    priority: 4

brother-overlay
    location: /mnt/portage/local/layman/brother-overlay
    masters: gentoo
    priority: 5

bitcoin
    location: /mnt/portage/local/layman/bitcoin
    masters: gentoo
    priority: 6

poly-c
    location: /mnt/portage/local/layman/poly-c
    masters: gentoo
    priority: 7

lokal
    location: /mnt/portage/local/local-overlay
    masters: gentoo
    priority: 8

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -O2 -pipe"
DISTDIR="/mnt/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks fail-clean fixlafiles merge-sync news nodoc noinfo parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="C"
LC_ALL=""
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
Comment 1 tman 2015-11-10 08:32:20 UTC
Created attachment 416520 [details]
/mnt/portage/logs/dev-cpp:gtkmm-2.24.4-r2:20151110-082709.log
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2015-11-10 13:42:53 UTC
You list a bunch of warnings, but not the first error:

In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/type_traits:35:0,
                 from /usr/include/sigc++-2.0/sigc++/visit_each.h:22,
                 from /usr/include/sigc++-2.0/sigc++/functors/slot.h:6,
                 from /usr/include/sigc++-2.0/sigc++/signal_base.h:27,
                 from /usr/include/sigc++-2.0/sigc++/signal.h:8,
                 from /usr/include/sigc++-2.0/sigc++/sigc++.h:86,
                 from /usr/include/glibmm-2.4/glibmm/thread.h:51,
                 from /usr/include/glibmm-2.4/glibmm.h:87,
                 from /var/tmp/portage/dev-cpp/gtkmm-2.24.4-r2/work/gtkmm-2.24.4/gdk/gdkmm/cursor.h:7,
                 from /var/tmp/portage/dev-cpp/gtkmm-2.24.4-r2/work/gtkmm-2.24.4/gdk/gdkmm/cursor.cc:4:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support is currently experimental, and must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
 #error This file requires compiler and library support for the \
Comment 3 tman 2015-11-10 14:55:56 UTC
Created attachment 416618 [details]
log

here is the log
Comment 4 temporalabstraction 2015-11-20 15:59:49 UTC
This bug also affected me. Letting it compile with -std=c++11 within package.env made it compile without issues.
Comment 5 Kobboi 2015-11-23 06:41:56 UTC
Same here, a lot of similar issues, e.g. bug 566318, media-gfx/inkscape-0.91 - multiple error after libsigc++-2.6.2 and glibmm-2.46.1 upgrade
Comment 6 Pacho Ramos gentoo-dev 2015-11-25 09:29:10 UTC
*** Bug 566780 has been marked as a duplicate of this bug. ***
Comment 7 Rinaldus 2015-11-25 09:47:56 UTC
Created attachment 417822 [details]
Temporary solution

I found temporary solution. gtkmm builds properly if you downgrade dev-libs/libsigc++ dev-cpp/glibmm dev-cpp/pangomm dev-cpp/cairomm dev-cpp/atkmm to their stable versions. Use this solution only if you very need to build gtkmm. So unstable versions of these packages need to be reworked.
Comment 8 Greg Turner 2015-11-29 08:53:39 UTC
mysql-workbench also affected -- there, the simple package.env work-around can't work due to code like:

src_vex() {
  strip-flags
  cmake_src_vex
}
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-12-06 21:57:40 UTC
I've added -std=c++11 in a revbump since this is a stable ebuild.

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=aae3ec3d3bd4b4f8dbb22a4b5e299252249a8ddf