Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 564762 - dev-util/coccinelle-1.0.4 fails to build
Summary: dev-util/coccinelle-1.0.4 fails to build
Status: RESOLVED DUPLICATE of bug 459512
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Tim Harder
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-11-03 09:17 UTC by Ralf Ramsauer
Modified: 2016-02-05 14:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,64.11 KB, text/plain)
2015-11-03 20:15 UTC, Ralf Ramsauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Ramsauer 2015-11-03 09:17:32 UTC
The (probably) last phase of the coccinelle build process fails linking with:

/usr/bin/ocamlc.opt -g  -I /usr/lib64/ocaml/menhirLib -I /usr/lib64/ocaml/parmap -I /usr/lib64/ocaml/pcre -I commons -I commons/ocamlextra -I ctl -I engine -I extra -I globals -I ocaml -I parsing_c -I parsing_cocci -I popl09 -I python -custom -g    -ccopt -lpcre -dllib -lpcre_stubs -cclib -lpcre_stubs -ccopt -lpcre -dllib -lpcre_stubs -cclib -lpcre_stubs -cclib -lparmap_stubs -o spatch str.cma unix.cma bigarray.cma nums.cma /usr/lib64/ocaml/pcre/pcre.cma /usr/lib64/ocaml/parmap/parmap.cma commons/commons.cma globals/globals.cma ctl/ctl.cma parsing_cocci/cocci_parser.cma parsing_c/parsing_c.cma engine/cocciengine.cma popl09/popl.cma extra/extra.cma python/coccipython.cma ocaml/cocciocaml.cma flag_cocci.cmo cocci.cmo testing.cmo read_options.cmo main.cmo
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
(.text+0x62): undefined reference to `tgetent'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
(.text+0x7a): undefined reference to `tgetnum'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
(.text+0x8f): undefined reference to `tgetstr'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
(.text+0xa5): undefined reference to `tgetstr'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
(.text+0xbb): undefined reference to `tgetstr'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
(.text+0xd1): undefined reference to `tgetstr'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_setup':
(.text+0xf6): undefined reference to `tgetstr'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o):(.text+0x10c): more undefined references to `tgetstr' follow
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_backup':
(.text+0x19d): undefined reference to `tputs'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_standout':
(.text+0x1d7): undefined reference to `tputs'
/usr/lib64/ocaml/libcamlrun.a(terminfo.o): In function `caml_terminfo_resume':
(.text+0x20c): undefined reference to `tputs'
collect2: error: ld returned 1 exit status

Full build.log: http://paste.debian.net/320121/

Reproducible: Always

Steps to Reproduce:
1. emerge coccinelle
Actual Results:  
Build fails

Expected Results:  
Build succeeds

# emerge --info
Portage 2.2.23 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop/gnome/systemd, gcc-4.9.3, glibc-2.22-r1, 4.2.5-gentoo x86_64)
=================================================================
System uname: Linux-4.2.5-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-2660_v3_@_2.60GHz-with-gentoo-2.2
KiB Mem:     6114904 total,    881972 free
KiB Swap:    4194300 total,   4176372 free
Timestamp of repository gentoo: Tue, 03 Nov 2015 08:30:01 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.3_p42::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10::gentoo, 3.4.3::gentoo, 3.5.0-r1::gentoo
dev-util/cmake:           3.3.2-r1::gentoo
dev-util/pkgconfig:       0.29::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.18.3::gentoo
sys-apps/sandbox:         2.9::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.22-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

crossdev
    location: /usr/local/portage
    masters: gentoo
    priority: 0

x11
    location: /var/lib/layman/x11
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=core-avx2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=core-avx2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl acpi alsa amd64 autotools berkdb bluetooth bluray branding bzip2 cairo cdda cddb cdr clang cli cmake colord cpudetection cracklib crypt cryptsetup cups curl cvs cxx dbus device-mapper dmraid dri dts dvd dvdr eds emboss encode evo exif fam fat firefox flac fluidsynth fortran fuse gdbm geoip gif git glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk3 hackrf hfs iconv introspection ipv6 jack jpeg lcms ldap libcaca libnotify libsecret mad mdadm mmx mmxext mng modules mount mp3 mp4 mpeg multilib nautilus ncurses networkmanager nfs nls nptl ntfs ogg opengl openmp pam pango pcre pdf png policykit postscript ppds pulseaudio qt3support qt4 readline rtlsdr scanner sdl seccomp session sftp sid spell sse sse2 ssl startup-notification svg systemd tcpd tiff tracker truetype udev udisks unicode upower usb v4l vdpau vim-syntax vorbis wxwidgets x264 x265 xattr xcb xinerama xml xv xvid zeroconf zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse synaptics elographics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="x86_64 arm aarch64" QEMU_USER_TARGETS="x86_64 arm aarch64" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="intel i915 i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Tomáš Mózes 2015-11-03 19:38:52 UTC
Would you mind attaching the full build log please?
Comment 2 Ralf Ramsauer 2015-11-03 20:15:49 UTC
Created attachment 416032 [details]
build log
Comment 3 Ralf Ramsauer 2015-11-03 20:16:27 UTC
(In reply to Tomas Mozes from comment #1)
> Would you mind attaching the full build log please?

Now also attached as an attachment.
Comment 4 Tim Harder gentoo-dev 2016-01-17 22:46:10 UTC
Don't forget to CC herds/projects when assigning bugs, especially since I wasn't the one to bump it this time.
Comment 5 Alexis Ballier gentoo-dev 2016-02-05 14:18:31 UTC
ncurses[tinfo] breaks everything written in ocaml I think :)

*** This bug has been marked as a duplicate of bug 459512 ***