Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 564580 - sys-devel/crossdev-20150716 : cross-armv7a-hardfloat-linux-gnueabi/gcc - gcc failed
Summary: sys-devel/crossdev-20150716 : cross-armv7a-hardfloat-linux-gnueabi/gcc - gcc ...
Status: RESOLVED DUPLICATE of bug 562460
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Embedded Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-10-31 17:02 UTC by Juergen Rose
Modified: 2015-11-10 15:27 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
cross-armv7a-hardfloat-linux-gnueabi-info.log (cross-armv7a-hardfloat-linux-gnueabi-info.log,27.58 KB, text/x-log)
2015-10-31 17:03 UTC, Juergen Rose
Details
cross-armv7a-hardfloat-linux-gnueabi-gcc-stage1.log.xz (cross-armv7a-hardfloat-linux-gnueabi-gcc-stage1.log.xz,39.60 KB, application/x-xz)
2015-10-31 17:05 UTC, Juergen Rose
Details
cross-armv7a-hardfloat-linux-gnueabi/gcc-4.9.3/temp/gcc-config.logs.tar.xz (gcc-config.logs.tar.xz,42.19 KB, application/x-xz)
2015-10-31 17:07 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2015-10-31 17:02:34 UTC
'crossdev -S -s4 -t armv7a-hardfloat-linux-gnueabi' fails with:
...
 * Log: /var/log/portage/cross-armv7a-hardfloat-linux-gnueabi-glibc-headers.log
 * Emerging cross-glibc-headers ...                                                                                                                       [ ok ]
 * Log: /var/log/portage/cross-armv7a-hardfloat-linux-gnueabi-gcc-stage1.log
 * Emerging cross-gcc-stage1 ...

 * gcc failed :(
 * If you file a bug, please attach the following logfiles:
 * /var/log/portage/cross-armv7a-hardfloat-linux-gnueabi-info.log
 * /var/log/portage/cross-armv7a-hardfloat-linux-gnueabi-gcc-stage1.log.xz
 * /var/tmp/portage/cross-armv7a-hardfloat-linux-gnueabi/gcc*/temp/gcc-config.logs.tar.xz


Reproducible: Always
Comment 1 Juergen Rose 2015-10-31 17:03:49 UTC
Created attachment 415816 [details]
cross-armv7a-hardfloat-linux-gnueabi-info.log
Comment 2 Juergen Rose 2015-10-31 17:05:05 UTC
Created attachment 415818 [details]
cross-armv7a-hardfloat-linux-gnueabi-gcc-stage1.log.xz
Comment 3 Juergen Rose 2015-10-31 17:07:14 UTC
Created attachment 415820 [details]
cross-armv7a-hardfloat-linux-gnueabi/gcc-4.9.3/temp/gcc-config.logs.tar.xz
Comment 4 Alexander Tsoy 2015-11-03 09:16:58 UTC
(In reply to Juergen Rose from comment #3)
> Created attachment 415820 [details]
> cross-armv7a-hardfloat-linux-gnueabi/gcc-4.9.3/temp/gcc-config.logs.tar.xz

This is most likely a dupe of bug #562460

configure:3389: /var/tmp/portage/cross-armv7a-hardfloat-linux-gnueabi/gcc-4.9.3/work/build/./gcc/xgcc -B/var/tmp/portage/cross-armv7a-hardfloat-linux-gnueabi
/gcc-4.9.3/work/build/./gcc/ -B/usr/armv7a-hardfloat-linux-gnueabi/bin/ -B/usr/armv7a-hardfloat-linux-gnueabi/lib/ -isystem /usr/armv7a-hardfloat-linux-gnuea
bi/include -isystem /usr/armv7a-hardfloat-linux-gnueabi/sys-include    -o conftest -g -O2 -pipe   conftest.c  >&5
Assembler messages:
Fatal error: selected target format 'elf32-littlearm' unknown
configure:3392: $? = 2
configure:3580: checking for suffix of object files
configure:3602: /var/tmp/portage/cross-armv7a-hardfloat-linux-gnueabi/gcc-4.9.3/work/build/./gcc/xgcc -B/var/tmp/portage/cross-armv7a-hardfloat-linux-gnueabi
/gcc-4.9.3/work/build/./gcc/ -B/usr/armv7a-hardfloat-linux-gnueabi/bin/ -B/usr/armv7a-hardfloat-linux-gnueabi/lib/ -isystem /usr/armv7a-hardfloat-linux-gnuea
bi/include -isystem /usr/armv7a-hardfloat-linux-gnueabi/sys-include    -c -g -O2 -pipe  conftest.c >&5
Assembler messages:
Fatal error: selected target format 'elf32-littlearm' unknown
configure:3606: $? = 2
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "GNU C Runtime Library"
| #define PACKAGE_TARNAME "libgcc"
| #define PACKAGE_VERSION "1.0"
| #define PACKAGE_STRING "GNU C Runtime Library 1.0"
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL "http://www.gnu.org/software/libgcc/"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:3620: error: in `/var/tmp/portage/cross-armv7a-hardfloat-linux-gnueabi/gcc-4.9.3/work/build/armv7a-hardfloat-linux-gnueabi/libgcc':
configure:3623: error: cannot compute suffix of object files: cannot compile
Comment 5 Priit Laes (IRC: plaes) 2015-11-03 16:38:10 UTC
(In reply to Alexander Tsoy from comment #4)
> (In reply to Juergen Rose from comment #3)
> > Created attachment 415820 [details]
> > cross-armv7a-hardfloat-linux-gnueabi/gcc-4.9.3/temp/gcc-config.logs.tar.xz
> 
> This is most likely a dupe of bug #562460

Yup, applied the patch from #562460 and things started working again.
Comment 6 Michael Palimaka (kensington) gentoo-dev 2015-11-10 15:27:57 UTC

*** This bug has been marked as a duplicate of bug 562460 ***