Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 56427 - dvdauthor core dumps
Summary: dvdauthor core dumps
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-07-08 01:59 UTC by Martin Mokrejš
Modified: 2005-04-22 07:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2004-07-08 01:59:10 UTC
I want to use dvdauthor to duplicate dvdrom, I use the following command:
dvdauthor -t -o Rakousko_dvd -f 'streamdvd -i /dev/dvd -t  -s , |'

Unfortuantely, it core dumps when looking for some files - missing:

<cut>
open("Rakousko_dvd/VIDEO_TS/VTS_01_0.IFO", O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = -1 ENOENT (No such file or directory)
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

The directory Rakousko_dvd/ exists, but is empty. It's caused by some other program failing so that's another problem, but I believe dvdauthor should crash.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Patrick Kursawe (RETIRED) gentoo-dev 2004-10-01 03:04:16 UTC
Could you please tell which version you tried?
Comment 2 Martin Mokrejš 2004-10-01 10:43:04 UTC
Sorry, the version is 0.5.0 and I can reproduce it still.
Comment 3 Martin Mokrejš 2005-02-25 05:29:05 UTC
This does not happen with latest dvdauthor-0.6.11.
Comment 4 Jan Brinkmann (RETIRED) gentoo-dev 2005-03-19 16:27:55 UTC
what about dvdauthor-0.6.10 ?
Comment 5 Chris White (RETIRED) gentoo-dev 2005-03-28 21:35:17 UTC
Resolving as FIXED then.
Comment 6 Martin Mokrejš 2005-04-08 14:07:42 UTC
Yes, it happens still.

# dvdauthor -t -o Rakousko_dvd -f 'streamdvd -i /dev/dvd -t  -s , |'
DVDAuthor::dvdauthor, version 0.6.10.
Build options: gnugetopt magick iconv freetype fribidi
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: dvdauthor creating VTS
STAT: Picking VTS 01

STAT: Processing streamdvd -i /dev/dvd -t  -s , |...
usage:  streamdvd -i device -t title [-c chapter|chapter range] [-s stream(s)] [-f factor] [-d level] [-v]
           device : dvd device or directory containing dvd structure
           title  : title number
           chapter: chapter number or range        (default: all chapter)
           streams: video/audio/subtitle stream(s) (default: all streams)
           factor : requantize factor              (default: 1)
           level  : debug level                    (default: 0)

  example:
        Use /dev/dvd to read chapter 3 out of title 1 with all video/audio/subtitle streams without requantizing
           streamdvd -i /dev/dvd -t 1 -c 3

        Use directory /mnt/movie to read complete title 2 with first video and audio stream, requantizing factor 1.5
           streamdvd -i /mnt/movie -t 2 -f 1.5 -s 0xe0,0x80

        Use /dev/dvd to read title 1, chapter 1 - 3, with first video, first 2 audio and first subtitle streams
           streamdvd -i /dev/dvd -t 1 -c 1-3 -s 0xe0,0x80,0x81,0x20

STAT: VOBU 0 at 0MB, 1 PGCS
Segmentation fault (core dumped)
#
Comment 7 Jan Brinkmann (RETIRED) gentoo-dev 2005-04-22 07:11:31 UTC
if 0.6.11 fixes this i'm marking it as upstream, since it was fixed by upstream