Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 563724 - media-video/nvidia-settings-358.09 - version bump
Summary: media-video/nvidia-settings-358.09 - version bump
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: ftp://download.nvidia.com/XFree86/nvi...
Whiteboard:
Keywords:
: 582488 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-10-21 20:46 UTC by Ștefan Talpalaru
Modified: 2017-01-12 16:37 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ștefan Talpalaru 2015-10-21 20:46:27 UTC
Renaming the 355.11-r2 ebuild and changing the nvidia-drivers dependency slot does the trick.

Reproducible: Always
Comment 1 Manfred Knick 2015-12-05 17:48:13 UTC
Now it's 358-16 :

ftp://download.nvidia.com/XFree86/nvidia-settings/nvidia-settings-358.16.tar.bz2
	1535 KB 	17.11.2015 	20:25:00
Comment 2 Ștefan Talpalaru 2016-01-29 02:46:39 UTC
nvidia-settings-361.18 is now available, and it depends on x11-drivers/nvidia-drivers:0/361
Comment 3 Stephan Litterst 2016-03-24 07:59:36 UTC
And another newer version:
ftp://download.nvidia.com/XFree86/nvidia-settings/nvidia-settings-364.12.tar.bz2
Comment 4 Adam Feldman gentoo-dev 2016-03-25 09:39:15 UTC
Personally, I don't see the point in the version bump.  We are already moving in the direction of dropping nvidia-settings as a standalone package #562910, so bumping a package that is effectively on its way out seems like a waste of effort.  Just my 2 cents.
Comment 5 Pacho Ramos gentoo-dev 2016-05-09 09:55:22 UTC
*** Bug 582488 has been marked as a duplicate of this bug. ***
Comment 6 Freddie Witherden 2016-05-09 13:13:29 UTC
The main reason at the moment for keeping nvidia-settings around as a standalone package is that it always installs libXNVCtrl.a whereas nvidia-drivers will only install libXNVCtrl.a if USE="static-libs".

Several packages, including sci-libs/vtk, depend on libXNVCtrl.a and only permit it to be provided through nvidia-settings.  Hence, when nvidia-settings is not bumped one gets into a sticky situation with regards to unresolved dependencies.
Comment 7 Jeroen Roovers gentoo-dev 2017-01-12 16:37:19 UTC
Please use x11-drivers/nvidia-drivers[tools] instead.