Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 562346 - x11-misc/obconf-2.0.4_p20150213 stabilisation (was: error when trying to change settings for "Desktop Pager" - triggered by lxde-base/lxpanel)
Summary: x11-misc/obconf-2.0.4_p20150213 stabilisation (was: error when trying to chan...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2021-06-14
Assignee: Johannes Huber
URL:
Whiteboard:
Keywords: CC-ARCHES, STABLEREQ
Depends on:
Blocks: EAPI5Removal gtk2-removal
  Show dependency tree
 
Reported: 2015-10-05 19:25 UTC by Raymond Jennings
Modified: 2021-06-14 09:18 UTC (History)
1 user (show)

See Also:
Package list:
x11-misc/obconf-2.0.4_p20150213
Runtime testing required: ---
nattka: sanity-check+


Attachments
screenshot of error message (oops.png,17.73 KB, image/png)
2015-10-05 19:26 UTC, Raymond Jennings
no flags Details
emerge --info (einfo.txt,5.39 KB, text/plain)
2015-10-05 19:26 UTC, Raymond Jennings
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Raymond Jennings 2015-10-05 19:25:38 UTC
I get an error.  See the screenshot.



Reproducible: Always

Steps to Reproduce:
1.  rm -rf ~/.themes
2.  right click on the desktop pager, select "Desktop Pager" settings

Actual Results:  
1.  Error message (see screenshot)
2.  ~/.themes now exists and is empty
3.  Repeating the operation doesn't do anything different

Expected Results:  
Access to the desktop pager settings.

lxde-base/lxpanel-0.7.0-r1
Comment 1 Raymond Jennings 2015-10-05 19:26:10 UTC
Created attachment 413844 [details]
screenshot of error message
Comment 2 Raymond Jennings 2015-10-05 19:26:37 UTC
Created attachment 413846 [details]
emerge --info
Comment 3 Jonas Stein gentoo-dev 2015-10-06 12:43:08 UTC
This looks like a bug in the upstream source code to me. If it is still present in the latest LXDE version, it should be reported to lxde.org.
Comment 5 Hanno Böck gentoo-dev 2016-09-22 06:14:14 UTC
According to comment #4 this is a bug in obconf, not lxpanel. Reassigning and changing title.

It seems upstream obconf hasn't done a new release since 2013. So either this fix should be backported or we should change to using git snapshots of obconf.
Comment 6 Raymond Jennings 2016-09-22 07:22:51 UTC
Are you sure its a segfault?

I just got nailed again and this came up in the error message box:

Unable to extract the file "6".
Please ensure that "/home/shentino/.themes" is writable and that the file is a valid Openbox theme archive.
The following errors were reported:
tar (child): 6: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now

Also, I'm doubting it was really a segfault because I can't find a core dump.
Comment 7 Andreas Sturmlechner gentoo-dev 2021-03-13 23:13:47 UTC
Maybe at this point a gtk3-based snapshot would be justified.
Comment 8 Andreas Sturmlechner gentoo-dev 2021-05-05 00:30:30 UTC
Please checkout the PR.
Comment 9 Andreas Sturmlechner gentoo-dev 2021-05-15 11:16:38 UTC
No volunteers for testing?
Comment 10 Andreas Sturmlechner gentoo-dev 2021-05-15 11:28:56 UTC
I've checked other downstreams, they either package p20150213-style version as well, add patches for libglade-- and gtk3++ or hide the last upstream commit behind a faux 2.0.4 version. That'll have to do then.
Comment 11 Larry the Git Cow gentoo-dev 2021-05-15 11:30:05 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=035486d139bc58d324d3493b840b4387f9f679b4

commit 035486d139bc58d324d3493b840b4387f9f679b4
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-03-27 08:42:08 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-05-15 11:23:47 +0000

    x11-misc/obconf: Add 2.0.4_p20150213 GTK3-based snapshot
    
    No release since 2013. No commit since 2015.
    
    Bug: https://bugs.gentoo.org/562346
    Package-Manager: Portage-3.0.17, Repoman-3.0.2
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 x11-misc/obconf/Manifest                      |  1 +
 x11-misc/obconf/obconf-2.0.4_p20150213.ebuild | 48 +++++++++++++++++++++++++++
 2 files changed, 49 insertions(+)
Comment 12 Sam James archtester gentoo-dev Security 2021-06-12 16:27:53 UTC
x86 done
Comment 13 Sam James archtester gentoo-dev Security 2021-06-12 16:28:22 UTC
amd64 done
Comment 14 Sam James archtester gentoo-dev Security 2021-06-12 16:29:59 UTC
ppc done
Comment 15 Sam James archtester gentoo-dev Security 2021-06-13 06:03:46 UTC
arm done
Comment 16 Sam James archtester gentoo-dev Security 2021-06-13 06:03:50 UTC
arm64 done
Comment 17 Agostino Sarubbo gentoo-dev 2021-06-13 06:30:49 UTC
sparc stable
Comment 18 Agostino Sarubbo gentoo-dev 2021-06-14 09:15:56 UTC
ppc64 stable. Closing.
Comment 19 Larry the Git Cow gentoo-dev 2021-06-14 09:18:22 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=791ef4dc33496a284608e0b3a9187f70cba37cb8

commit 791ef4dc33496a284608e0b3a9187f70cba37cb8
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-06-14 09:17:35 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-06-14 09:17:35 +0000

    x11-misc/obconf: Drop 2.0.4, EAPI5--
    
    Bug: https://bugs.gentoo.org/562346
    Package-Manager: Portage-3.0.20, Repoman-3.0.3
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 x11-misc/obconf/Manifest            |  1 -
 x11-misc/obconf/obconf-2.0.4.ebuild | 38 -------------------------------------
 2 files changed, 39 deletions(-)