Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 562200 - media-libs/libraw-0.17.0 with gcc-5.2.0 - internal/dcraw_common.cpp:25:15: internal compiler error: Aborted
Summary: media-libs/libraw-0.17.0 with gcc-5.2.0 - internal/dcraw_common.cpp:25:15: in...
Status: RESOLVED DUPLICATE of bug 560904
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-10-04 09:26 UTC by Markus Oehme
Modified: 2015-10-09 15:15 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.txt,6.23 KB, text/plain)
2015-10-04 09:26 UTC, Markus Oehme
Details
build log (libraw-0.17.0:20151004-083831.log,26.13 KB, text/plain)
2015-10-04 09:26 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2015-10-04 09:26:37 UTC
Created attachment 413660 [details]
emerge --info

On my hardened ~amd64 system with gcc-5.2.0 I see the following failure for libraw.

/var/tmp/portage/dev-libs/isl-0.15/work/isl-0.15/isl_constraint.c:627: expecting integer value
/var/tmp/portage/media-libs/libraw-0.17.0/work/LibRaw-0.17.0/internal/dcraw_common.cpp: In member function ‘void LibRaw::cielab(ushort*, short int*)’:
/var/tmp/portage/media-libs/libraw-0.17.0/work/LibRaw-0.17.0/internal/dcraw_common.cpp:25:15: internal compiler error: Aborted
 #define CLASS LibRaw::
               ^
/var/tmp/portage/media-libs/libraw-0.17.0/work/LibRaw-0.17.0/internal/dcraw_common.cpp:4714:6: note: in expansion of macro ‘CLASS’
 void CLASS cielab (ushort rgb[3], short lab[3])
      ^
The build log says to append some files if appropriate, please indicate what would be usefull here.
Comment 1 Markus Oehme 2015-10-04 09:26:59 UTC
Created attachment 413662 [details]
build log
Comment 2 SpanKY gentoo-dev 2015-10-09 15:15:36 UTC

*** This bug has been marked as a duplicate of bug 560904 ***