Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 562198 - sys-fs/bcache-tools-1.0.5: bcache-super-show.c:117: undefined reference to `crc64'
Summary: sys-fs/bcache-tools-1.0.5: bcache-super-show.c:117: undefined reference to `c...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Justin Lecher (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-10-04 09:23 UTC by Markus Oehme
Modified: 2015-12-07 08:23 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.txt,6.23 KB, text/plain)
2015-10-04 09:23 UTC, Markus Oehme
Details
build log (bcache-tools-1.0.5:20151004-083833.log,3.37 KB, text/plain)
2015-10-04 09:23 UTC, Markus Oehme
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Oehme 2015-10-04 09:23:19 UTC
Created attachment 413656 [details]
emerge --info

On my hardened ~amd64 system with gcc-5.2.0 I see the following failure for bcache-tools.

x86_64-pc-linux-gnu-gcc -O2 -pipe -march=native -ggdb -floop-interchange -floop-strip-mine -floop-block -finline-functions -Wall  -std=gnu99  -Wl,-O1 -Wl,--as-needed  bcache-super-show.c bcache.o  `pkg-config --libs uuid` -o bcache-super-show
/var/tmp/portage/sys-fs/bcache-tools-1.0.5/temp/ccbmMIPk.o: In function `main':
/var/tmp/portage/sys-fs/bcache-tools-1.0.5/work/bcache-tools-1.0.5/bcache-super-show.c:117: undefined reference to `crc64'
collect2: error: ld returned 1 exit status
Comment 1 Markus Oehme 2015-10-04 09:23:36 UTC
Created attachment 413658 [details]
build log
Comment 2 Justin Lecher (RETIRED) gentoo-dev 2015-10-11 07:36:10 UTC
Is this something hardened specific? I cannot reproduce it here.
Comment 3 Markus Oehme 2015-11-30 17:45:53 UTC
(In reply to Justin Lecher from comment #2)
> Is this something hardened specific? I cannot reproduce it here.

Coming back to this, it's gcc-5.2.0 related since the problem vanishes if I switch to gcc-4.9.3.
Comment 4 Ted Tanberry 2015-12-06 21:37:21 UTC
--- /usr/portage/sys-fs/bcache-tools/bcache-tools-1.0.8.ebuild
+++ /usr/portage/sys-fs/bcache-tools/bcache-tools-1.0.8.ebuild
@@ -22,7 +22,7 @@
 	tc-export CC
 	sed \
 		-e '/^CFLAGS/s:-O2::' \
-		-e '/^CFLAGS/s:-g::' \
+		-e '/^CFLAGS/s:-g:-std=gnu89:' \
 		-i Makefile || die
 }
Comment 5 Ted Tanberry 2015-12-06 21:37:55 UTC
Classic gnu89 vs c11 inline symbol differences.
Comment 6 Justin Lecher (RETIRED) gentoo-dev 2015-12-07 08:23:59 UTC
commit 8bddc4b710c6c9dc66efae65d705110f4702a4fb
Author: Justin Lecher <jlec@gentoo.org>
Date:   Mon Dec 7 09:03:11 2015 +0100

    sys-fs/bcache-tools: Set c standard during compilation

    Thanks Ted Tanberry for the fix

    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=562198

    Package-Manager: portage-2.2.26
    Signed-off-by: Justin Lecher <jlec@gentoo.org>

    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=8bddc4b710c6c9dc66efae65d705110f4702a4fb