Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 559870 - sys-libs/ncurses-6.0-r1 USE="-tinfo" failed (install phase) Building terminfo database , no tic program found
Summary: sys-libs/ncurses-6.0-r1 USE="-tinfo" failed (install phase) Building terminfo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-07 12:46 UTC by jospezial
Modified: 2015-12-15 04:58 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gzipped build.log (build.log.gz,132.60 KB, application/gzip)
2015-09-07 12:49 UTC, jospezial
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jospezial 2015-09-07 12:46:47 UTC
emerge autocleaned ncurses-6.0-r1. That was related to an old VLC ebuild in my overlay.

Because sys-libs/ncurses-6.0 is only a "transitional package" no files are installed:

joerg@bastellinux ~ $ equery f ncurses
 * Searching for ncurses ...
 * Contents of sys-libs/ncurses-6.0:
joerg@bastellinux ~ $ 

Without a real ncurses installed, there is no tic program installed.
The install phase of sys-libs/ncurses-6.0-r1 wants to build terminfo database even with USE="-tinfo" and needs the tic program for that.
USE="minimal" does not help.


So it is not possible to install sys-libs/ncurses-6.0-r1 without real ncurses installed.


MAKEOPTS="-j1" emerge -v1 ncurses

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] sys-libs/ncurses-6.0-r1:0/6::gentoo [6.0:0/6::gentoo] USE="cxx gpm threads%* unicode -ada -debug% -doc% -minimal% -profile% -static-libs {-test%} -tinfo -trace%" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 1 package (1 upgrade), Size of downloads: 0 KiB


make[1]: Entering directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses/form'
linking ../lib/libform.so.6.0
x86_64-pc-linux-gnu-gcc -m32 -march=native -O2 -pipe  --param max-inline-insns-single=1200  -W -Wall -Wbad-function-cast -Wcast-align -Wcast-qual -Wdeclaration-after-statement -Wextra -Winline -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wshadow -Wstrict-prototypes -Wundef -Wignored-qualifiers -Wlogical-op -Wvarargs -Wwrite-strings -Wno-unknown-pragmas -Wswitch-enum -shared -Wl,-soname,`basename ../lib/libform.so.6.0 .6.0`.6,-stats,-lc -o ../lib/libform.so.6.0 ../obj_s/fld_arg.o ../obj_s/fld_attr.o ../obj_s/fld_current.o ../obj_s/fld_def.o ../obj_s/fld_dup.o ../obj_s/fld_ftchoice.o ../obj_s/fld_ftlink.o ../obj_s/fld_info.o ../obj_s/fld_just.o ../obj_s/fld_link.o ../obj_s/fld_max.o ../obj_s/fld_move.o ../obj_s/fld_newftyp.o ../obj_s/fld_opts.o ../obj_s/fld_pad.o ../obj_s/fld_page.o ../obj_s/fld_stat.o ../obj_s/fld_type.o ../obj_s/fld_user.o ../obj_s/frm_cursor.o ../obj_s/frm_data.o ../obj_s/frm_def.o ../obj_s/frm_driver.o ../obj_s/frm_hook.o ../obj_s/frm_opts.o ../obj_s/frm_page.o ../obj_s/frm_post.o ../obj_s/frm_req_name.o ../obj_s/frm_scale.o ../obj_s/frm_sub.o ../obj_s/frm_user.o ../obj_s/frm_win.o ../obj_s/fty_alnum.o ../obj_s/fty_alpha.o ../obj_s/fty_enum.o ../obj_s/fty_generic.o ../obj_s/fty_int.o ../obj_s/fty_ipv4.o ../obj_s/fty_num.o ../obj_s/fty_regex.o -L../lib -lncurses -ldl  -Wl,-O1 -Wl,--as-needed   
/usr/lib/gcc/x86_64-pc-linux-gnu/5.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: total time in link: 0.044000
/usr/lib/gcc/x86_64-pc-linux-gnu/5.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: data size 4632576
cd ../lib && (ln -s -f libform.so.6.0 libform.so.6; ln -s -f libform.so.6 libform.so; )
linking /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.so.6.0
x86_64-pc-linux-gnu-gcc -m32 -march=native -O2 -pipe  --param max-inline-insns-single=1200  -W -Wall -Wbad-function-cast -Wcast-align -Wcast-qual -Wdeclaration-after-statement -Wextra -Winline -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wshadow -Wstrict-prototypes -Wundef -Wignored-qualifiers -Wlogical-op -Wvarargs -Wwrite-strings -Wno-unknown-pragmas -Wswitch-enum -shared -Wl,-soname,`basename /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.so.6.0 .6.0`.6,-stats,-lc -o /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.so.6.0 ../obj_s/fld_arg.o ../obj_s/fld_attr.o ../obj_s/fld_current.o ../obj_s/fld_def.o ../obj_s/fld_dup.o ../obj_s/fld_ftchoice.o ../obj_s/fld_ftlink.o ../obj_s/fld_info.o ../obj_s/fld_just.o ../obj_s/fld_link.o ../obj_s/fld_max.o ../obj_s/fld_move.o ../obj_s/fld_newftyp.o ../obj_s/fld_opts.o ../obj_s/fld_pad.o ../obj_s/fld_page.o ../obj_s/fld_stat.o ../obj_s/fld_type.o ../obj_s/fld_user.o ../obj_s/frm_cursor.o ../obj_s/frm_data.o ../obj_s/frm_def.o ../obj_s/frm_driver.o ../obj_s/frm_hook.o ../obj_s/frm_opts.o ../obj_s/frm_page.o ../obj_s/frm_post.o ../obj_s/frm_req_name.o ../obj_s/frm_scale.o ../obj_s/frm_sub.o ../obj_s/frm_user.o ../obj_s/frm_win.o ../obj_s/fty_alnum.o ../obj_s/fty_alpha.o ../obj_s/fty_enum.o ../obj_s/fty_generic.o ../obj_s/fty_int.o ../obj_s/fty_ipv4.o ../obj_s/fty_num.o ../obj_s/fty_regex.o -L../lib -lncurses -ldl  -Wl,-O1 -Wl,--as-needed   
/usr/lib/gcc/x86_64-pc-linux-gnu/5.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: total time in link: 0.045000
/usr/lib/gcc/x86_64-pc-linux-gnu/5.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: data size 4632576
cd /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32 && (ln -s -f libform.so.6.0 libform.so.6; ln -s -f libform.so.6 libform.so; )
test -z "/var/tmp/portage/sys-libs/ncurses-6.0-r1/image/" && /sbin/ldconfig
Makefile:387: recipe for target '/var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.so.6.0' failed
make[1]: [/var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.so.6.0] Error 1 (ignored)
installing ../lib/libform.a as /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.a
/usr/lib/portage/python3.4/ebuild-helpers/xattr/install -c -m 644 ../lib/libform.a /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.a
ranlib /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/libform.a
installing /var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0/form/form.h in /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/include
make[1]: Leaving directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses/form'
cd misc && make DESTDIR="/var/tmp/portage/sys-libs/ncurses-6.0-r1/image/" RPATH_LIST="/usr/lib32" install
make[1]: Entering directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses/misc'
mkdir -p /var/tmp/portage/sys-libs/ncurses-6.0-r1/image//usr/share/tabset
DESTDIR=/var/tmp/portage/sys-libs/ncurses-6.0-r1/image/ \
prefix=/usr \
exec_prefix=/usr \
bindir=/usr/bin \
top_srcdir=/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0 \
srcdir=/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0/misc \
datadir=/usr/share \
ticdir=/usr/share/terminfo \
source=terminfo.tmp \
cross_compiling=no \
/bin/bash ./run_tic.sh
** Building terminfo database, please wait...
? no tic program found
Makefile:90: recipe for target 'install.data' failed
make[1]: *** [install.data] Error 1
make[1]: Leaving directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses/misc'
Makefile:113: recipe for target 'install' failed
make: *** [install] Error 2
make: Leaving directory '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86/ncurses'
 * ERROR: sys-libs/ncurses-6.0-r1::gentoo failed (install phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_32.x86'
 * S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'
Comment 1 jospezial 2015-09-07 12:49:53 UTC
Created attachment 411258 [details]
gzipped build.log
Comment 2 jospezial 2015-09-07 13:44:42 UTC
ncurses-6.0-r1.ebuild has a check for installed ncurses.
It seems this is confused by installed ncurses-6.0 transitional package.

# When installing ncurses, we have to use a compatible version of tic.
	# This comes up when cross-compiling, doing multilib builds, upgrading,
	# or installing for the first time.  Build a local copy of tic whenever
	# the host version isn't available. #249363 #557598
	if ! ROOT=/ has_version "~sys-libs/${P}:0" ; then
		local lbuildflags="-static"


The workaround was uninstall ncurses-6.0 transitional package.
Comment 3 Mike Gilbert gentoo-dev 2015-09-16 21:03:33 UTC
That's really strange. "~sys-libs/${P}:0" should not match on sys-libs/ncurses-6.0:5/6.

I added the ":0" to address exactly this issue.
Comment 4 SpanKY gentoo-dev 2015-09-17 02:09:23 UTC
if has_version is matching a SLOT it shouldn't, that's not a bug in the ebuild

post the output of (assuming it's still broken on your system):
qlist -ICvS ncurses
Comment 5 jospezial 2015-09-17 11:26:51 UTC
(In reply to SpanKY from comment #4)
> if has_version is matching a SLOT it shouldn't, that's not a bug in the
> ebuild
> 
> post the output of (assuming it's still broken on your system):
> qlist -ICvS ncurses

My system is running fine now related to ncurses and I don't want to break it.

=================================================================
                        Package Settings
=================================================================

sys-libs/ncurses-6.0-r1::gentoo was built with the following:
USE="cxx gpm threads unicode -ada -debug -doc -minimal -profile -static-libs -test -tinfo -trace" ABI_X86="32 64 -x32"

I think it was only an old VLC-9999 ebuild in my overlay that was not updated to the slot and broke the whole ncurses thing with its dependencies.

If nobody else has still this bug then we can close it.
Comment 6 Joshua Kinard gentoo-dev 2015-09-19 07:20:51 UTC
So I just ran into this on my dev box.  It seems the problem is this:

** Building terminfo database, please wait...
/bin/bash -c 'for name in *.pc; do /usr/lib/portage/python2.7/ebuild-helpers/xattr/install -c -m 644 $name /ramfs/portage/sys-libs/ncurses-6.0-r1/image//usr/lib32/pkgconfig/$name; done'
Running /ramfs/portage/sys-libs/ncurses-6.0-r1/work/cross/progs/tic to install /ramfs/portage/sys-libs/ncurses-6.0-r1/image//usr/share/terminfo ...

        You may see messages regarding extended capabilities, e.g., AX.
        These are extended terminal capabilities which are compiled
        using
                tic -x
        If you have ncurses 4.2 applications, you should read the INSTALL
        document, and install the terminfo without the -x option.

./run_tic.sh: line 140: /ramfs/portage/sys-libs/ncurses-6.0-r1/work/cross/progs/tic: No such file or directory
? tic could not build /ramfs/portage/sys-libs/ncurses-6.0-r1/image//usr/share/terminfo
Makefile:90: recipe for target 'install.data' failed
make[1]: *** [install.data] Error 1
make[1]: *** Waiting for unfinished jobs....

---

So where is 'tic'?

# find /ramfs/ -name tic
/ramfs/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_64.amd64/ncursesw/progs/tic
/ramfs/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0-abi_x86_64.amd64/ncurses/progs/tic


It seems 'run_tic.sh' is looking for '${WORKDIR}/cross/progs/tic' when it should really be using '${WORKDIR}/${MULTILIBDIR}/ncurses/progs/tic'.  The presence of the transitional package seems to be confusing the multilib code somehow, causing ncurses (I think) to think it's being cross-compiled and it's not setting the paths up correctly.
Comment 7 SpanKY gentoo-dev 2015-09-19 18:11:07 UTC
please post the output of `qlist -ICvS` and attach a `emerge --debug` log of the ncurses build
Comment 8 jospezial 2015-10-12 19:50:36 UTC
Is https://bugs.gentoo.org/show_bug.cgi?id=560474 related or a dup?
Comment 9 Steve Arnold gentoo-dev 2015-10-14 08:02:54 UTC
This is still confused/broken on arm, trying to do (broken) cross builds, and even leaves a rogue configure process running:

 * Package:    sys-libs/ncurses-6.0-r1
 * Repository: gentoo
 * USE:        arm cxx elibc_glibc gpm kernel_linux threads tinfo unicode userland_GNU
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
>>> Unpacking source...
>>> Unpacking ncurses-6.0.tar.gz to /var/tmp/portage/sys-libs/ncurses-6.0-r1/work
>>> Source unpacked in /var/tmp/portage/sys-libs/ncurses-6.0-r1/work
>>> Preparing source in /var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0 ...
 * Applying ncurses-6.0-gfbsd.patch ...
 [ ok ]
 * Applying ncurses-5.7-nongnu.patch ...
 [ ok ]
 * Applying ncurses-6.0-rxvt-unicode-9.15.patch ...
 [ ok ]
 * Applying ncurses-6.0-pkg-config.patch ...
 [ ok ]
 * Applying ncurses-5.9-gcc-5.patch ...
 [ ok ]
 * Applying ncurses-6.0-ticlib.patch ...
 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0 ...
 * .arm: running multilib-minimal_abi_src_configure
 * econf: updating ncurses-6.0/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating ncurses-6.0/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating ncurses-6.0/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating ncurses-6.0/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating ncurses-6.0/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating ncurses-6.0/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating ncurses-6.0/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating ncurses-6.0/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating ncurses-6.0/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating ncurses-6.0/config.sub with /usr/share/gnuconfig/config.sub
/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0/configure --prefix=/usr --build=armv7a-hardfloat-linux-gnueabi --host=armv7a-hardfloat-linux-gnueabi --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib --with-terminfo-dirs=/etc/terminfo:/usr/share/terminfo --enable-pc-files --with-pkg-config=armv7a-hardfloat-linux-gnueabi-pkg-config --with-pkg-config-libdir=/usr/lib/pkgconfig --with-shared --without-hashed-db --without-ada --with-cxx --with-cxx-binding --with-cxx-shared --without-debug --without-profile --with-gpm=libgpm.so.1 --disable-termcap --enable-symlinks --with-rcs-ids --with-manpage-format=normal --enable-const --enable-colorfgbg --enable-hard-tabs --enable-echo --enable-warnings --without-assertions --enable-leaks --without-expanded --with-macros --with-progs --without-tests --without-trace --with-termlib --disable-widec --without-pthread --without-reentrant --includedir=/usr/include/cross --without-shared --with-normal
/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0/configure --prefix=/usr --build=armv7a-hardfloat-linux-gnueabi --host=armv7a-hardfloat-linux-gnueabi --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib --with-terminfo-dirs=/etc/terminfo:/usr/share/terminfo --enable-pc-files --with-pkg-config=armv7a-hardfloat-linux-gnueabi-pkg-config --with-pkg-config-libdir=/usr/lib/pkgconfig --with-shared --without-hashed-db --without-ada --with-cxx --with-cxx-binding --with-cxx-shared --without-debug --without-profile --with-gpm=libgpm.so.1 --disable-termcap --enable-symlinks --with-rcs-ids --with-manpage-format=normal --enable-const --enable-colorfgbg --enable-hard-tabs --enable-echo --enable-warnings --without-assertions --enable-leaks --without-expanded --with-macros --with-progs --without-tests --without-trace --with-termlib --disable-widec --with-pthread --with-reentrant --includedir=/usr/include/ncursest
/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0/configure --prefix=/usr --build=armv7a-hardfloat-linux-gnueabi --host=armv7a-hardfloat-linux-gnueabi --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib --with-terminfo-dirs=/etc/terminfo:/usr/share/terminfo --enable-pc-files --with-pkg-config=armv7a-hardfloat-linux-gnueabi-pkg-config --with-pkg-config-libdir=/usr/lib/pkgconfig --with-shared --without-hashed-db --without-ada --with-cxx --with-cxx-binding --with-cxx-shared --without-debug --without-profile --with-gpm=libgpm.so.1 --disable-termcap --enable-symlinks --with-rcs-ids --with-manpage-format=normal --enable-const --enable-colorfgbg --enable-hard-tabs --enable-echo --enable-warnings --without-assertions --enable-leaks --without-expanded --with-macros --with-progs --without-tests --without-trace --with-termlib --enable-widec --without-pthread --without-reentrant --includedir=/usr/include/ncursesw
/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0/configure --prefix=/usr --build=armv7a-hardfloat-linux-gnueabi --host=armv7a-hardfloat-linux-gnueabi --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib --with-terminfo-dirs=/etc/terminfo:/usr/share/terminfo --enable-pc-files --with-pkg-config=armv7a-hardfloat-linux-gnueabi-pkg-config --with-pkg-config-libdir=/usr/lib/pkgconfig --with-shared --without-hashed-db --without-ada --with-cxx --with-cxx-binding --with-cxx-shared --without-debug --without-profile --with-gpm=libgpm.so.1 --disable-termcap --enable-symlinks --with-rcs-ids --with-manpage-format=normal --enable-const --enable-colorfgbg --enable-hard-tabs --enable-echo --enable-warnings --without-assertions --enable-leaks --without-expanded --with-macros --with-progs --without-tests --without-trace --with-termlib --disable-widec --without-pthread --without-reentrant
/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0/configure --prefix=/usr --build=armv7a-hardfloat-linux-gnueabi --host=armv7a-hardfloat-linux-gnueabi --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib --with-terminfo-dirs=/etc/terminfo:/usr/share/terminfo --enable-pc-files --with-pkg-config=armv7a-hardfloat-linux-gnueabi-pkg-config --with-pkg-config-libdir=/usr/lib/pkgconfig --with-shared --without-hashed-db --without-ada --with-cxx --with-cxx-binding --with-cxx-shared --without-debug --without-profile --with-gpm=libgpm.so.1 --disable-termcap --enable-symlinks --with-rcs-ids --with-manpage-format=normal --enable-const --enable-colorfgbg --enable-hard-tabs --enable-echo --enable-warnings --without-assertions --enable-leaks --without-expanded --with-macros --with-progs --without-tests --without-trace --with-termlib --enable-widec --with-pthread --with-reentrant --includedir=/usr/include/ncursestw
checking for egrep... grep -E
checking for egrep... grep -E
Configuring NCURSES 6.0 ABI 6 (Wed Oct 14 00:19:37 PDT 2015)
checking for package version... checking for egrep... Configuring NCURSES 6.0 ABI 6 (Wed Oct 14 00:19:37 PDT 2015)
checking for package version... checking for egrep... grep -E
grep -E
checking for egrep... grep -E
6.0
checking for package patch date... 20150808
Configuring NCURSES 6.0 ABI 6 (Wed Oct 14 00:19:37 PDT 2015)
checking for package version... Configuring NCURSES 6.0 ABI 6 (Wed Oct 14 00:19:37 PDT 2015)
checking for package version... 6.0
checking for package patch date... 20150808
Configuring NCURSES 6.0 ABI 6 (Wed Oct 14 00:19:37 PDT 2015)
checking for package version... 6.0
checking for package patch date... 20150808
6.0
checking for package patch date... 20150808
6.0
checking for package patch date... 20150808
checking build system type... checking build system type... checking build system type... armv7a-hardfloat-linux-gnueabi
checking build system type... checking build system type... checking host system type... armv7a-hardfloat-linux-gnueabi
armv7a-hardfloat-linux-gnueabi
checking host system type... armv7a-hardfloat-linux-gnueabi
checking host system type... armv7a-hardfloat-linux-gnueabi
checking host system type... armv7a-hardfloat-linux-gnueabi
checking target system type... checking host system type... armv7a-hardfloat-linux-gnueabi
armv7a-hardfloat-linux-gnueabi
armv7a-hardfloat-linux-gnueabi
checking target system type... armv7a-hardfloat-linux-gnueabi
checking target system type... armv7a-hardfloat-linux-gnueabi
checking target system type... checking target system type... Configuring for linux-gnueabi
checking for prefix... /usr
checking for armv7a-hardfloat-linux-gnueabi-gcc... armv7a-hardfloat-linux-gnueabi
armv7a-hardfloat-linux-gnueabi-gcc
armv7a-hardfloat-linux-gnueabi
armv7a-hardfloat-linux-gnueabi
Configuring for linux-gnueabi
checking for prefix... /usr
Configuring for linux-gnueabi
checking for prefix... /usr
checking for armv7a-hardfloat-linux-gnueabi-gcc... checking for armv7a-hardfloat-linux-gnueabi-gcc... armv7a-hardfloat-linux-gnueabi-gcc
armv7a-hardfloat-linux-gnueabi-gcc
armv7a-hardfloat-linux-gnueabi
Configuring for linux-gnueabi
checking for prefix... /usr
checking for armv7a-hardfloat-linux-gnueabi-gcc... armv7a-hardfloat-linux-gnueabi-gcc
checking for C compiler default output... Configuring for linux-gnueabi
checking for prefix... /usr
checking for armv7a-hardfloat-linux-gnueabi-gcc... armv7a-hardfloat-linux-gnueabi-gcc
checking for C compiler default output... checking for C compiler default output... checking for C compiler default output... checking for C compiler default output... a.out
checking whether the C compiler works... configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-libs/ncurses-6.0-r1/work/cross/config.log
 * ERROR: sys-libs/ncurses-6.0-r1::nerdboy-local failed (configure phase):
a.out
checking whether the C compiler works... yes
 *   econf failed
checking whether we are cross compiling... no
checking for executable suffix...  * 
 * Call stack:
a.out
checking whether the C compiler works... a.out
checking whether the C compiler works...  *               ebuild.sh, line   90:  Called src_configure
yes
checking whether we are cross compiling... no
checking for executable suffix... yes
a.out
checking whether the C compiler works... checking whether we are cross compiling... no
checking for executable suffix...  *             environment, line 2901:  Called multijob_child_init 'do_configure' 'cross' '--without-shared' '--with-normal'
yes
checking whether we are cross compiling... no
checking for executable suffix...  *             environment, line 1958:  Called do_configure 'cross' '--without-shared' '--with-normal'
 *             environment, line  598:  Called econf '--with-terminfo-dirs=/etc/terminfo:/usr/share/terminfo' '--enable-pc-files' '--with-pkg-config=armv7a-hardfloat-linux-gnueabi-pkg-config' '--with-pkg-config-libdir=/usr/lib/pkgconfig' '--with-shared' '--without-hashed-db' '--without-ada' '--with-cxx' '--with-cxx-binding' '--with-cxx-shared' '--without-debug' '--without-profile' '--with-gpm=libgpm.so.1' '--disable-termcap' '--enable-symlinks' '--with-rcs-ids' '--with-manpage-format=normal' '--enable-const' '--enable-colorfgbg' '--enable-hard-tabs' '--enable-echo' '--enable-warnings' '--without-assertions' '--enable-leaks' '--without-expanded' '--with-macros' '--with-progs' '--without-tests' '--without-trace' '--with-termlib' '--disable-widec' '--without-pthread' '--without-reentrant' '--includedir=/usr/include/cross' '--without-shared' '--with-normal'
 *        phase-helpers.sh, line  662:  Called __helpers_die 'econf failed'
 *   isolated-functions.sh, line  117:  Called die
 * The specific snippet of code:
 *              die "$@"
 * 
 * If you need support, post the output of `emerge --info '=sys-libs/ncurses-6.0-r1::nerdboy-local'`,
 * the complete build log and the output of `emerge -pqv '=sys-libs/ncurses-6.0-r1::nerdboy-local'`.
/usr/lib/portage/python2.7/isolated-functions.sh: line 205: wait: `econf failed': not a pid or valid job spec
 * The complete build log is located at '/var/log/portage/sys-libs:ncurses-6.0-r1:20151014-071918.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-libs/ncurses-6.0-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/cross'
 * S: '/var/tmp/portage/sys-libs/ncurses-6.0-r1/work/ncurses-6.0'

checking for object suffix... 

checking for object suffix... checking for object suffix... 
checking for object suffix... o
checking whether we are using the GNU C compiler... o
checking whether we are using the GNU C compiler... o
checking whether we are using the GNU C compiler... yes
checking whether armv7a-hardfloat-linux-gnueabi-gcc accepts -g... o
checking whether we are using the GNU C compiler... yes
checking whether armv7a-hardfloat-linux-gnueabi-gcc accepts -g... yes
checking whether armv7a-hardfloat-linux-gnueabi-gcc accepts -g... yes
yes
checking whether armv7a-hardfloat-linux-gnueabi-gcc accepts -g... yes
yes
checking version of armv7a-hardfloat-linux-gnueabi-gcc... 7
checking for armv7a-hardfloat-linux-gnueabi-gcc option to accept ANSI C... yes
checking version of armv7a-hardfloat-linux-gnueabi-gcc... checking version of armv7a-hardfloat-linux-gnueabi-gcc... 7
checking for armv7a-hardfloat-linux-gnueabi-gcc option to accept ANSI C... 7
checking for armv7a-hardfloat-linux-gnueabi-gcc option to accept ANSI C... checking version of armv7a-hardfloat-linux-gnueabi-gcc... 7
checking for armv7a-hardfloat-linux-gnueabi-gcc option to accept ANSI C... none needed
checking $CC variable... ok
checking how to run the C preprocessor... none needed
checking $CC variable... ok
checking how to run the C preprocessor... none needed
checking $CC variable... ok
Comment 10 SpanKY gentoo-dev 2015-12-15 04:58:02 UTC
some changes have landed since.  re-open if still a problem.