Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 559660 - sys-boot/grub-2.02_beta2-r7 fails to build due to missing dev-perl/Locale-gettext dependency
Summary: sys-boot/grub-2.02_beta2-r7 fails to build due to missing dev-perl/Locale-get...
Status: RESOLVED DUPLICATE of bug 592880
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-09-05 13:18 UTC by Patrizio Bassi
Modified: 2016-09-04 16:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (build.log,633.80 KB, text/x-log)
2015-09-05 13:20 UTC, Patrizio Bassi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrizio Bassi 2015-09-05 13:18:47 UTC
config.status: creating grub-mkconfig
(for x in util/grub-reboot.in ; do cat /mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/work/grub-2.02~beta2/"$x"; done) | ./config.status --file=grub-reboot:-
chmod a+x grub-mkconfig
chmod a+x grub-kbdcomp
PATH=.:$PATH pkgdatadir=. /usr/bin/help2man --section=1 -i /mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/work/grub-2.02~beta2/docs/man/grub-kbdcomp.h2m -o grub-kbdcomp.1 grub-kbdcomp
config.status: creating grub-set-default
Can't locate Locale/gettext.pm in @INC (you may need to install the Locale::gettext module) (@INC contains: /etc/perl /usr/local/lib64/perl5/5.20.2/x86_64-linux /usr/local/lib64/perl5/5.20.2 /usr/lib64/perl5/vendor_perl/5.20.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.20.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.20.2/x86_64-linux /usr/lib64/perl5/5.20.2 .) at /usr/bin/help2man line 28.
BEGIN failed--compilation aborted at /usr/bin/help2man line 28.
Makefile:13026: recipe for target 'grub-kbdcomp.1' failed
make[2]: *** [grub-kbdcomp.1] Error 2
make[2]: *** Waiting for unfinished jobs....
chmod a+x grub-set-default
config.status: creating grub-reboot
chmod a+x grub-reboot
make[2]: Leaving directory '/mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/work/grub-2.02~beta2-guessed'
Makefile:11542: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/work/grub-2.02~beta2-guessed'
Makefile:3938: set di istruzioni per l'obiettivo "all" non riuscito
make: *** [all] Errore 2
 * ERROR: sys-boot/grub-2.02_beta2-r7::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sys-boot/grub-2.02_beta2-r7::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-boot/grub-2.02_beta2-r7::gentoo'`.
 * The complete build log is located at '/mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/temp/build.log'.
 * The ebuild environment file is located at '/mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/temp/environment'.
 * Working directory: '/mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/work/grub-2.02~beta2-guessed'
 * S: '/mnt/Portage/Gentoo/tmp/portage/sys-boot/grub-2.02_beta2-r7/work/grub-2.02~beta2'

Portage 2.2.18 (python 2.7.5-final-0, default/linux/amd64/13.0/desktop/kde/systemd, gcc-5.1.0, glibc-2.20-r2, 4.0.0 x86_64)
=================================================================
System uname: Linux-4.0.0-x86_64-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-gentoo-2.2
KiB Mem:     4046812 total,    502796 free
KiB Swap:    4942532 total,   4821904 free
Timestamp of repository gentoo: Sat, 05 Sep 2015 11:15:01 +0000
sh bash 4.3_p39
ld ld di GNU (Gentoo 2.25 p1.2) 2.25
ccache version 3.1.9 [disabled]
app-shells/bash:          4.3_p39::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2-r1::gentoo
dev-lang/python:          2.7.5-r4::gentoo, 3.4.3::gentoo
dev-util/ccache:          3.1.9::gentoo
dev-util/cmake:           3.2.1::gentoo
dev-util/pkgconfig:       0.28-r3::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::<unknown repository>, 2.69-r1::gentoo
sys-devel/automake:       1.9.6-r3::gentoo, 1.11.6::gentoo, 1.12.6::gentoo, 1.13.1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25-r1::gentoo
sys-devel/gcc:            5.1.0::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.0::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /mnt/Portage/Gentoo/portage
    sync-type: rsync
    sync-uri: rsync://rsync.europe.gentoo.org/gentoo-portage
    priority: -1000

blight
    location: /mnt/Portage/Gentoo/localportage
    masters: gentoo
    priority: 0

Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA skype-4.0.0.7-copyright googleearth AdobeFlash-11.x PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -mtune=core2 -march=core2 -fomit-frame-pointer -mmmx -msse -msse2 -msse3 -mfpmath=sse"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/mail/dspam /usr/lib/mozilla/defaults/pref /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb /var/run/dspam"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/eselect/compiler /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -mtune=core2 -march=core2 -fomit-frame-pointer -mmmx -msse -msse2 -msse3 -mfpmath=sse"
DISTDIR="/mnt/Portage/Gentoo/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.utf8"
LC_ALL="it_IT.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--enable-new-dtags -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/mnt/Portage/Gentoo/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/mnt/Portage/Gentoo/tmp/"
USE="X a52 aac acl acpi alsa amd64 apache2 apng bash-completion branding bzip2 cairo caps cdda cdr connectionstatus cracklib crypt css cups curl cxx daemon dbus declarative device-mapper disable-watermark divx dri dtmf dts dvd dvdr dvdread dynamicplugin embedded encode exif ffmpeg firefox flac ftp g3dvl gallium gbm gif glamor gles gles1 gles2 glibc-omitfp glitz glut gpm hddtemp iconv icu idn ipod ipv6 irc java java6 javascript jpeg jpeg2k justify kde kde4 kdehiddenvisibility kipi kpathsea kqemu lame lcms libkms libmpv lightning lilo lm_sensors lzo mad matroska mime minizip mmx mmxext mng mozdevelop mp3 mp4 mp4live mpeg mpeg2 mplayer msn multilib musepack ncurses network nls nntp npp nptl nsplugin ntfs ogg opengl openmp openssl openvg opus pam pango pdf pdfimport pgo phonon plasma png policykit python3 qt3support qt4 quicktime readline reiserfs remote rtc samba scanner sdl seccomp secure-delete semantic-desktop session sip sipim slang smp sockets speex spell sse sse2 sse3 ssl ssse3 svg system-sqlite systemd tao theora threads tiff truetype udev udisks unicode unlock-notify usb userlocales v4l v4l2 vaapi vdpau video vorbis vpx wav wavpack webgl webm webp wifi wma wxwidgets x264 x265 xa xcb xcomposite xine xml xorg xpm xulrunner xv xvfb xvid xvmc zip zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Patrizio Bassi 2015-09-05 13:20:38 UTC
Created attachment 411054 [details]
build log
Comment 2 Mike Gilbert gentoo-dev 2015-09-05 19:55:44 UTC
> Can't locate Locale/gettext.pm

Please run perl-cleaner --all and re-open this if you still have problems.
Comment 3 Patrizio Bassi 2015-09-20 06:47:40 UTC
Hi Mike,

perl-cleaner didn't work, because the problem is different.

after some forums search i fixed by merging dev-perl/Locale-gettext which isn't in the deps. Can you please add to the grub2 deps list?

i'm reopening and changing title.
Comment 4 Mike Gilbert gentoo-dev 2015-09-20 14:07:08 UTC
(In reply to Patrizio Bassi from comment #3)
> after some forums search i fixed by merging dev-perl/Locale-gettext which
> isn't in the deps. Can you please add to the grub2 deps list?

grub does not utilize it directly. It is used by sys-apps/help2man, which already has a dependency on dev-perl/Locale-gettext.
Comment 5 Mike Gilbert gentoo-dev 2015-09-27 18:23:18 UTC
If you can demonstrate how you managed to install help2man without dev-perl/Locale-gettext, feel free to reopen.
Comment 6 Kent Fredric (IRC: kent\n) gentoo-dev 2016-09-04 16:03:59 UTC

*** This bug has been marked as a duplicate of bug 592880 ***