Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 55888 - wxBase.2.4.2.ebuild (New Package)
Summary: wxBase.2.4.2.ebuild (New Package)
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Gentoo wxWidgets Herd
URL:
Whiteboard:
Keywords:
: 36907 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-07-02 08:04 UTC by Jan Loderhose
Modified: 2004-12-09 13:02 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ebuild wxBase-2.4.2 (wxBase-2.4.2.ebuild,967 bytes, text/plain)
2004-07-02 08:06 UTC, Jan Loderhose
Details
license to wxBase-2.4.2 (LICENCE.txt,2.43 KB, text/plain)
2004-07-02 08:09 UTC, Jan Loderhose
Details
Corrected ebuild file (wxBase-2.4.2.ebuild,976 bytes, text/plain)
2004-07-17 06:55 UTC, Rodrigo Severo
Details
wxBase-2.4.2 ebuild using the "wxWinLL-3" license reference (wxBase-2.4.2.ebuild,949 bytes, text/plain)
2004-07-18 05:18 UTC, Rodrigo Severo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Loderhose 2004-07-02 08:04:01 UTC
Hi!

I've watched the discussion wether aMule-1.2.6 should be installed with a dependency to wxBase. My opinion is a definite 'Yes' since my system only runs aMule if wxBase is installed, in addition to wxGTK.

wxBase is the library providing most of the non-GUI classes of the wxWindows
cross-platform C++ framework. wxBase has some generic classes such as yet
another C++ string class, typesafe dynamic arrays, hashes and lists and, more
excitingly, wxDateTime - a very flexible and powerful class for manipulating
the dates in the range of 580 million years with up to millisecond precision.

Since this is the first ebuild I submit, please have mercy if you find any mistake. (My machines (x86) do not complain about anything.)

Cheers, Jan
Comment 1 Jan Loderhose 2004-07-02 08:06:14 UTC
Created attachment 34648 [details]
ebuild wxBase-2.4.2
Comment 2 Jan Loderhose 2004-07-02 08:09:22 UTC
Created attachment 34649 [details]
license to wxBase-2.4.2

Couldn' find license in /usr/portage/licenses -> attached
Comment 3 Giacomo Perale 2004-07-12 14:08:28 UTC
I suggest insertion in portage, too.
It is needed by remote control utilities in new amule 2.0.0 rc4
Comment 4 Rodrigo Severo 2004-07-17 06:54:10 UTC
I've corrected two small errors on #1 ebuild:

1. Remove spaces on dependency atoms;

2. Include the apropriate IUSE flags.

And metoo for ebuild inclusion, please.
Comment 5 Rodrigo Severo 2004-07-17 06:55:39 UTC
Created attachment 35632 [details]
Corrected ebuild file
Comment 6 Rodrigo Severo 2004-07-17 10:28:33 UTC
I have been testing wxBase ebuild but I believe it is conflicting with wxGTK ebuild. Maybe because of filenames with same name? There is at least one file (symbolic link to be exact) with same names under both packages: wx-config.

I have just manually installed wxBase with --prefix=/usr/local/wxBase.

With this setup I managed to manually compile aMule-2.0.0rc4a with webserver support (which depends on wxBase).

What should be the --prefix for wxBase ebuild if it can't reside together with wxGTK under --prefix=/usr?

My first bet was /opt but I've seem that /opt should be used only for binary packages like openoffice-bin.

I don't understand exactly how SLOT works. Could it be a solution for this problem? I mean, if wxGTK goes to one SLOT and wxBase goes to another will things be ok?

I now that I have more doubts than solutions but I'm really new to this ebuild world.
Comment 7 Rodrigo Severo 2004-07-18 05:16:33 UTC
I have just found the proper license for wxBase in the present list of licenses under /usr/portage/licenses.

I'm including a modified ebuild for wxBase-2.4.2 with this single modification.
Comment 8 Rodrigo Severo 2004-07-18 05:18:10 UTC
Created attachment 35685 [details]
wxBase-2.4.2 ebuild using the "wxWinLL-3" license reference
Comment 9 Rob Cakebread (RETIRED) gentoo-dev 2004-07-30 14:10:16 UTC
*** Bug 36907 has been marked as a duplicate of this bug. ***
Comment 10 Rob Cakebread (RETIRED) gentoo-dev 2004-07-30 14:38:23 UTC
wxBase is for applications that do not need the GUI components of a full wxGTK installation. If wxBase has something that wxGTK doesn't already provide, could you please point it out? 
Comment 11 Rodrigo Severo 2004-07-30 14:55:22 UTC
Answering #10, sorry, I can't. I don't know if there is something "extra" in wxBase.

What I can tell you for sure is that there are some features in aMule (web command for example) that are only compiled on a machine with wxBase. This makes me believe that there is something extra in wxBase.

Another explanation for the aMule-requires-wxBase issue would be that the aMule developers are crazy/dumb and request wxBase without real need. That's possible but I'm not beting on it by now...
Comment 12 Rob Cakebread (RETIRED) gentoo-dev 2004-07-30 16:25:45 UTC
Can someone who doesn't have wxBase installed try this and let me know if you get all the features:

cp /usr/bin/wxgtk-2.4-config /usr/bin/wxbase-2.4-config

Then re-emerge amule. Its seems to be working for me but I'm not familiar enough with amule to know if I'm missing anything.
Comment 13 Rodrigo Severo 2004-07-31 03:24:20 UTC
I have just removed wxBase and everything seems to be working fine.

I bet I will have to contact the aMule developers about this issue...
Comment 14 Rob Cakebread (RETIRED) gentoo-dev 2004-07-31 08:29:41 UTC
Thanks, Rodrigo. The only thing we should have to do in the ebuild is add this as the first line in src_compile:
export WXBASE_CONFIG_NAME=wxgtk-2.4-config

You can skip copying the wxbase-2.4-config file in the future.
Comment 15 Rob Cakebread (RETIRED) gentoo-dev 2004-12-09 13:02:59 UTC
I'm not going to add wxBase as there is nothing in portage that currently needs it. If a future app needs it, it should be a blocker of wxGTK because it overwrites many of wxGTK's files.