Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 557582 - net-mail/mailutils-2.99.98: fatal error: mysql/plugin_auth_common.h: No such file or directory
Summary: net-mail/mailutils-2.99.98: fatal error: mysql/plugin_auth_common.h: No such ...
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Net-Mail Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-08-14 15:19 UTC by jannis
Modified: 2015-08-25 09:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,298.71 KB, text/plain)
2015-08-14 15:20 UTC, jannis
Details
emerge --info (einfo,25.71 KB, text/plain)
2015-08-14 15:20 UTC, jannis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jannis 2015-08-14 15:19:35 UTC
I tried to rebuild mailutils due to ncurses-update but it failed:
In file included from /usr/include/mysql/mysql.h:64:0,
                 from mysql.c:25:
/usr/include/mysql/mysql/client_plugin.h:103:38: fatal error: mysql/plugin_auth_common.h: No such file or directory
 #include <mysql/plugin_auth_common.h>

mariadb is installed as mysql server + client libs:
[I] dev-db/mariadb
     Available versions:  (~)5.5.45^d 10.0.19(0/0)^d (~)10.0.21(0/18)^d (~)10.0.21-r1(0/18)^d {bindist client-libs cluster +community debug embedded extraengine jemalloc latin1 max-idx-128 minimal odbc oqgraph pam +perl profiling selinux +server sphinx ssl static static-libs systemtap tcmalloc test tokudb +tools xml ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  10.0.21-r1^d(14:43:27 08/11/15)(community extraengine pam perl server ssl tools xml -bindist -client-libs -cluster -debug -embedded -jemalloc -latin1 -odbc -oqgraph -profiling -selinux -sphinx -static -static-libs -systemtap -tcmalloc -test -tokudb ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32 64 -x32")
     Homepage:            http://mariadb.org/
     Description:         An enhanced, drop-in replacement for MySQL

Reproducible: Always
Comment 1 jannis 2015-08-14 15:20:15 UTC
Created attachment 408998 [details]
build.log
Comment 2 jannis 2015-08-14 15:20:35 UTC
Created attachment 409000 [details]
emerge --info
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2015-08-14 15:29:39 UTC
" -I. -I.. -I.. -I../include -I../include"

This is a case of a build system not explicitly including the mysql include directory ( such as from `mysql_config --include`, i.e. -I/usr/include/mysql )

Please fix this.
Comment 4 jannis 2015-08-14 15:56:56 UTC
For completeness:
miramis ~ # mysql_config --include
-I/usr/include/mysql

So maybe the build system doesn't use mysql_config?
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2015-08-14 16:06:46 UTC
(In reply to jannis from comment #0)
> I tried to rebuild mailutils due to ncurses-update but it failed:
> In file included from /usr/include/mysql/mysql.h:64:0,
>                  from mysql.c:25:
> /usr/include/mysql/mysql/client_plugin.h:103:38: fatal error:
> mysql/plugin_auth_common.h: No such file or directory
>  #include <mysql/plugin_auth_common.h>
> 
> mariadb is installed as mysql server + client libs:
> [I] dev-db/mariadb

>      Installed versions:  10.0.21-r1^d(14:43:27 08/11/15)(community
> extraengine pam perl server ssl tools xml -bindist -client-libs -cluster
> -debug -embedded -jemalloc -latin1 -odbc -oqgraph -profiling -selinux
> -sphinx -static -static-libs -systemtap -tcmalloc -test -tokudb
> ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="32
> 64 -x32")
>      Homepage:            http://mariadb.org/
>      Description:         An enhanced, drop-in replacement for MySQL
> 
> Reproducible: Always

Also for completeness:

According to that eix output, client-libs is off and is probably provided by dev-db/mysql-connector-c, which is OK as it is the new planned default.
Comment 6 Eray Aslan gentoo-dev 2015-08-25 07:02:48 UTC
Should be fixed in the tree.  Thanks for the report.
Comment 7 jannis 2015-08-25 09:51:07 UTC
Confirmed, thanks!