Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 55689 - Cant emerge libgdiplus-0.10. Complains about not finding Cairo libs, but they are installed
Summary: Cant emerge libgdiplus-0.10. Complains about not finding Cairo libs, but they...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: dotnet
URL: http://forums.gentoo.org/viewtopic.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-06-30 09:27 UTC by Richard Svensson
Modified: 2004-09-19 11:28 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Svensson 2004-06-30 09:27:01 UTC
Im trying to emerge libgdiplus-0.10 and it requiers carior. I emerged cairo-0.1.23-r1 and all went fine. But when i tried whith libgdiplus, it cant find the cairo libs, im getting the following error:

Code:

checking for pkg-config... /usr/bin/pkg-config
GLIB 2.0 installation OK
configure: error: "Did not find Cairo 0.1.22"
 
!!! ERROR: dev-dotnet/libgdiplus-0.10 failed.
!!! Function econf, Line 365, Exitcode 1
!!! econf failed



Im running Xfree-4.3.0-r6

Reproducible: Always
Steps to Reproduce:
1.ACCEPT_KEYWORDS="~x86" emerge -vt cairo
2.ACCEPT_KEYWORDS="~x86" emerge -vt libgdiplus
3.

Actual Results:  
The emerge of libgdiplus fails.

Expected Results:  
Completed the emerge

Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.2, glibc-2.3.2-r9, 2.6.5-gentoo-r1)
=================================================================
System uname: 2.6.5-gentoo-r1 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.4.3.13
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.8.3
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=i686 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/
http://trumpetti.atm.tut.fi/gentoo/
http://sunsite.cnlab-switch.ch/ftp/mirror/gentoo/
http://212.219.247.19/sites/www.ibiblio.org/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/root/ebuilds"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb cdr crypt cups encode esd foomaticdb gdbm gif
gnome gpm gtk gtk2 guile imlib java jpeg kde ldap libg++ libwww mad mikmod motif
mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl png python qt
quicktime readline sdl slang spell ssl svga tcltk tcpd truetype x86 xml2 xmms xv
zlib"
Comment 1 Peter Johanson (RETIRED) gentoo-dev 2004-06-30 09:39:07 UTC
Hey guys, my money is on the xrender.pc not being installed. User is using xfree-4.3.0-r6 (as posted to forums).

Shouldn't we make the cairo versions that don't install xrender.pc rely on xfree versions high enough that *do* install the file? It seems that the latest cairo depends on at least 4.3.0-r6, but only 4.3.0-r7 installs the xrender.pc file.
Comment 2 Tom Payne (RETIRED) gentoo-dev 2004-06-30 11:28:43 UTC
[I maintain cairo]

Hi Peter,

I did do what you're suggesting, but I thought that xfree-4.3.0-r6 provided xrender.pc (bug # 40400, bug # 44314, bug # 44984), and specifically
http://bugs.gentoo.org/show_bug.cgi?id=40400#c6

However, it seems that it doesn't:

twp@bongo twp $ grep xrender /var/db/pkg/x11-base/xfree-4.3.0-r6/CONTENTS 
*nothing*

I'll update the cairo dependencies appropriately.

Tom
Comment 3 Peter Johanson (RETIRED) gentoo-dev 2004-06-30 11:36:42 UTC
Tom, yeah, i suspected that was the case. Thanks for fixing it. Richard, can you just respond once you've upgraded xfree and let me know for sure this fixed things? Thanks.
Comment 4 Tom Payne (RETIRED) gentoo-dev 2004-06-30 11:40:22 UTC
Cairo deps now fixed in CVS.

Please close the bug if this solves the problem.

Cheers,

Tom
Comment 5 Donnie Berkholz (RETIRED) gentoo-dev 2004-06-30 17:21:57 UTC
4.3.0-r6 used to, but revisions were screwed around because of a security bump.
Comment 6 Tom Payne (RETIRED) gentoo-dev 2004-07-09 12:39:03 UTC
*ping*

Richard, has this fixed your problem?

If not, let me know...
Comment 7 Richard Svensson 2004-07-09 12:48:26 UTC
*pong*

Well i havnt been abel to install Xfree-4.3.0-r7, When i try an emerge, it wants to install Xorg as an dep. to an other package for some reason. And i has not been abel to spend as much time on the problem as i would like. Hopefully i can get on with it within a couple of days.

//Richard
Comment 8 Peter Johanson (RETIRED) gentoo-dev 2004-09-19 11:28:19 UTC
xfree/xorg-x11 have had this resolved fine as of recently, and have had no further input from user.

Marking CANTFIX, please feel free to re-open if you manage to either reproduce this problem with recent xorg-x11/xfree ebuilds. Thanks.