Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 556432 - virtual/mysql upgrade blocker weirdness
Summary: virtual/mysql upgrade blocker weirdness
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
: 556482 (view as bug list)
Depends on: 555478 555480
Blocks:
  Show dependency tree
 
Reported: 2015-08-01 05:59 UTC by Patrick Lauer
Modified: 2016-03-15 12:13 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kde-try (kde-chroot-attempt.txt,51.29 KB, text/plain)
2015-12-24 15:04 UTC, Oleh
Details
update-block (update-block,21.48 KB, text/plain)
2016-03-15 11:10 UTC, Pryka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2015-08-01 05:59:41 UTC
Seen this on multiple machines when explicitly trying to update dev-db/mysql (which is installed)

emerge -1 dev-db/mysql

Calculating dependencies... done!
[ebuild  N     ] dev-libs/libevent-2.1.5  USE="ssl threads -debug -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 
[ebuild     U  ] dev-db/mysql-5.6.26 [5.6.25]
[ebuild  N     ] dev-db/mysql-cluster-7.3.9-r1  USE="community perl ssl -cluster -debug -embedded -extraengine -java -jemalloc -latin1 -minimal -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test}" ABI_X86="(64) -32 (-x32)" 
[uninstall     ] dev-db/mysql-connector-c-6.1.6 
[blocks b      ] dev-db/mysql[client-libs(+)] ("dev-db/mysql[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.6)
[blocks b      ] dev-db/mysql-cluster[client-libs(+)] ("dev-db/mysql-cluster[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.6)
[blocks B      ] dev-db/mysql ("dev-db/mysql" is blocking dev-db/mysql-cluster-7.3.9-r1)
[blocks B      ] dev-db/mysql-cluster ("dev-db/mysql-cluster" is blocking dev-db/mysql-5.6.25, dev-db/mysql-5.6.26)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-db/mysql-5.6.26:0/18::gentoo, ebuild scheduled for merge) pulled in by
    dev-db/mysql
    =dev-db/mysql-5.6*[embedded=,minimal=,static=,static-libs=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (=dev-db/mysql-5.6*[-embedded,-minimal,-static,-static-libs,abi_x86_64(-)]) required by (virtual/mysql-5.6-r2:0/18::gentoo, installed)

  (dev-db/mysql-cluster-7.3.9-r1:0/18::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mysql-cluster-7.3*[embedded=,minimal=,static=,static-libs=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (=dev-db/mysql-cluster-7.3*[-embedded,-minimal,-static,-static-libs,abi_x86_64(-)]) required by (virtual/mysql-5.6-r2:0/18::gentoo, installed)


# emerge -upNDv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-db/mysql-5.6.26-r1:0/18::gentoo [5.6.25:0/0::gentoo] USE="community perl server%* ssl {test*} tools%* -client-libs% (-cluster) -debug -embedded -extraengine -jemalloc -latin1 -profiling (-selinux) -static -static-libs -systemtap -tcmalloc (-minimal%)" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] virtual/mysql-5.6-r5:0/18::gentoo [5.6-r2:0/18::gentoo] USE="-embedded -static -static-libs (-minimal%)" ABI_X86="(64) -32 (-x32)" 0 KiB
[blocks b      ] <virtual/mysql-5.6-r4 ("<virtual/mysql-5.6-r4" is blocking dev-db/mysql-5.6.26-r1)
Comment 1 Brian Evans Gentoo Infrastructure gentoo-dev 2015-08-01 20:09:48 UTC
The 5.6.{25,26}-r1 with client-libs USE is intended to stay unstable until mysql-connector-c can be keyworded by all arches.

The -r0 is currently being left so it can be security stabled very soon.

If the virtual/mysql version is too low, not upgrading world will temporarily cause blockers
Comment 2 Fabio Coatti 2015-08-04 21:06:03 UTC
I have the same problem (almost): what I can't understand is why virtual/mysql pulls mysql-cluster on my system:



calvin ~ # emerge -1 virtual/mysql
Calculating dependencies... done!
[ebuild  N     ] dev-db/mysql-cluster-7.3.9-r1  USE="community embedded java perl ssl -cluster -debug -extraengine -jemalloc -latin1 -minimal -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test}" ABI_X86="32 (64) (-x32)" 
[ebuild     U  ] virtual/mysql-5.6-r6 [5.6-r5]
[uninstall     ] dev-db/mysql-connector-c-6.1.6 
[blocks b      ] dev-db/mysql-cluster[client-libs(+)] ("dev-db/mysql-cluster[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.6)
[blocks B      ] dev-db/mysql-cluster ("dev-db/mysql-cluster" is blocking dev-db/mariadb-10.0.20-r1)
[blocks B      ] dev-db/mariadb ("dev-db/mariadb" is blocking dev-db/mysql-cluster-7.3.9-r1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-db/mysql-cluster-7.3.9-r1:0/18::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mysql-cluster-7.3*[client-libs(+),embedded,static=] (=dev-db/mysql-cluster-7.3*[client-libs(+),embedded,-static]) required by (virtual/mysql-5.6-r6:0/18::gentoo, ebuild scheduled for merge)
    dev-db/mysql-cluster:0/18[client-libs(+),static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-db/mysql-cluster:0/18[client-libs(+),abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libmysqlclient-18:0/18::gentoo, installed)

  (dev-db/mariadb-10.0.20-r1:0/18::gentoo, installed) pulled in by
    dev-db/mariadb required by @selected



Note, I'm using mariadb
Comment 3 Pryka 2015-08-05 10:34:39 UTC
Same:

[ebuild     U  ] dev-python/setuptools-18.1::gentoo [18.0.1::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 -pypy -pypy3 -python3_3" 616 KiB
[ebuild     U  ] dev-libs/boost-1.57.0:0/1.57.0::gentoo [1.56.0-r1:0/1.56.0::gentoo] USE="nls python threads -context -debug -doc -icu -mpi -static-libs -tools" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_3" 59397 KiB
[ebuild  NS    ] sys-kernel/vanilla-sources-4.1.4:4.1.4::gentoo [4.1.0:4.1.0::gentoo, 4.1.1:4.1.1::gentoo, 4.1.2:4.1.2::gentoo, 4.1.3:4.1.3::gentoo] USE="symlink -build -deblob" 128 KiB
[ebuild     U  ] x11-libs/pixman-0.33.2::gentoo [0.32.6::gentoo] USE="(-altivec) (-iwmmxt) (-loongson2f) (-neon) -static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="mmxext sse2 ssse3" 709 KiB
[ebuild  N     ] dev-db/mysql-cluster-7.3.9-r1:0/18::gentoo  USE="community embedded java perl ssl -cluster -debug -extraengine -jemalloc -latin1 -minimal -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test}" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] www-client/google-chrome-44.0.2403.130_p1::gentoo [44.0.2403.125_p1::gentoo] USE="plugins" LINGUAS="pl -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 46458 KiB
[blocks B      ] dev-db/mysql-cluster[client-libs(+)] ("dev-db/mysql-cluster[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.6)


 * Error: The above package list contains packages which cannot be                                                                                                    
 * installed at the same time on the same system.                                                                                                                     

  (dev-db/mysql-connector-c-6.1.6:0/18::gentoo, installed) pulled in by
    dev-db/mysql-connector-c:0/18[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-db/mysql-connector-c:0/18[abi_x86_64(-)]) required by (virtual/libmysqlclient-18:0/18::gentoo, installed)

  (dev-db/mysql-cluster-7.3.9-r1:0/18::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mysql-cluster-7.3*[client-libs(+),embedded,static=] (=dev-db/mysql-cluster-7.3*[client-libs(+),embedded,-static]) required by (virtual/mysql-5.6-r6:0/18::gentoo, installed)
Comment 4 Billy DeVincentis 2015-08-06 01:14:50 UTC
I have this problem too, I can't upgrade
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2015-08-11 20:23:17 UTC
*** Bug 556482 has been marked as a duplicate of this bug. ***
Comment 6 Daniel 2015-08-26 21:25:25 UTC
I have the same issue.
Have percona server installed
virtual/mysql pulls in mariadb

[blocks B      ] dev-db/mariadb ("dev-db/mariadb" is blocking dev-db/percona-server-5.6.25.73.0)
[blocks B      ] dev-db/percona-server ("dev-db/percona-server" is blocking dev-db/mariadb-10.0.21)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-db/percona-server-5.6.25.73.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/percona-server-5.6*[embedded=,minimal=,static=,static-libs=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (=dev-db/percona-server-5.6*[-embedded,-minimal,-static,-static-libs,abi_x86_64(-)]) required by (virtual/mysql-5.6-r2:0/18::gentoo, ebuild scheduled for merge)
    dev-db/percona-server required by @selected

  (dev-db/mariadb-10.0.21:0/18::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mariadb-10.0*[embedded=,minimal=,static=,static-libs=,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (=dev-db/mariadb-10.0*[-embedded,-minimal,-static,-static-libs,abi_x86_64(-)]) required by (virtual/mysql-5.6-r2:0/18::gentoo, ebuild scheduled for merge)
Comment 7 Pryka 2015-08-28 09:47:36 UTC
Someone is trying to fix this? Can't update the system for about a month because of this block.
Comment 8 Brian Evans Gentoo Infrastructure gentoo-dev 2015-08-28 12:27:49 UTC
(In reply to Pryka from comment #7)
> Someone is trying to fix this? Can't update the system for about a month
> because of this block.

Mixing stable virtual/mysql and unstable/testing dev-db/{mariadb,percona-server,mysql} causes this currently.

I plan to mark stable the new virtuals once the security bugs for mysql/mariadb are done.
Comment 9 Oleh 2015-12-24 15:04:27 UTC
ok, so the virtuals are stable for quite some time and this does not fix a thing.

akonadi-server[mysql] depend on virtual/mysql, which defaults to mariadb
qtsql switched to depend on virtual/libmysqlclient, which defaults to mysql-connector-c and obviously this is not a go for mariadb. This is a stopper.
Attached fresh kde try.
Comment 10 Oleh 2015-12-24 15:04:49 UTC
Created attachment 420666 [details]
kde-try
Comment 11 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2015-12-31 12:36:04 UTC
(In reply to Oleg from comment #10)
> Created attachment 420666 [details]
> kde-try

Does it work if you run emerge -uDpv @world ?

I see in the above paste that you already have virtual/libmysqlclient installed, but are only trying to update kde-meta. You may need to use -D (deep) so it updates the dependencies or explicitly tell portage to update virtual/libmysqlclient as well.
Comment 12 Brian Evans Gentoo Infrastructure gentoo-dev 2015-12-31 18:32:09 UTC
Added virtual/mysql-5.6-r7 to try to fix this.
Comment 13 Oleh 2016-01-02 16:38:57 UTC
(In reply to Jorge Manuel B. S. Vicetto from comment #11)
> (In reply to Oleg from comment #10)
> > Created attachment 420666 [details]
> > kde-try
> 
> Does it work if you run emerge -uDpv @world ?
> 
> I see in the above paste that you already have virtual/libmysqlclient
> installed, but are only trying to update kde-meta. You may need to use -D
> (deep) so it updates the dependencies or explicitly tell portage to update
> virtual/libmysqlclient as well.

libmysqlclient has never been installed. This is vanilla attempt to install kde-meta in freshly created chroot.
Comment 14 Oleh 2016-01-02 16:39:49 UTC
(In reply to Brian Evans from comment #12)
> Added virtual/mysql-5.6-r7 to try to fix this.

looks like it fixed. mysql-connector-c++/mariadb clash is not observed.
Comment 15 Reinis Danne 2016-01-06 20:50:39 UTC
Could this be because of required USE client-libs which is in virtual/mysql, but mariadb doesn't have it anymore? I'm still having the following blocker on world update:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-db/mariadb-10.1.10:0/18::gentoo [10.1.9:0/18::gentoo] USE="cracklib openssl pam perl server systemd xml -bindist -debug -embedded
 -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jemalloc -latin1 -libressl -mroonga -odbc -oqgraph -profiling (-selinux) -sphinx -sst-rs
ync -sst-xtrabackup -static -static-libs -systemtap -tcmalloc {-test} -tokudb -yassl (-client-libs%) (-tools%*)" ABI_X86="(64) -32 (-x32)" 54 155 KiB
[blocks B      ] dev-db/mariadb[client-libs(+)] ("dev-db/mariadb[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.6-r2)

Total: 1 package (1 upgrade), Size of downloads: 54 155 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-db/mysql-connector-c-6.1.6-r2:0/18::gentoo, installed) pulled in by
    dev-db/mysql-connector-c:0/18[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_pp
c_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-db/mysql-connector-c:0/18[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libmysqlcli
ent-18:0/18::gentoo, installed)

  (dev-db/mariadb-10.1.10:0/18::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mariadb-10.1*[-embedded,static=] (=dev-db/mariadb-10.1*[-embedded,-static]) required by (virtual/mysql-5.6-r7:0/18::gentoo, installed)


Uninstalling dev-db/mysql-connector-c and virtual/libmysqlclient pulls them right back in on next merge:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-db/mysql-connector-c-6.1.6-r2:0/18::gentoo  USE="ssl -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N     ] virtual/libmysqlclient-18:0/18::gentoo  USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] dev-db/mariadb-10.1.10:0/18::gentoo [10.1.9:0/18::gentoo] USE="cracklib openssl pam perl server systemd xml -bindist -debug -embedded -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jemalloc -latin1 -libressl -mroonga -odbc -oqgraph -profiling (-selinux) -sphinx -sst-rsync -sst-xtrabackup -static -static-libs -systemtap -tcmalloc {-test} -tokudb -yassl (-client-libs%) (-tools%*)" ABI_X86="(64) -32 (-x32)" 54 155 KiB
[blocks B      ] dev-db/mariadb[client-libs(+)] ("dev-db/mariadb[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.6-r2)

Total: 3 packages (1 upgrade, 2 new), Size of downloads: 54 155 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-db/mysql-connector-c-6.1.6-r2:0/18::gentoo, ebuild scheduled for merge) pulled in by
    dev-db/mysql-connector-c:0/18[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-db/mysql-connector-c:0/18[abi_x86_32(-),abi_x86_64(-)]) required by (virtual/libmysqlclient-18:0/18::gentoo, ebuild scheduled for merge)

  (dev-db/mariadb-10.1.10:0/18::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mariadb-10.1*[-embedded,static=] (=dev-db/mariadb-10.1*[-embedded,-static]) required by (virtual/mysql-5.6-r7:0/18::gentoo, installed)
Comment 16 Brian Evans Gentoo Infrastructure gentoo-dev 2016-01-07 01:52:39 UTC
(In reply to Reinis Danne from comment #15)
> Could this be because of required USE client-libs which is in virtual/mysql,
> but mariadb doesn't have it anymore? I'm still having the following blocker
> on world update:
> 
> Uninstalling dev-db/mysql-connector-c and virtual/libmysqlclient pulls them
> right back in on next merge:
> 
> These are the packages that would be merged, in order:
> 
> Calculating dependencies... done!
> [ebuild  N     ] dev-db/mysql-connector-c-6.1.6-r2:0/18::gentoo  USE="ssl
> -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
> [ebuild  N     ] virtual/libmysqlclient-18:0/18::gentoo  USE="-static-libs"
> ABI_X86="32 (64) (-x32)" 0 KiB
> [ebuild     U  ] dev-db/mariadb-10.1.10:0/18::gentoo [10.1.9:0/18::gentoo]
> USE="cracklib openssl pam perl server systemd xml -bindist -debug -embedded
> -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jemalloc
> -latin1 -libressl -mroonga -odbc -oqgraph -profiling (-selinux) -sphinx
> -sst-rsync -sst-xtrabackup -static -static-libs -systemtap -tcmalloc {-test}
> -tokudb -yassl (-client-libs%) (-tools%*)" ABI_X86="(64) -32 (-x32)" 54 155
> KiB
> [blocks B      ] dev-db/mariadb[client-libs(+)]
> ("dev-db/mariadb[client-libs(+)]" is blocking
> dev-db/mysql-connector-c-6.1.6-r2)

This is an issue of mismatched ABI_X86 USE between the virtual/libmysqlclient and dev-db/mariadb.  Unfortunately, portage's autounmask is not smart enough to suggest it when it is possible, but unsetting abi_x86_32 on mysql-connector-c might change that.

No one else has further input and it has been a week, so I'm calling this fixed.

Post and/or reopen if you still have issues.
Comment 17 Reinis Danne 2016-01-07 12:08:58 UTC
Thanks for the tip! Indeed setting abi_x86_32 for mariadb allows to solve the blocker.

It seems that virtual/mysql is missing ${MULTILIB_USEDEP} for packages in RDEPEND, right now it is set only for virtual/libmysqlclient in PDEPEND.
Comment 18 Pryka 2016-03-15 11:09:45 UTC
Im completely forgot about this problem, because in the time the only solution for me was to mask dev-db/mysql-connector-c. And install dev-db/mysql-cluster.

Today I removed mask, mysql-cluster and virtual/libmysqlclient. But Im still getting this block every single time i try to update my machine... The +/-abi_x86_32 on mysql-connector-c didn't work in my case.

[ebuild  N     ] dev-db/mysql-connector-c-6.1.6-r2:0/18::gentoo  USE="ssl -static-libs" ABI_X86="(64) -32 (-x32)" 3394 KiB
[ebuild  N     ] virtual/libmysqlclient-18:0/18::gentoo  USE="-static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild  N     ] dev-db/mariadb-10.1.12:0/18::gentoo  USE="cracklib embedded openssl pam perl server xml -bindist -debug -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jemalloc -kerberos -latin1 -libressl -mroonga -odbc -oqgraph -profiling (-selinux) -sphinx -sst-rsync -sst-xtrabackup -static -static-libs -systemd -systemtap -tcmalloc {-test} -tokudb -yassl" ABI_X86="(64) -32 (-x32)" 54249 KiB
[blocks B      ] dev-db/mariadb[client-libs(+)] ("dev-db/mariadb[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.6-r2)




 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-db/mariadb-10.1.12:0/18::gentoo, ebuild scheduled for merge) pulled in by
    =dev-db/mariadb-10.1*[embedded?,server,static?] (=dev-db/mariadb-10.1*[embedded,server]) required by (virtual/mysql-5.6-r8:0/18::gentoo, ebuild scheduled for merge)

  (dev-db/mysql-connector-c-6.1.6-r2:0/18::gentoo, ebuild scheduled for merge) pulled in by
    dev-db/mysql-connector-c:0/18[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-db/mysql-connector-c:0/18[abi_x86_64(-)]) required by (virtual/libmysqlclient-18:0/18::gentoo, ebuild scheduled for merge)


Any idea?

ps. I Cut-out other unrelated updates in queue just to better view.

ps2. Full update queue is attached.
Comment 19 Pryka 2016-03-15 11:10:13 UTC
Created attachment 428284 [details]
update-block
Comment 20 Pryka 2016-03-15 12:13:30 UTC
I just resolved it.

Installed mariadb then libmysqlclient one by one. And its working. No more mysql-connector-c in the way.