Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 556264 - x11-drivers/xf86-video-intel-2.99.917 fails to start when built against >=x11-libs/libdrm-2.4.61
Summary: x11-drivers/xf86-video-intel-2.99.917 fails to start when built against >=x11...
Status: RESOLVED DUPLICATE of bug 552124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal critical (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-29 19:59 UTC by Ilia Mirkin
Modified: 2015-08-17 17:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilia Mirkin 2015-07-29 19:59:37 UTC
When built against a recent enough libdrm (2.4.51+ I believe, but not 100% sure), the X server doesn't start.

Commit 7fe2b294865 upstream fixes this.

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=7fe2b2948652443ff43d907855bd7a051d54d309

This is the segfault I get otherwise:

[   240.532] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
[   240.532] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
[   240.532] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
[   240.532] (++) using VT number 7

[   240.533] (II) intel(0): Using Kernel Mode Setting driver: i915, version 1.6.0 20150130
[   240.534] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4600
[   240.534] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2
[   240.534] (II) intel(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[   240.534] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[   240.534] (==) intel(0): RGB weight 888
[   240.534] (==) intel(0): Default visual is TrueColor
[   240.534] (**) intel(0): Option "TearFree" "on"
[   240.534] (EE) 
[   240.534] (EE) Backtrace:
[   240.534] (EE) 0: /usr/bin/X (xorg_backtrace+0x48) [0x5841b8]
[   240.534] (EE) 1: /usr/bin/X (0x400000+0x188169) [0x588169]
[   240.534] (EE) 2: /lib64/libc.so.6 (0x7f5467c95000+0x34ed0) [0x7f5467cc9ed0]
[   240.534] (EE) 
[   240.534] (EE) Segmentation fault at address 0x0


Reproducible: Always

Steps to Reproduce:
Install libdrm 2.4.52 (or .51 may be good enough) rebuild xf86-video-intel, restart X. Observe segfault above.
Comment 1 Ilia Mirkin 2015-07-29 20:05:30 UTC
Sorry, typo. I meant libdrm 2.4.61+, not 2.4.51.
Comment 2 Ilia Mirkin 2015-07-29 22:14:45 UTC
Also, I believe, but haven't verified, that this issue happens any xf86-video-intel version, not just 2.99.917 (at least when using the sna backend), when built against the latest libdrm version.
Comment 3 Toralf Förster gentoo-dev 2015-08-17 15:23:24 UTC
run today into a similar mess (stable amd64 hardened, ThinkPad T440s, i915, mesa-10.6.3, x11-drivers/xf86-video-intel-2.99.91) - X11 was f*ed up.

For me the it was sufficient to downgrade ~x11-base/xorg-server-1.17.2 to .1 and to re-emerge deps.
Comment 4 Ilia Mirkin 2015-08-17 16:37:25 UTC
(In reply to Toralf Förster from comment #3)
> run today into a similar mess (stable amd64 hardened, ThinkPad T440s, i915,
> mesa-10.6.3, x11-drivers/xf86-video-intel-2.99.91) - X11 was f*ed up.
> 
> For me the it was sufficient to downgrade ~x11-base/xorg-server-1.17.2 to .1
> and to re-emerge deps.

Note that there's an issue with x11-proto/xproto-7.0.28 which causes an X server built against it to randomly die too, somewhere in Close* or something along those lines. There is a patch (to the X server) to fix it, but it has yet to be checked in: http://lists.freedesktop.org/archives/xorg-devel/2015-July/046980.html

However this bug is about segfault in the intel driver on startup, pretty sure that's only affected by newer libdrm versions. (And I note that there's a x11-drivers/xf86-video-intel-2.99.917-r2 ebuild which includes the patch I suggested.)
Comment 5 Rémi Cardona gentoo-dev 2015-08-17 17:01:00 UTC
@Ilia, then could you try the -r2 ebuild if you're not using it?

@Toralf, probably a different issue. Please open a separate bug.

Thanks to both of you.

*** This bug has been marked as a duplicate of bug 552124 ***
Comment 6 Ilia Mirkin 2015-08-17 17:10:27 UTC
(In reply to Rémi Cardona from comment #5)
> @Ilia, then could you try the -r2 ebuild if you're not using it?

Hmmmm.... that is very surprising. It does seem like the -r2 ebuild was around when I filed this bug. Was I not using it somehow? Will reopen if it was not a case of PEBKAC.