Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 556074 - dev-tex/luatex (any version) : /usr/include/kpathsea/config.h:62:29: fatal error: kpathsea/c-auto.h: No such file or directory
Summary: dev-tex/luatex (any version) : /usr/include/kpathsea/config.h:62:29: fatal er...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-27 20:04 UTC by Toralf Förster
Modified: 2019-11-27 06:56 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log (dev-tex-luatex-0.76.0-20150727-195130.log,44.10 KB, text/plain)
2015-07-27 20:04 UTC, Toralf Förster
Details
package history (dev-tex-luatex-0.76.0-20150727-195130.pks,406.30 KB, text/plain)
2015-07-27 20:04 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2015-07-27 20:04:14 UTC
Created attachment 407760 [details]
emerge log

hhm, maybe the tex at this chroot image is broken, if not :


x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I./w2c  -I/usr/include -DNO_DEBUG -DLUA_COMPAT_MODULE -I./luatexdir/lua52 -DFONTFORGE_CONFIG_NO_WINDOWING_UI=1 -DLUA_FF_LIB=1 -D_NO_PYTHON=1 -DX_DISPLAY_MISSING=1 -DNODYNAMIC=1 -D_NO_FREETYPE=1 -D_NO_LIBUNINAMESLIST=1 -UHAVE_LIBINTL_H -DUSE_OUR_MEMORY=1 -I./w2c -I./luatexdir/luafontloader/fontforge/inc -I./luatexdir/luafontloader/fontforge/fontforge   -march=native -O2 -pipe -c -o luatexdir/luafontloader/fontforge/Unicode/libff_a-ArabicForms.o `test -f 'luatexdir/luafontloader/fontforge/Unicode/ArabicForms.c' || echo './'`luatexdir/luafontloader/fontforge/Unicode/ArabicForms.c
In file included from ./w2c/config.h:22:0,
                 from ./luatexdir/luafontloader/fontforge/inc/basics.h:38,
                 from ./luatexdir/luafontloader/fontforge/inc/utype.h:7,
                 from luatexdir/luafontloader/fontforge/Unicode/ArabicForms.c:1:
/usr/include/kpathsea/config.h:62:29: fatal error: kpathsea/c-auto.h: No such file or directory
 #include <kpathsea/c-auto.h>
                             ^
compilation terminated.
Makefile:3140: recipe for target 'luatexdir/luafontloader/fontforge/Unicode/libff_a-ArabicForms.o' failed
make: *** [luatexdir/luafontloader/fontforge/Unicode/libff_a-ArabicForms.o] Error 1
 * ERROR: dev-tex/luatex-0.76.0::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-tex/luatex-0.76.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-tex/luatex-0.76.0::gentoo'`.
 * The complete build log is located at '/var/log/portage/dev-tex:luatex-0.76.0:20150727-195130.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-tex/luatex-0.76.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-tex/luatex-0.76.0/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-tex/luatex-0.76.0/work/luatex-beta-0.76.0/source/texk/web2c'
 * S: '/var/tmp/portage/dev-tex/luatex-0.76.0/work/luatex-beta-0.76.0/source'

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named amd64-gnome-unstable_20150719-194535) at a hardened host acting as a tinderbox.

Portage 2.2.20 (python 2.7.10-final-0, default/linux/amd64/13.0/desktop/gnome, gcc-4.9.3, glibc-2.21-r1, 4.0.8-hardened x86_64)
=================================================================
System uname: Linux-4.0.8-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16164692 total,   1759896 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 27 Jul 2015 17:45:01 +0000
sh bash 4.3_p39
ld GNU ld (Gentoo 2.25.1 p1.0) 2.25.1
ccache version 3.2.2 [disabled]
app-shells/bash:          4.3_p39::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10::gentoo, 3.3.5-r1::gentoo, 3.4.3::gentoo
dev-util/ccache:          3.2.2::gentoo
dev-util/cmake:           3.3.0::gentoo
dev-util/pkgconfig:       0.28-r3::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1::gentoo
sys-devel/gcc:            4.8.4::gentoo, 4.9.3::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

local
    location: /usr/local/portage
    masters: gentoo

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: 9999

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/entropy /etc/stunnel/stunnel.conf /usr/lib64/fax /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /var/lib/hsqldb /var/lib/redmine/config /var/spool/fax/etc /var/spool/torque"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/games/angband/edit/ /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /var/lib/redmine/config/locales /var/lib/redmine/config/settings.yml"
CXXFLAGS="-O2 -pipe"
DISTDIR="/var/tmp/distfiles"
EMERGE_DEFAULT_OPTS="--nospinner --tree --quiet-build --accept-properties=-interactive --accept-restrict=-fetch --accept-restrict=-cdinstall"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync network-sandbox news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.uni-erlangen.de/pub/mirrors/gentoo rsync://mirror.netcologne.de/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gor.bytemark.co.uk/gentoo/ rsync://ftp.snt.utwente.nl/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi aes-ni alsa amd64 apache2 avx avx2 berkdb bluetooth branding btrfs bzip2 cairo cdda cdr cgi cli colord consolekit corefonts cracklib crypt cups curl cxx dbus designer dnssec dot dri drmkms dts dvd dvdr ecc eds emboss encode evo exif extraengine fam firefox flac fortran fpm gdbm gif glamor gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gudev gui iconv icu inifile introspection ipv6 jadetex jpeg lcms libkms libnotify libsecret logrotate mad mbox minizip mmx mmxext mng modules mp3 mp4 mpeg multilib nautilus ncurses nls nptl ogg opengl openmp pam pango pax_kernel pcre pcre16 pdf plasma policykit postgres ppds pulseaudio qemu qml qt3support qt4 readline sdl session spell spice sqlite sqlite3 sse sse2 sse4 sse4_1 sse4_2 ssl ssse3 startup-notification svg tcl tcpd tiff tracker truetype udev udisks uml unicode upower usb usbredir vorbis wxwidgets x264 xcb xkb xml xslt xv xvfb xvid xvmc zenmap zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104 v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Toralf Förster gentoo-dev 2015-07-27 20:04:30 UTC
Created attachment 407762 [details]
package history
Comment 2 Rafał Mużyło 2015-07-28 08:26:16 UTC
The version of kpathsea that moved that header belongs to texlive set 2014 which has dev-tex/luatex block, so this seems to be a case of setup not supported by maintainer/herd.
Comment 3 Miroslav Olšák 2015-09-17 19:09:32 UTC
Well, there is c-auto.h but at a very wrong place. 

$ equery f kpathsea 
 * Searching for kpathsea ...
 * Contents of dev-libs/kpathsea-6.2.1_p20150521:
/etc
/etc/texmf
/etc/texmf/fmtutil.d
...
/usr/include/kpathsea/variable.h
/usr/include/kpathsea/version.h
/usr/include/kpathsea/win32lib.h
/usr/lib64
/usr/lib64/kpathsea
/usr/lib64/kpathsea/c-auto.h
...

Moving it to /usr/include solves the problem. Sorry, I don't understand, what put it there.
Comment 4 David Haller 2015-09-19 16:29:13 UTC
I came across this too, solved the root of the problem (I think), but chose to open a seperate bug:

https://bugs.gentoo.org/show_bug.cgi?id=560856

Until apps (upstream!) using kpathsea use pkgconfig to find the cflags for kpathsea, I see little use in patching a ton of apps using kpathsea to use pkgconfig for cflags when we can fix the root cause (that weird move of the header to $libdir/kpathsea/c-auto.h). If my (or a similar) fix is adopted,
I think this bug can be closed :)
Comment 5 Fabian Groffen gentoo-dev 2016-02-20 14:31:39 UTC
Right, so, @tex what stops us from moving (or symlinking) c-auto.h back to usr/unclude/kpathsea?  Or should we mask kpathsea versions?
Comment 6 Alexis Ballier gentoo-dev 2016-02-22 09:51:19 UTC
(In reply to Fabian Groffen from comment #5)
> Right, so, @tex what stops us from moving (or symlinking) c-auto.h back to
> usr/unclude/kpathsea?

well, first maybe because it has been moved there for a reason: it is abi-dependent and autogenerated.

>  Or should we mask kpathsea versions?

mask luatex rather: the offending kpathsea version is for texlive 2015, and probably doesn't work with earlier versions, and with texlive 2015 you can't install dev-tex/luatex since it is incldued in texlive-core.


lazy fix is what is all around the place:
has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
Comment 7 Andreas K. Hüttel archtester gentoo-dev 2017-06-07 08:59:24 UTC
This now affects stable package set.
Comment 8 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-11-27 06:56:19 UTC
Will be removed in a week.