Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 555890 - sys-firmware/seabios-1.7.5[-binary]: kbd.c:120: undefined reference to `usb_kbd_command'
Summary: sys-firmware/seabios-1.7.5[-binary]: kbd.c:120: undefined reference to `usb_k...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Doug Goldstein (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-5
  Show dependency tree
 
Reported: 2015-07-25 19:57 UTC by xpue
Modified: 2015-08-30 03:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (sys-firmware:seabios-1.7.5-r1:20150725-191717.log,154.66 KB, text/plain)
2015-07-25 19:57 UTC, xpue
Details
emerge --info (einfo,3.48 KB, text/plain)
2015-07-25 19:59 UTC, xpue
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xpue 2015-07-25 19:57:17 UTC
sys-firmware/seabios[-binary] fails to build

Reproducible: Always
Comment 1 xpue 2015-07-25 19:57:42 UTC
Created attachment 407618 [details]
build.log
Comment 2 xpue 2015-07-25 19:59:15 UTC
Created attachment 407620 [details]
emerge --info
Comment 3 Felix Janda 2015-07-27 17:18:17 UTC
The build failed because of gcc 5.2 (-std=gnu11).

Try compiling with an older version of gcc or with -fgnu89-inline added to CFLAGS.
Comment 4 xpue 2015-08-21 08:39:19 UTC
Yes, -fgnu89-inline fixes the problem.
Comment 5 SpanKY gentoo-dev 2015-08-30 00:13:27 UTC
fixed w/1.8.2 release which is in the tree now