Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 555108 - A slot non-conflict blocks merging
Summary: A slot non-conflict blocks merging
Status: RESOLVED DUPLICATE of bug 554924
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-16 20:41 UTC by Lukas Barth
Modified: 2015-07-17 11:30 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
The requested emerge --info (emerge_info.txt,5.50 KB, text/plain)
2015-07-16 20:41 UTC, Lukas Barth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Barth 2015-07-16 20:41:46 UTC
Created attachment 406934 [details]
The requested emerge --info

Hi,

this is what emerge -auND currently gives me:

=============================================================
janeway tinloaf # emerge -auDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-util/boost-build-1.56.0 [1.55.0] PYTHON_TARGETS="python2_7%*" 
[ebuild     U  ] sys-process/lsof-4.88-r1 [4.87-r1]
[ebuild     U ~] www-plugins/chrome-binary-plugins-44.0.2403.89_beta1 [44.0.2403.81_beta1]
[ebuild     U  ] sys-devel/bc-1.06.95-r1 [1.06.95]
[ebuild     U  ] media-libs/netpbm-10.66.00 [10.51.00-r2] USE="-doc% -static-libs%" CPU_FLAGS_X86="sse2%*" 
[ebuild   R    ] cross-avr/gcc-4.8.4  USE="cxx* openmp* sanitize*" 
[ebuild     U  ] sys-apps/help2man-1.46.6 [1.45.1]
[ebuild     U  ] sys-libs/pam-1.2.1 [1.1.8-r2] USE="pie%*" 
[ebuild     U  ] dev-db/postgresql-9.4.4 [9.4.3]
[ebuild     U  ] dev-lang/spidermonkey-17.0.0-r4 [17.0.0-r3]
[ebuild     U  ] dev-libs/boost-1.56.0-r1 [1.55.0-r2]
[ebuild     U  ] sys-devel/crossdev-20150602 [20141030]
[ebuild     U  ] sys-boot/grub-2.02_beta2-r7 [2.02_beta2-r3] USE="fonts%* themes%*" GRUB_PLATFORMS="-uboot%" 

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/boost:0

  (dev-libs/boost-1.56.0-r1:0/1.56.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/boost-1.55.0-r2:0/1.55.0::gentoo, installed) pulled in by
    dev-libs/boost:0/1.55.0= required by (app-text/libwps-0.3.1:0/0::gentoo, installed)
                  ^^^^^^^^^^                                                                                               
    dev-libs/boost:0/1.55.0 required by (app-office/libreoffice-bin-4.4.3.2:0/0::gentoo, installed)
                  ^^^^^^^^^                                                                                                            
    (and 7 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
=============================================================

Emerge then returns and does not offer me to start the update. It looks like that non-existent slot conflict is a problem. 

Something similar has already been reported in #430190 (which I read..), but the difference is: Over there, emerge actually did ignore that pseudo-conflict (and refused the merge because of some other conflicts that the user did not see). In my case, I can't find any other reasons why emerge refuses to merge this.

Turning backtracking up does also not solve this problem. I know I could mask away the updated version of boost, but I should not have to...
Comment 1 Amy Liffey gentoo-dev 2015-07-17 11:30:39 UTC

*** This bug has been marked as a duplicate of bug 554924 ***