Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 55479 - help2man-1.29 configure: error: perl 5.005 required
Summary: help2man-1.29 configure: error: perl 5.005 required
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2004-06-28 16:19 UTC by Daniel
Modified: 2004-12-08 21:06 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2004-06-28 16:19:10 UTC
When doing an emerge system there is a dependency to perl missing.
So you get something like this.

emerge system
>>> emerge (1 of 65) sys-apps/help2man-1.29 to /
>>> md5 src_uri ;-) help2man-1.29.tar.gz
>>> Unpacking source...
>>> Unpacking help2man-1.29.tar.gz to /var/tmp/portage/help2man-1.29/work
>>> Source unpacked.
creating cache ./config.cache
checking for perl... no
configure: error: perl   required

!!! ERROR: sys-apps/help2man-1.29 failed.
!!! Function econf, Line 365, Exitcode 1
!!! econf failed

Reproducible: Always
Steps to Reproduce:
1.unmerge perl
2.emerge help2man
Actual Results:  
After this steps you get the above error.

Expected Results:  
First get the missing perl 5.005

Portage 2.0.50-r5 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.2-r9, 2.4.26)
System uname: 2.4.26 i686 
Gentoo Base System version
CFLAGS="-march=pentium2 -mcpu=pentium2 -mmmx -Os -pipe"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium2 -mcpu=pentium2 -mmmx -Os -pipe"
FEATURES="autoaddcvs ccache distcc sandbox userpriv usersandbox"
USE="3dfx X aalib alsa apm avi berkdb bzlib cdr crypt cups db dvd dvdr encode
f77 foomatic foomaticdb gdbm gif gimp gimpprint gmp gnome gpm gtk2 imlib java
jpeg lame lesstif libg++ libwww lirc mad mbox mikmod mmx mng motif mp3 mpeg
ncurses nls ogg oggvorbis opengl oss pam pdf pdflib png ppds ps python quicktime
readline ruby samba sane sdl slang spell ssl svcd svga tcpd tiff truetype vcd
vim wmf x86 xml2 xmms xv zlib"
Comment 1 mindtech 2004-07-20 07:56:49 UTC
Same problem today during an installation with "emerge system"

"emerge help2man" asks for perl, but "emerge perl" asks help2man ...
Comment 2 Martin Diers 2004-09-04 00:02:07 UTC

On a 2004.2, using a stage2 tarball, during "emerge system", Portage attempts to merge help2man before perl, in spite of its depedency upon perl.

Repeated "emerge system", and "emerge perl" and "emerge help2man" attempts finally resolved this problem.

This would appear to be a dependency issue of some sort, that oddly enough, only manifests itself during a system merge. The dependency info in the help2man ebuild is correct, AFAIK.
Comment 3 Christopher Hotchkiss 2004-09-22 04:12:13 UTC
This bug also occurs on the amd64 platform. I checked the ebuild and perl was already in the ebuild, but emerge wasn't catching it.
Chris Hotchkiss
Comment 4 Alexey Guzeev 2004-10-11 21:51:09 UTC
Exactly the same problem on the sparc
Comment 5 leo 2004-10-27 07:11:57 UTC
ive had this one too, repeating emerge of help2man and perl and system solved the problem!
Comment 6 Eric Pretorious 2004-10-31 13:54:41 UTC
This is absurd: How can a bug that prevents the installation of an O/S be "normal"? What's the ETA for a repair?

Eric P.,
Sunnyvale, CA
Comment 7 Eric Pretorious 2004-10-31 18:20:04 UTC
I'm absurd. I apologize: I just realized that I'm using the stage2-i686-20030910.tar.bz2. I've downloaded the current stage (stage2-pentium3-2004.2.tar.bz2) instead of using the one contained on my LiveCD and everything seems to be going very nicely. I apologize for being so abrupt.
Comment 8 Jonathan Hitchcock 2004-11-02 01:11:04 UTC
I'm using stage2-x86-2004.2, and I get the same problem.

I remember this problem from a while back, though - perl "needs" help2man, and help2man definitely needs perl...

AFAICR, it's only a problem with stage2, though.
Comment 9 Jonathan Hitchcock 2004-11-02 01:29:40 UTC
You might want to look at bug 58176 and bug 48687, too.

My emerge system (stage 2 -> stage 3) broke on help2man, and I did it again, and help2man was four packages down the proposed install list, but still above perl, and so still broke.

I then did an 'emerge system' again, and this time perl and libperl were at the top of the install list, and installed fine.  My machine is now compiling openssl, so everything seems dandy.

There is definitely some sort of circular dependency problem here, though.  'qpkg -q' and 'equery depends' are not awfully helpful, and I suspect I may have to resort to some form of grep -r to find out exactly what the dependency tree (no, it'd be a dependency graph if it's got a circular path, eh?) is that's causing the problem.
Comment 10 Philippe Trottier (RETIRED) gentoo-dev 2004-11-17 19:04:31 UTC
broke on sparc 

emerge system

RDEPEND is now having perl, maybe we should add DEPEND ??
Comment 11 katerina 2004-11-21 00:17:42 UTC
Same error. Gentoo 2004.3, stage1.
Comment 12 katerina 2004-11-21 00:59:13 UTC
Workaround: USE="-berkdb"
Otherwise, perl and help2man have circular deps, as noted in comment 1.  

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-, 2.6.9-gentoo-r1 i686)
System uname: 2.6.9-gentoo-r1 i686 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
USE="X alsa apm arts avi bitmap-fonts crypt cups doc dvd encode f77 faad flac foomaticdb fortran gdbm gif gimpprint gpm gtk gtk2 guile imagemagick imlib java javascript jpeg kde libg++ libwww mad mikmod mpeg ncurses nls nptl objc oggvorbis opengl oss pam pdflib perl png python qt quicktime readline ruby scanner sdl spell ssl tcltk tcpd theora tiff truetype unicode usb wmf x86 xml2 xmms xv zlib"
Comment 13 AD Rutledge 2004-11-24 11:26:48 UTC
This shows up on PowerPC as well.
What's wrong is the configure stage requires perl to be present, even though it really is only needed to run the program.  So, until the configure stage is fixed, this should really have perl in DEPEND and not just RDEPEND.
Comment 14 Peter Karlsson 2004-12-08 06:46:33 UTC
I just hit this bug yesterday (2004-12-08) using gentoo 2004.3-r1 universal
livecd and doing a stage2 install.

Can it be avoided (it's a showstopper for me right now)?
Comment 15 SpanKY gentoo-dev 2004-12-08 21:06:14 UTC
this bug was triggered by diffutils' requirement of help2man

i've removed it from the ebuild and tweaked diffutils to not require help2man anymore