Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 554578 - emerge always raises attribute error with soname deps enabled
Summary: emerge always raises attribute error with soname deps enabled
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Binary packages support (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks: 694246 549914
  Show dependency tree
 
Reported: 2015-07-12 03:38 UTC by mike@marineau.org
Modified: 2019-09-12 23:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Use Atom with dbapi.match_pkgs (0001-Use-Atom-with-dbapi.match_pkgs.patch,1.17 KB, patch)
2015-07-12 03:38 UTC, mike@marineau.org
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description mike@marineau.org 2015-07-12 03:38:25 UTC
Created attachment 406578 [details, diff]
Use Atom with dbapi.match_pkgs

A plain string atom is passed to code assuming Atom:

  File "/usr/lib64/python2.7/site-packages/_emerge/Scheduler.py", line 1306, in _do_merge_exit
    self._task_complete(pkg)
  File "/usr/lib64/python2.7/site-packages/_emerge/Scheduler.py", line 1379, in _task_complete
    blocker_db.discardBlocker(pkg)
  File "/usr/lib64/python2.7/site-packages/_emerge/BlockerDB.py", line 120, in discardBlocker
    for cpv_match in self._fake_vartree.dbapi.match_pkgs("=%s" % (pkg.cpv,)):
  File "/usr/lib64/python2.7/site-packages/_emerge/resolver/DbapiProvidesIndex.py", line 85, in match_pkgs
    return [self._db._cpv_map[cpv] for cpv in self.match(atom)]
  File "/usr/lib64/python2.7/site-packages/_emerge/resolver/DbapiProvidesIndex.py", line 39, in match
    if atom.soname:
AttributeError: 'unicode' object has no attribute 'soname'
Comment 1 Zac Medico gentoo-dev 2015-07-12 05:09:48 UTC
There's a patch in the following branch:

https://github.com/zmedico/portage/tree/bug_554578

It can be installed like this:

echo '=sys-apps/portage-9999 **' >> /etc/portage/package.accept_keywords
portage_LIVE_BRANCH=bug_554578 \
portage_LIVE_REPO=https://github.com/zmedico/portage.git \
emerge -1 =sys-apps/portage-9999

I've posted it for review here:

https://archives.gentoo.org/gentoo-portage-dev/message/3913fe7229d6470f2242ec0471a97cce
Comment 3 mike@marineau.org 2015-07-14 21:14:42 UTC
(In reply to Zac Medico from comment #2)
> This is in the master branch:
> 
> https://gitweb.gentoo.org/proj/portage.git/commit/
> ?id=2afd8f2c533e6e000b5619282a4cd4c71405eb62

I can confirm that the current master works for me. Thanks!
Comment 4 Brian Dolbec gentoo-dev 2015-09-22 01:23:19 UTC
Released in portage-2.2.21