Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 55452 - dev-lisp/lush-0.99 (libload "gsl/gsl") broken
Summary: dev-lisp/lush-0.99 (libload "gsl/gsl") broken
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Gentoo Lisp Project
Depends on:
Reported: 2004-06-28 10:39 UTC by Philippe Trottier (RETIRED)
Modified: 2005-03-03 11:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Trottier (RETIRED) gentoo-dev 2004-06-28 10:39:11 UTC
emerge dev-lisp/lush-0.99
emerge dev-libs/gsl-1.4

? (libload "gsl/gsl")

*** module-load : dld/bfd error
*** File in wrong format

Same thing for many other demos in /usr/share/lush/demos/RUNME
Comment 1 Philippe Trottier (RETIRED) gentoo-dev 2004-06-28 10:44:19 UTC
We are trying to use gsl libraries with lush... but no success using the ebuilds... the same lush-0.99 compile from the tarball of creates proper gsl-lush functions.

Tried on those systems:
Linux s1 2.6.4 #4 SMP Thu Mar 25 16:53:22 EET 2004 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel GNU/Linux

Linux flatdrum 2.6.7 #3 Mon Jun 21 17:24:45 EEST 2004 ppc 7450, altivec supported PowerBook3,3 GNU/Linux

These have been tested on many ppc system, compiled all with gcc-3.3.4, started with 3.2.x, upgraded to 3.3.3 and then to 3.3.4 etc etc and all show a similar behavior.

Comment 2 Matthew Kennedy (RETIRED) gentoo-dev 2004-07-16 08:43:14 UTC
I was able to confim this problem.  As a work around, you could try adding 
--without-bfd to the econf line in the ebuild such as follows:

src_compile() {
        econf `use_with X X` \
                --without-bfd \
                || die "./configure failed"
        emake -j1 || die

(The above with use dlopen() etc. instead of libbfd)

I built lush-0.99 /with/ BFD support outside of the emerge/ebuild environment 
and tried it with (libload "gsl/gsl") and it does function properly, so I 
suspect there is a problematic interaction with the sandbox library preloader.  
I have not investigated this further though.
Comment 3 Philippe Trottier (RETIRED) gentoo-dev 2004-10-17 15:05:34 UTC
Same thing here, I just got the time to make one newer test. Since this tool is not anymore needed for us, I probably won't continue the follow up on this bug... It would be nice to fix it anyway as SANDBOX might be causing other not so easy to reproduce troubles while this one is systematic.
Comment 4 Matthew Kennedy (RETIRED) gentoo-dev 2005-03-03 11:38:12 UTC
added fix to lush-0.99 and added lush-1.0 with the same fix.