Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 553770 - Call ‘epatch_user’ at the end of ‘src_prepare’ by default
Summary: Call ‘epatch_user’ at the end of ‘src_prepare’ by default
Status: RESOLVED DUPLICATE of bug 475288
Alias: None
Product: Gentoo Hosted Projects
Classification: Unclassified
Component: PMS/EAPI (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: PMS/EAPI
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-02 07:48 UTC by Another Mortal
Modified: 2015-07-02 17:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Another Mortal 2015-07-02 07:48:54 UTC
I find the ‘epatch_user’ approach a **lot** simpler and cleaner
than having to copy ebuilds to my local overlay for applying patches.
Unfortunately, too many ebuilds do *not* include ‘epatch_user’
(for no good reason, other than noboday having requested this).
Now, I’m getting tired having to ask ebuild by ebuild; so, I’d
much prefer to have this functionality as __standard__, unless
-of course- there’s obvious drawbacks (which I couldn’t think of).

Reproducible: Always
Comment 1 Zac Medico gentoo-dev 2015-07-02 17:27:42 UTC

*** This bug has been marked as a duplicate of bug 475288 ***