Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 552310 - >=net-fs/samba-4.2.0 does not install backend for cups
Summary: >=net-fs/samba-4.2.0 does not install backend for cups
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
: 554106 (view as bug list)
Depends on:
Blocks: samba-4
  Show dependency tree
 
Reported: 2015-06-16 17:12 UTC by Small_Penguin
Modified: 2017-02-16 23:48 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Small_Penguin 2015-06-16 17:12:10 UTC
I am not sure if this is a problem with all samba-4, I have only tested samba-4.2.0.

If you enable the cups USE flag, the backend gets built as /usr/bin/smbspool. But net-print/cups-2.0.2-r2 does not find it:
Printer status: Paused - "Backend /usr/libexec/cups/backend/smb does not exist!"

It can be fixed easily by symlinking it, and it will work again:
ln -s /usr/bin/smbspool /usr/libexec/cups/backend/smb


Reproducible: Always

Steps to Reproduce:
1. USE="cups" emerge samba

Actual Results:  
Samba-4 cups backend not found by cups.

Expected Results:  
Samba-4 cups backend found by cups.
Comment 1 Erik Quaeghebeur 2016-03-30 12:19:34 UTC
With the stabilization of samba-4.2.9, I got hit by this bug, so I can confirm it. Grumpily I wonder why samba-4.2.9 was stabilized with this 9-month old bug still unfixed, as the fix seems to be easy, given that the provided workaround works well. (One should resume the affected printers in the CUPS web interface after creating the symlink.)
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2016-03-30 14:08:30 UTC
commit 955e092df75b63c6de9b3295808b44aeaa22e954
Author: Lars Wendler <polynomial-c@gentoo.org>
Date:   Wed Mar 30 16:00:41 2016

    net-fs/samba: Fixed smb backend detection by cups (bug #552310)
    
    Package-Manager: portage-2.2.28
    Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>


Sorry. I completely missed that bug. Most likely because I don't use any printers via samba. Should be fixed now. Please re-sync your portage tree and re-emerge samba-4.2.9
Comment 3 Andreas K. Hüttel archtester gentoo-dev 2017-02-16 23:48:59 UTC
*** Bug 554106 has been marked as a duplicate of this bug. ***