Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 552124 - x11-drivers/xf86-video-intel-2.99.917-r1 crashes with SNA, but works with UXA
Summary: x11-drivers/xf86-video-intel-2.99.917-r1 crashes with SNA, but works with UXA
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL: http://cgit.freedesktop.org/xorg/driv...
Whiteboard:
Keywords:
: 556264 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-14 19:54 UTC by jorgicio
Modified: 2015-08-17 17:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
The log from Xorg that shows a segmentation fault. (Xorg.0.log,6.83 KB, text/plain)
2015-06-14 19:55 UTC, jorgicio
Details
Patch that solves the breakage (xf86-video-intel-2.99.917-kernel-4.0-sna.patch,1.97 KB, patch)
2015-06-15 02:30 UTC, jorgicio
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description jorgicio 2015-06-14 19:54:15 UTC
Yesterday, the xf86-video-intel-2.99.917-r1 was upgraded with some patches that fix compilation with newer versions of GCC. Since then, running with SNA enabled is broken.
The only workaround I could do, is disabling SNA and enabling UXA, and it works, as I mentioned in https://bugs.gentoo.org/show_bug.cgi?id=550784.

Even I tried with downgrading to 2.99.917, but it also fails. Also recompiled xorg-server and glibc, and nothing happens. I have KMS enabled. Also tried with other session managers (lightdm, slim, etc.), and the result is the same.
I'm using Kernel 4.0.5-gentoo.


Reproducible: Always




Portage 2.3.6-r9 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.9.2, glibc-2.20-r1, 4.0.5-gentoo x86_64)
=================================================================
System uname: Linux-4.0.5-gentoo-x86_64-Intel-R-_Core-TM-_i5-2410M_CPU_@_2.30GHz-with-gentoo-2.2.0
KiB Mem:     8087788 total,   2904324 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Unknown
ld GNU ld (Funtoo 2.25) 2.25.0
app-shells/bash:          4.3_p39
dev-java/java-config:     2.2.0-r1000
dev-lang/perl:            5.20.2-r1
dev-lang/python:          2.7.10-r1000, 3.4.3-r1000
dev-util/cmake:           3.2.1
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.4-r4
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.13, 2.69-r1
sys-devel/automake:       1.11.6-r1, 1.13.4, 1.14.1, 1.15
sys-devel/binutils:       2.25-r1
sys-devel/gcc:            4.9.2-r1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.3-r2
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 4.0 (virtual/os-headers)
sys-libs/glibc:           2.20-r1
Repositories: gentoo local hasufell haskell laurentb sublime-text causelay xhochy gamerlay sunrise gentoo-zh jorgicio mv seeds
Installed sets: @kernel
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7-avx -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-march=corei7-avx -O2 -pipe"
GENTOO_MIRRORS="http://gentoo.c3sl.ufpr.br/ http://ftp.heanet.ie/mirrors/funtoo/"
INSTALL_MASK="/usr/lib/systemd/ /lib/systemd/"
LANG="es_CL.utf8"
LC_ALL="es_CL.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="es"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp/"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/hasufell /var/lib/layman/haskell /var/lib/layman/laurentb /var/lib/layman/sublime-text /var/lib/layman/causelay /var/lib/layman/xhochy /var/lib/layman/gamerlay /var/lib/layman/sunrise /var/lib/layman/gentoo-zh /var/lib/layman/jorgicio /var/lib/layman/mv /var/lib/layman/seeds"
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X a52 aac acl alsa amd64 amr amrenc ap apng avx base berkdb bluetooth bluray branding bzip2 cairo caja cdda cddb cdio cdr cleartype consolekit cracklib crypt cups cxx dbus dconf declarative djvu dri dts dvd dvdr dvdread encode exif extras faac faad ffmpeg flac fontconfig fortran gconf gdbm gdu gif gpm gstreamer gtk gtkstyle highlight ibus ico iconv icu id3tag ieee1394 infinality introspection ios ipod ipv6 jpeg jpeg2k lame libass libguess libmpeg2 libv4l lzma mad matroska mjpeg mmx modemmanager modules mp3 mp4 mpeg mtp mudflap multilib ncurses networkmanager nls nptl nsplugin ogg opengl openmp pam pcre pdf php png policykit postproc pppd pulseaudio python qt3support quicktime readline resolvconf scanner sndfile sse sse2 ssl svg taglib tcpd themes theora threads tiff truetype truetype-fonts twolame type1 udev udisks unicode upower urandom v4l v4l2 vaapi vdpau vim vim-syntax vorbis vpx wav wavpack webp win32codecs wmf x264 x265 xattr xml xv xvid zlib zsh-completion" ABI_X86="32 64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="userdir mime dir mime_magic cgi status unixd unique_id env alias usertrack authn_core authz_core authz_host socache_shmcb mem_cache file_cache cache headers include actions auth_basic authn_anon authn_core authn_dbm authz_host authn_file autoindex authz_owner authz_user cgid dav dav_fs dav_lock deflate expires ext_filter filter info log_config logio negotiation rewrite setenvif socache_shmcb speling vhost_alias authz_dbm authz_groupfile auth_digest" CALLIGRA_FEATURES="krita braindump plan" CAMERAS="samsung" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="emu efi-32 efi-64 pc multiboot" INPUT_DEVICES="evdev mouse synaptics joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-minimizer" LINGUAS="es" NGINX_MODULES_EXTERNAL="access_key accept_language concat echo fancyindex metrics upload_progress" NGINX_MODULES_HTTP="access auth_basic autoindex browser charset empty_gif fastcgi geo gzip limit_conn limit_req map memcached proxy referer rewrite scgi split_clients ssi upstream_hash upstream_ip_hash upstream_keepalive upstream_least_conn userid uwsgi auth_request flv geoip gunzip gzip_static image_filter mp4 ssl stub_status" NGINX_MODULES_MAIL="smtp" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_ABIS="2.7 3.4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby20 ruby22" SANE_BACKENDS="hp gt68xx" USERLAND="GNU" VIDEO_CARDS="intel i965 nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK

Note that the xf86-video-intel used in Funtoo, is the same as in Gentoo, so don't dismiss that!
Comment 1 jorgicio 2015-06-14 19:55:09 UTC
Created attachment 405152 [details]
The log from Xorg that shows a segmentation fault.
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2015-06-14 22:45:41 UTC
(In reply to jorgicio from comment #0)
> Even I tried with downgrading to 2.99.917, but it also fails.

"also fails" means what exactly? Also crashes? 2.99.917 was not touched at all when bug 550784 was fixed.

> Note that the xf86-video-intel used in Funtoo, is the same as in Gentoo, so
> don't dismiss that!

Funtoo may have done other strange things to their packages, we don't know. So any Funtoo issues should be reported to their bug tracker.
Comment 3 jorgicio 2015-06-14 23:06:46 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #2)
> (In reply to jorgicio from comment #0)
> > Even I tried with downgrading to 2.99.917, but it also fails.
> 
> "also fails" means what exactly? Also crashes? 2.99.917 was not touched at
> all when bug 550784 was fixed.

I don't know, what that's what I got when I downgraded, which is weird at all.
> 
> > Note that the xf86-video-intel used in Funtoo, is the same as in Gentoo, so
> > don't dismiss that!
> 
> Funtoo may have done other strange things to their packages, we don't know.
> So any Funtoo issues should be reported to their bug tracker.

Just some few system packages: GCC, Portage and unrelated libraries to X11 ones. The rest of the ebuilds are the same than the Gentoo ones, so in ebuild matters, Gentoo and Funtoo are (almost) the same. Hence the advice.
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2015-06-15 00:23:19 UTC
Yes, and the crash happens apparently somewhere in glibc:

> [ 20009.508] (EE) Backtrace:
> [ 20009.508] (EE) 0: /usr/bin/X (xorg_backtrace+0x49) [0x5836a9]
> [ 20009.508] (EE) 1: /usr/bin/X (0x400000+0x1874d9) [0x5874d9]
> [ 20009.508] (EE) 2: /lib64/libc.so.6 (0x7f54a5c72000+0x332d0) [0x7f54a5ca52d0]
Comment 5 jorgicio 2015-06-15 02:30:58 UTC
Created attachment 405170 [details, diff]
Patch that solves the breakage

I applied that patch that I found somewhere in the Opensuse's Bugzilla. It works.
The problem is for people who have the 4.0 kernel.

Thanks to: https://bugzilla.opensuse.org/show_bug.cgi?id=931917
Comment 6 Miroslav Šulc gentoo-dev 2015-06-15 06:48:58 UTC
i can confirm both that the issue exists in gentoo and that the attached patch fixes it.
Comment 7 Markus Rathgeb 2015-06-15 07:10:41 UTC
I have done a fresh Gentoo installation on my new M3800 (Intel Core i7-4702HQ with integrated Intel Graphics (HD4600) + Nvidia Quadro K1100M) this weekend.
ATM VIDEO_CARDS is set to "intel i965".
I can start X (xf86-video-intel USE flag was not changed, so sna should be choosen -- will have a look at this evening) without any crash or freeze.

I am using ~amd64.
So, are you using the testing branch, too?

If this patch fixes your freeze, we should (IMHO) apply them.
But perhaps we could wait until someone without a freeze (perhaps myself) test the patch, too. If this breaks my system then we need to further inspect it.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2015-06-15 12:26:38 UTC
+  15 Jun 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+  +files/xf86-video-intel-2.99.917-libdrm-kernel-4_0-crash.patch,
+  +xf86-video-intel-2.99.917-r2.ebuild:
+  Add patch to fix SNA crash with newer libdrm/kernel, bug #552124.
Comment 9 Oleh 2015-06-15 13:14:38 UTC
i'd suggest not close this bug until it's confirmed working. This bug impact WAY much of a users assuming amount of Intel cards used.
Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2015-06-15 13:19:13 UTC
The original issue is fixed with this patch according to the reporter per comment #5.

If there are any crashes or other issues remaining, a separate bug report should be opened for them.
Comment 11 Rémi Cardona gentoo-dev 2015-08-17 17:01:00 UTC
*** Bug 556264 has been marked as a duplicate of this bug. ***