Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 551874 - app-shells/bash-4.3 w/ app-shells/bash-completion: cd autocomplete fail with [], () and {} in directory names
Summary: app-shells/bash-4.3 w/ app-shells/bash-completion: cd autocomplete fail with ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Michał Górny
URL: https://lists.gnu.org/archive/html/bu...
Whiteboard:
Keywords:
: 554572 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-12 09:15 UTC by Petr Lanc
Modified: 2017-07-02 20:06 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Lanc 2015-06-12 09:15:41 UTC
After upgrade app-shells/bash from 4.2 to 4.3, autocomplete function of bash used with 'cd' command is failing with directory names containing [], () and {}.

For example:

$ ls -1
(a)_aa
(a)_bb
[a]_aa
[a]_bb
[b]_aa
{a}_aa
{a}_bb

4.2$ cd \[a\]_<TAB><TAB>
a]_aa/ [a]_bb/
4.2$ cd \(a\)_<TAB><TAB>
(a)_aa/ (a)_bb/
4.2$ cd {a\}_<TAB><TAB>
{a}_aa/ {a}_bb/

4.3$ cd \[<TAB><TAB>
4.3$ cd \[a<TAB><TAB>
...
nothing happen. Completion doesn't work. Other kind of braces is the same. But, when i try

4.3$ ls \[a\]_<TAB><TAB>
[a]_aa/ [a]_bb/
4.3$ ls \(a\)_<TAB><TAB>
(a)_aa/ (a)_bb/
4.3$ ls \{a\}_<TAB><TAB>
{a}_aa/ {a}_bb/

With ls, and other commands it works. I had only seen this problem with cd.

I tried it with versions 4.2_p53, 4.3_p33-r2, ~4.3_p39.

Thanks

Petr



Reproducible: Always

Steps to Reproduce:
1. update to app-shells/bash from 4.2 to 4.3
2. mkdir '[a]_aa' '[a]_bb'
3. cd \[a<TAB><TAB>



irbis ~ # emerge --info
Portage 2.2.18 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.4, glibc-2.20-r2, 3.18.12-gentoo x86_64)
=================================================================
System uname: Linux-3.18.12-gentoo-x86_64-Intel-R-_Core-TM-_i7-4770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16397564 total,   2791060 free
KiB Swap:    4194300 total,   4177984 free
Timestamp of repository gentoo: Fri, 05 Jun 2015 04:30:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.24 p1.4) 2.24
ccache version 3.1.9 [disabled]
app-shells/bash:          4.3_p33-r2::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r1::gentoo, 3.4.1::gentoo
dev-util/ccache:          3.1.9-r4::gentoo
dev-util/cmake:           2.8.12.2-r1::gentoo
dev-util/pkgconfig:       0.28-r3::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.11::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.13.4::gentoo, 1.14.1::gentoo
sys-devel/binutils:       2.24-r3::gentoo
sys-devel/gcc:            4.8.4::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.18::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://drak.ab.czso.cz/gentoo-portage
    priority: -1000

drak-overlay
    location: /usr/local/portage
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core-avx-i -funroll-loops -mfpmath=sse -msse -msse2 -msse3 -mssse3 -mmmx -msse4.1 -msse4.2 -mavx -mavx2 -maes -mpclmul -mfsgsbase -mrdrnd -mf16c -mabm -mbmi2 -fomit-frame-pointer -fprefetch-loop-arrays -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/xsessions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core-avx-i -funroll-loops -mfpmath=sse -msse -msse2 -msse3 -mssse3 -mmmx -msse4.1 -msse4.2 -mavx -mavx2 -maes -mpclmul -mfsgsbase -mrdrnd -mf16c -mabm -mbmi2 -fomit-frame-pointer -fprefetch-loop-arrays -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ http://mirror.switch.ch/mirror/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/var/tmp/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac aalib acl acpi alsa amd64 anthy apm asf bash-completion berkdb bzip2 caps cdparanoia cdrom cjk cli clucene consolekit cracklib crypt cups curl cxx dbus dri dvd dvdread f77 ffmpeg flac fontconfig foomaticdb fortran fuse gdbm gif gimpprint gnutls gpm gtk gtk2 iconv imagemagick imap imlib immqt-bc inotify jpeg jpeg2ki kde lame libass lzma lzo m17n-lib mad maildir mjpeg mmx mmxext modules mp3 mpeg mplayer mtp multilib ncurses network nls nptl nptlonly nsplugin objc ogg oggvorbis opengl openmp oss pam pcre pdf pdflib png policykit ppds qt qt3support qt4 rar rdp readline recode samba scim sdl semantic-desktop session slang sndfile spell sse sse2 ssl ssse3 tcpd threads tiff truetype udev unicode usb vim-syntax vnc vorbis win32codecs wma wmf x264 xcomposite xine xinerama xpm xv zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.4"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andrew Miller 2015-06-12 13:26:25 UTC
Have you tried the other forms of completion? What happens if you do

cd <ALT + SHIFT + ?>
Comment 2 Petr Lanc 2015-06-12 13:33:45 UTC
With alt+shift+? its unfortunately all the same. In 4.2 works, in 4.3 not.
Comment 3 SpanKY gentoo-dev 2015-07-08 18:12:04 UTC
works fine for me.  are you sure bash-completion isn't screwing it up ?
Comment 4 Petr Lanc 2015-07-10 08:20:34 UTC
Maybe, but I don't realy know. I tried several combinations of bash and bash-completion:

bash-4.3 alone = work
bash-4.2 + bash-completion-2.1-r2 = work
bash-4.3 + bash-completion-2.1-r2 = doesn't work
bash-4.3 + bash-completion-2.1_p20141224 = doesn't work

bash 4.3 with any bash-completion doesn't work, bash 4.2 works with it. I couldn't try bash-4.2 with bash-completion-2.1_p20141224, because it needs bash-4.3.
Comment 5 SpanKY gentoo-dev 2015-07-10 10:04:15 UTC
it works for me w/out bash-completion, so assuming bug on that side
Comment 6 SpanKY gentoo-dev 2015-07-13 02:58:21 UTC
*** Bug 554572 has been marked as a duplicate of this bug. ***