Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 550342 - loudness-scanner: A tool that scans your music files and tags them with loudness information.
Summary: loudness-scanner: A tool that scans your music files and tags them with loudn...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Default Assignee for New Packages
URL: https://github.com/jiixyj/loudness-sc...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-25 10:34 UTC by Tobias Leupold
Modified: 2019-07-09 20:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
media-sound/loudness-scanner-9999.ebuild (loudness-scanner-9999.ebuild,1.76 KB, text/plain)
2019-07-01 03:11 UTC, Stefan Briesenick
Details
media-sound/loudness-scanner-9999.ebuild (loudness-scanner-9999.ebuild,1.78 KB, text/plain)
2019-07-01 09:13 UTC, Stefan Briesenick
Details
media-sound/loudness-scanner-9999.ebuild (loudness-scanner-9999.ebuild,1.91 KB, text/plain)
2019-07-01 12:41 UTC, Stefan Briesenick
Details
media-sound/loudness-scanner-9999.ebuild (loudness-scanner-9999.ebuild,1.87 KB, text/plain)
2019-07-01 13:20 UTC, Stefan Briesenick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Leupold 2015-05-25 10:34:12 UTC
Hi all!

Please add an ebuild for loudness-scanner. It's an application implementing the EBU R 128 algorithm for calculating the perceived loudness of audio material. It's comparable to the older ReplayGain algorithm but newer.

The "loudness" tool can add replaygain tags to all kinds of audio files like mp3, ogg, aac and m4a. So this tool can replace all the single *gain tools like mp3gain, vorbisgain and aacgain. It's very handy.

Building it was a bit tricky though. Apparently, there's no "real" homepage. I cloned the git repository from https://github.com/jiixyj/loudness-scanner and checked out v0.5.1. But there are two external projects that have to be put into the sources so that one can build it: https://github.com/jiixyj/libebur128.git at state 1214547 has to be put inside the "ebur128" directory and https://github.com/jiixyj/filewalk.git at state 38422e6 has to be put into "scanner/filetree".

After that, the sources build just fine. it's quite easy, it can be bult via the normal cmake procedure. A CLI, Qt and GTK version of the scanner is built. Perhaps, some source snapshot with all the relevant sources could be created and mirrored by Gentoo (and that#s the point why I don't simply post an ebuild)?

As this project surpasses all the other *gain ones, it would be very cool to have it into Gentoo.

Cheers, Tobias
Comment 1 Tobias Leupold 2015-08-28 14:00:15 UTC
Happily, libebur128 already made it to the tree: media-libs/libebur128. Perhaps, this will help?
Comment 2 Tobias Leupold 2016-08-02 18:48:10 UTC
Just to say this: it's not that tricky, one just has to rtfm on the github info:

git submodule init
git submodule update

in the cloned repository does the trick. No manual fiddling necessary. Still ... would be very nice if this made it to the tree :-)
Comment 3 Tobias Leupold 2017-11-04 18:57:16 UTC
Just to ping this one more time: This package is way better than all the other format-specific ReplayGain ones. It's actively developed and we really, really should have it in Gentoo.

Still, it has not been added to portage ...
Comment 4 Michael Palimaka (kensington) gentoo-dev 2017-11-05 12:25:16 UTC
Unfortunately there's no dedicated team of people picking up new packages - mostly everyone ends up maintaining packages that directly interest them.

The good news though is that interested person can be you! See: https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers
Comment 5 Tobias Leupold 2017-11-05 13:19:04 UTC
I know of this possibility (I'm currently trying to do so with Bug #574964), but the problem is that I didn't manage to write an ebuild doing the job until now.

I thought this would be easy because of the "normal" build process, but unfortunately, I didn't get after "it apparently builds, but it doesn't install correctly" with this:

    EAPI=6

    inherit git-r3 cmake-utils

    DESCRIPTION="A tool that scans your music files and tags them with loudness information"
    HOMEPAGE="https://github.com/jiixyj/loudness-scanner/"
    EGIT_REPO_URI="git://github.com/jiixyj/loudness-scanner.git"

    LICENSE="MIT"
    SLOT="0"
    KEYWORDS="~amd64"
    IUSE=""

    DEPEND=""
    RDEPEND="${DEPEND}"
Comment 6 Stefan Briesenick 2017-11-25 14:47:09 UTC
+1 ping, need this urgently ;-)
Comment 7 Stefan Briesenick 2018-03-23 03:38:55 UTC
media-sound/mp3gain and media-sound/aacgain is masked and will be removed in a few days. So this tool is needed urgently! PLEASE! ;-)
Comment 8 Stefan Briesenick 2019-06-30 20:58:51 UTC
ping?
Comment 9 Stefan Briesenick 2019-07-01 03:11:23 UTC
Created attachment 581582 [details]
media-sound/loudness-scanner-9999.ebuild
Comment 10 Stefan Briesenick 2019-07-01 03:12:38 UTC
attached ebuild works, but may need some touching from a maintainer. ;-)
Comment 11 Stefan Briesenick 2019-07-01 09:13:14 UTC
Created attachment 581602 [details]
media-sound/loudness-scanner-9999.ebuild

fixed docs install and QA warnings.
Comment 12 Stefan Briesenick 2019-07-01 12:41:47 UTC
Created attachment 581606 [details]
media-sound/loudness-scanner-9999.ebuild

moved plugins (libinput_*.so) into /usr/lib{,64}/r128
Comment 13 Stefan Briesenick 2019-07-01 13:20:19 UTC
Created attachment 581610 [details]
media-sound/loudness-scanner-9999.ebuild

final cleanup.

now it would be nice to have this in portage. Thanks!
Comment 14 Larry the Git Cow gentoo-dev 2019-07-09 20:43:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e1cda045fa5de9279d72e0641a7483982285ee84

commit e1cda045fa5de9279d72e0641a7483982285ee84
Author:     Matthias Maier <tamiko@gentoo.org>
AuthorDate: 2019-07-09 20:05:42 +0000
Commit:     Matthias Maier <tamiko@gentoo.org>
CommitDate: 2019-07-09 20:41:15 +0000

    media-sound/loudness-scanner: new ebuild
    
    Closes: https://bugs.gentoo.org/550342
    Closes: https://github.com/gentoo/gentoo/pull/12411
    Package-Manager: Portage-2.3.68, Repoman-2.3.16
    Signed-off-by: Matthias Maier <tamiko@gentoo.org>

 .../loudness-scanner/loudness-scanner-9999.ebuild  | 72 ++++++++++++++++++++++
 media-sound/loudness-scanner/metadata.xml          | 29 +++++++++
 2 files changed, 101 insertions(+)