Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 549976 - net-misc/dhcp-4.3.2 fails to compile on musl
Summary: net-misc/dhcp-4.3.2 fails to compile on musl
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: musl-porting
  Show dependency tree
 
Reported: 2015-05-20 15:13 UTC by Robert Sebastian Gerus
Modified: 2016-10-13 07:32 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dhcp-4.3.2-fix-compilation-for-musl.patch (dhcp-4.3.2-fix-compilation-for-musl.patch,1.42 KB, patch)
2015-05-20 15:13 UTC, Robert Sebastian Gerus
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Sebastian Gerus 2015-05-20 15:13:14 UTC
net-misc/dhcp-4.3.2 fails to compile on musl. One-liner patch (attached) fixes it for musl and doesn't break it for regular (glibc) gentoo

Reproducible: Always

Steps to Reproduce:
1. emerge -v net-misc/dhcp
Actual Results:  
x86_64-gentoo-linux-musl-gcc -DHAVE_CONFIG_H -I. -I../includes  -DMINIRES_LIB -DHMAC_MD5   -Os -pipe -fomit-frame-pointer -mtune=g
eneric  -I../bind/include -c -o prandom.o prandom.c
In file included from dst_api.c:56:0:
../includes/arpa/nameser.h:109:2: error: unknown type name 'u_int8_t'
  const u_int8_t *_msg, *_eom;
  ^
../includes/arpa/nameser.h:110:2: error: unknown type name 'u_int16_t'
  u_int16_t _id, _flags, _counts[ns_s_max];
  ^


Expected Results:  
>>> net-misc/dhcp-4.3.2 merged.

Tested only for these use flags set (for dhcp package): USE="client ipv6 server ssl", didn't check ldap or vim-syntax; selinux is masked on musl.
Comment 1 Robert Sebastian Gerus 2015-05-20 15:13:55 UTC
Created attachment 403684 [details, diff]
dhcp-4.3.2-fix-compilation-for-musl.patch
Comment 2 Anthony Basile gentoo-dev 2015-05-22 11:32:21 UTC
This is now on the overlay.  It should go upstream since its correct.
Comment 3 Matthew Thode ( prometheanfire ) archtester Gentoo Infrastructure gentoo-dev Security 2015-08-06 18:56:11 UTC
upstreaming status?
Comment 4 Felix Janda 2016-10-13 02:20:34 UTC
At least net-misc/dhcp-4.3.3_p1 (stable) and net-misc/dhcp-4.3.5 build
fine for me (on musl) with the same USE as the reporter. The version
for which this bug was reported is no longer in the tree. So this bug
can probably be closed.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2016-10-13 07:32:11 UTC
Thanks for the heads up.

Closing this bug.