Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 549618 - sys-devel/boost-m4-0.4 - incompatible with gcc-5.1
Summary: sys-devel/boost-m4-0.4 - incompatible with gcc-5.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Nathan Phillip Brink (binki) (RETIRED)
URL:
Whiteboard:
Keywords: PATCH
Depends on:
Blocks: gcc-5 546738
  Show dependency tree
 
Reported: 2015-05-16 05:03 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2015-07-19 09:57 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2015-05-16 05:03:16 UTC
See upstream commit: https://github.com/tsuna/boost.m4/commit/32553aaf4d5090da19aa0ec33b936982c685009f

Attempting to configure any package that was eautoreconf-ed using boost.m4 from boost-m4-0.4 results in errors like this with gcc-5.1.0:

> checking for Boost's header version... 
> configure: error: invalid value: boost_major_version=
Comment 1 Christoph Junghans gentoo-dev 2015-05-19 21:46:34 UTC
This issue breaks povray, too.
Comment 2 Ryan Hill (RETIRED) gentoo-dev 2015-07-07 04:09:11 UTC
Anyone mind if I apply this?
Comment 3 Sergey Popov gentoo-dev 2015-07-08 12:28:43 UTC
(In reply to Ryan Hill from comment #2)
> Anyone mind if I apply this?

<cpp hat>Do it please</cpp hat>
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2015-07-19 09:57:24 UTC
Fixed in boost-m4-0.4-r1.