Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 549294 - dev-java/ant-1.9.2 or dev-java/ant-core-1.9.2: no org.apache.tools.bzip2 installed
Summary: dev-java/ant-1.9.2 or dev-java/ant-core-1.9.2: no org.apache.tools.bzip2 inst...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Java (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Java team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-12 19:01 UTC by Martin Mokrejš
Modified: 2015-05-14 14:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Mokrejš 2015-05-12 19:01:59 UTC
It is weird that dev-java/ant-1.9.2 installs no files. Is this a virtual package?

In the jar files provided by ant-core I do not see anything related to org/apache/tools/bzip2 . I thought I do not have some USE flag set but which one would it be?

[ebuild   R    ] dev-java/ant-core-1.9.2::gentoo  USE="-doc -source" 0 KiB
[ebuild   R    ] dev-java/ant-commons-net-1.9.2::gentoo  0 KiB
[ebuild   R    ] dev-java/ant-contrib-1.0_beta3-r1::gentoo  USE="-doc -source" 0 KiB
[ebuild   R    ] dev-java/ant-ivy-2.3.0:2::gentoo  USE="-doc -examples -source {-test}" 0 KiB
[ebuild   R    ] dev-java/ant-1.9.2::gentoo  USE="X antlr bcel bsf commonslogging commonsnet javamail jdepend jsch log4j oro regexp resolver -jai -jmf -testutil" 0 KiB




My real pain is:

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/tools/bzip2/CBZip2InputStream


This is from MarkDuplicates utility from sci-biology/picard-1.103 .
Comment 1 James Le Cuirot gentoo-dev 2015-05-14 14:23:48 UTC
dev-java/ant is indeed a virtual package. ant-core provides this class.

chewi@symphony % jar tf /usr/share/ant-core/lib/ant.jar | fgrep CBZip2InputStream
org/apache/tools/bzip2/CBZip2InputStream$Data.class
org/apache/tools/bzip2/CBZip2InputStream.class

I can't look into it now but it's probably a problem with the picard build itself.