Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 548792 - kde-apps/kde4-l10n: KDE SC partially untranslated
Summary: kde-apps/kde4-l10n: KDE SC partially untranslated
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-06 19:07 UTC by Martin Gebert
Modified: 2015-08-25 22:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of emerge --info (emerge.info,5.28 KB, application/x-info)
2015-05-06 19:07 UTC, Martin Gebert
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Gebert 2015-05-06 19:07:02 UTC
I've configured my system to German locale (de_DE.UTF-8). However, kdm and lightdm-kde-greeter are always displayed in English, and the KDE apps are either partially (kconfig) or completely (kate) in English - as if most of the translation files aren't found, or my settings are intentionally ignored. I tried setting LANG, LANGUAGE and LC_ALL, Language in .dmrc (root and user), kdmrc and greeter.conf, without avail; kdeglobals is set to Language=de and kde-l10n installed.
Comment 1 Martin Gebert 2015-05-06 19:07:28 UTC
Created attachment 402776 [details]
Output of emerge --info
Comment 2 Martin Gebert 2015-05-06 21:51:22 UTC
Sorry, forgot to mention the package versions; they're currently all marked stable:

x11-misc/lightdm-kde-0.3.2.1
kde-base/kdm-4.11.14
kde-base/kde-l10n-4.14.3
kde-base/kate-4.14.3
Comment 3 Andreas Sturmlechner gentoo-dev 2015-05-09 20:57:12 UTC
You haven't by chance set kde-base/kde-l10n[minimal]?
Comment 4 Martin Gebert 2015-05-19 11:39:30 UTC
No.

--8><--
$ equery u kde-l10n
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for kde-base/kde-l10n-4.14.3:
 U I
 - - handbook            : Enable handbooks generation for KDE4.
 - - linguas_ar          : Arabic locale
[...]
 + + linguas_de          : German locale
[...]
 - - minimal             : Install a very minimal build (disables, for example, 
                           plugins, fonts, most drivers, non-critical features)
--><8--
Comment 5 Johannes Huber gentoo-dev 2015-08-25 22:32:51 UTC
There is a new version in tree. Please test with that.

 https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=03e89692c30604fee3d11f1b34c9554fea02496f