Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54758 - gpgme-0.4.7 build segfaults
Summary: gpgme-0.4.7 build segfaults
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: SpanKY
Depends on:
Reported: 2004-06-22 09:35 UTC by Alex Walker
Modified: 2005-03-20 21:44 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alex Walker 2004-06-22 09:35:28 UTC
When I try to emerge gpgme, it fails with a segfault.

Reproducible: Always
Steps to Reproduce:
1. emerge -u gpgme

Actual Results:  
/usr/bin/gpgsm --homedir . --import ./cert_g10code_test1.der 
gpgsm: keybox `./pubring.kbx' created 
gpgsm: some signal caught ... exiting 
make[3]: *** [pubring.kbx] Segmentation fault 
make[3]: *** Deleting file `pubring.kbx' 
make[3]: *** Waiting for unfinished jobs.... 
make[3]: Leaving directory 
make[2]: *** [all-recursive] Error 1 
make[2]: Leaving directory 
make[1]: *** [all-recursive] Error 1 
make[1]: Leaving directory 
make: *** [all] Error 2 
!!! ERROR: app-crypt/gpgme-0.4.7 failed. 
!!! Function src_compile, Line 48, Exitcode 2 
!!! (no error message) 

Expected Results:  
Installed correctly :) 

Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-, 
System uname: 2.6.7-gentoo i686 Pentium III (Coppermine) 
Gentoo Base System version 1.4.16 
ccache version 2.3 [enabled] 
Autoconf: sys-devel/autoconf-2.59-r4 
Automake: sys-devel/automake-1.8.5-r1 
CFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer -fforce-addr 
-falign-functions=4 -fprefetch-loop-arrays" 
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3/share/config /usr/kde/cvs/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control" 
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d" 
CXXFLAGS="-march=pentium3 -O3 -pipe -fomit-frame-pointer -fforce-addr 
-falign-functions=4 -fprefetch-loop-arrays" 
FEATURES="autoaddcvs ccache sandbox" 
USE="X X509 aalib acpi alsa apache2 arts artswrappersuid avi berkdb bonobo cdr 
composite crypt cups dga dvd editor encode esd flash foomaticdb gd gdbm ggi 
gif gnome gtk gtk2 gtkhtml guile imap imlib java jikes jpeg kde ldap libg++ 
libwww mad mikmod mmx motif mozilla moznocompose moznoirc mpeg mysql nas 
ncurses nls oggvorbis opengl pam pdflib perl png postgres ppds python qt 
quicktime readline samba sdl slang slp spell sse ssl svga tcltk tcpd tetex 
theora tiff tools truetype usb videos wmf x86 xml xml2 xmms xosd xslt xv zlib"
Comment 1 Tom Martin (RETIRED) gentoo-dev 2004-06-22 11:11:05 UTC
Have you tried lowering your CFLAGS?

Also, if it still segfaults with no CFLAGS, try running memtest86 (boot a Gentoo Livecd and enter memtest at the boot prompt).
Comment 2 SpanKY gentoo-dev 2004-07-05 13:17:50 UTC
report back when you've tried building with CFLAGS="-O -pipe" CXXFLAGS="-O -pipe"
Comment 3 Daniel Black (RETIRED) gentoo-dev 2004-08-08 13:51:39 UTC
Aiming of removing this ebuild in favour of 0.9.0 and fixing dependancies accordingly. Any dependancy problem please add to bug #57193.
Comment 4 Daniel Black (RETIRED) gentoo-dev 2004-09-21 02:38:16 UTC
What version of gnupg, libgcrypt, libgpg-error, and newpg do you have?
Comment 5 Sean E Russell 2004-09-21 04:42:48 UTC
> Sean - what you have seems to be same fault as #54758. Can we continue 
> discussion there. What version of gnupg, libgcrypt, libgpg-error, newpg 
> (anything else) do you have? Also consider changing you /etc/make.profile
> link to a 2004.2 profile. If you have a bit of time can you rummage around
> gpgme mailing lists for a similar error. I don't it's gentoo specific but
> having said that it works for me hence this bug.

Huh.  I think I keep up fairly well with Gentoo topics, but this /etc/make.profile thing is entirely new to me.  Anyway, I relinked it to 2004.2 and retried the build (-Uua world), and got the same error.

GnuPG: 1.2.4
libgcrypt: 1.1.94
libgpgerror: 1.0

Interestingly, I *know* I had newpg (newpg-0.9.4-r1) installed:


but emerge (and equery) no longer shows it as being installed -- in fact, emerge search turns up no results for newpg at all.  Was this a consequence of the switch to 2004.2?  If so, isn't this a bug in Portage?  Changing profiles shouldn't make installed packages disappear out of the database.

In any case, I can't think of any other appropriate packages to report about.  My CXX build flag is "-O2 -pipe" -- should I try with just "-O", or has this been proven to have no effect?
Comment 6 SpanKY gentoo-dev 2005-03-20 21:44:17 UTC