Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 547146 - [gnome-overlay] gnome-base/gdm-3.16.1.1 does not give login screen
Summary: [gnome-overlay] gnome-base/gdm-3.16.1.1 does not give login screen
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gnome-3.16
  Show dependency tree
 
Reported: 2015-04-19 22:39 UTC by Harris Landgarten
Modified: 2015-05-16 23:43 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harris Landgarten 2015-04-19 22:39:16 UTC
gdm-3.16.1.1 gives oh no something is wrong with no mouse or keyboard control.

if I boot to multi-user, startx works fine getting me into gnome with gnome-shell-3.16.1 and all the other bits in the overlay

Maybe gdm needs some more of 3.16 to work. I saw a similar thread on arch with gdm not working but seems like their 3.16.1-2 update fixed it.

logs are no help. The gdm user starts an x session which ends with session started and no errors.

I tried disabling wayland and turning on debugging in /etc/gdm/custom.conf but nothing changed.
Comment 1 Jura 2015-04-21 08:06:35 UTC
Try set "-wayland" in make.conf and update world.
Comment 2 Harris Landgarten 2015-04-21 12:36:05 UTC
I set -wayland globally but nothing seemed to have that useflag set.
Comment 3 Harris Landgarten 2015-04-21 15:31:58 UTC
Since the gdm user does get to the session started marker before the oh no something is wrong box I assume something went wrong starting gnome session for that gdm session.

It would held if we could get the new version of gnome-session and friends.
Comment 4 Harris Landgarten 2015-04-21 22:12:56 UTC
I tried installing gnome-session-9999 which works fine via startx but had no effect on GDM.

I also tried installing wayland libraries and turning on the wayland useflag in gdm but not change in OH NO Something is wrong when I start the graphical.target

Also nothing useful in logs.
Comment 5 Harris Landgarten 2015-04-22 18:02:20 UTC
this is the output of journctl -u gdm after the last attempts:

Apr 21 17:39:58 harrisl-desktop systemd[1]: Starting GNOME Display Manager...
Apr 21 17:39:58 harrisl-desktop systemd[1]: Started GNOME Display Manager.
Apr 21 17:39:58 harrisl-desktop gdm-launch-environment][21225]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-processes=1', ignoring
Apr 21 17:42:31 harrisl-desktop systemd[1]: Stopping GNOME Display Manager...
Apr 21 17:42:31 harrisl-desktop gdm[21186]: GLib: g_hash_table_find: assertion 'version == hash_table->version' failed
Apr 21 17:42:31 harrisl-desktop gdm[21186]: (gdm-display.c:1141):gdm_display_dispose: runtime check failed: (self->priv->status != GDM_DISPLAY_PREPARED)
Apr 21 17:42:31 harrisl-desktop systemd[1]: Stopped GNOME Display Manager.
Apr 21 17:43:04 harrisl-desktop systemd[1]: Starting GNOME Display Manager...
Apr 21 17:43:04 harrisl-desktop systemd[1]: Started GNOME Display Manager.
Apr 21 17:43:04 harrisl-desktop gdm-launch-environment][31067]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-processes=1', ignoring
Apr 21 17:46:08 harrisl-desktop systemd[1]: Stopping GNOME Display Manager...
Apr 21 17:46:08 harrisl-desktop gdm[31044]: GLib: g_hash_table_find: assertion 'version == hash_table->version' failed
Apr 21 17:46:08 harrisl-desktop gdm[31044]: (gdm-display.c:1141):gdm_display_dispose: runtime check failed: (self->priv->status != GDM_DISPLAY_PREPARED)
Apr 21 17:46:08 harrisl-desktop systemd[1]: Stopped GNOME Display Manager.
Apr 21 17:46:18 harrisl-desktop systemd[1]: Starting GNOME Display Manager...
Apr 21 17:46:18 harrisl-desktop systemd[1]: Started GNOME Display Manager.
Apr 21 17:46:18 harrisl-desktop gdm-launch-environment][16754]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-processes=1', ignoring
Apr 21 17:46:19 harrisl-desktop gdm[16732]: GdmDisplay: display lasted 0.389605 seconds
Apr 21 17:46:19 harrisl-desktop gdm[16732]: Child process 16754 was already dead.
Apr 21 17:46:19 harrisl-desktop gdm[16732]: Unable to kill session worker process
Apr 21 17:46:19 harrisl-desktop gdm[16732]: Child process 16754 was already dead.
Apr 21 17:46:19 harrisl-desktop gdm[16732]: Unable to kill session worker process
Apr 21 17:46:19 harrisl-desktop gdm-launch-environment][16789]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-processes=1', ignoring
Apr 21 17:47:07 harrisl-desktop gdm[16732]: Tried to look up non-existent conversation gdm-launch-environment
Apr 21 17:47:07 harrisl-desktop gdm[16732]: Freeing conversation 'gdm-launch-environment' with active job
Apr 21 17:47:07 harrisl-desktop gdm-session-worker[16995]: <5>AccountsService: Failed to create accounts proxy: Error calling StartServiceByName for org.freedesktop.Accounts: GDBus.Error:org.freedesktop.systemd1
Apr 21 17:47:07 harrisl-desktop gdm-session-worker[16995]: **
Apr 21 17:47:07 harrisl-desktop gdm-session-worker[16995]: AccountsService:ERROR:act-user-manager.c:2564:load_users: assertion failed: (manager->priv->accounts_proxy != NULL)
Apr 21 17:47:07 harrisl-desktop gdm[16732]: Freeing conversation 'gdm-launch-environment' with active job
Apr 21 17:47:13 harrisl-desktop systemd[1]: Stopping GNOME Display Manager...
Apr 21 17:47:13 harrisl-desktop gdm[16732]: Failed to contact accountsservice: Error calling StartServiceByName for org.freedesktop.Accounts: The connection is closed
Apr 21 17:47:13 harrisl-desktop gdm[16732]: GLib: g_hash_table_find: assertion 'version == hash_table->version' failed
Apr 21 17:47:13 harrisl-desktop gdm[16732]: (gdm-display.c:1141):gdm_display_dispose: runtime check failed: (self->priv->status != GDM_DISPLAY_PREPARED)
Apr 21 17:47:13 harrisl-desktop systemd[1]: Stopped GNOME Display Manager.
Comment 6 Harris Landgarten 2015-04-23 15:36:27 UTC
It seems from the log I posted and the way things are failing that gdm is trying to get a list of users and is being denied permission or otherwise failing. It so the issue is with the interface to either systemd-pam or accountsservice.
Comment 7 Gilles Dartiguelongue gentoo-dev 2015-05-14 21:48:43 UTC
Could you check again with an updated overlay ?
Comment 8 Harris Landgarten 2015-05-14 21:54:44 UTC
I can test it tomorrow night.
Comment 9 Harris Landgarten 2015-05-16 01:43:39 UTC
Getting closer:

Still getting oh no something has gone wrong with no mouse or keyboard control

but now everything looks right in the logs.

GDM user is setup authorized xorg starts and show systemd-logind controlling. But then as Xorg seems to finish initializing everything properly I end up with the error screen referenced above.

journalclt -e -u gdm give the following which is the only hint I have:

May 15 21:25:38 harrisl-desktop systemd[1]: Starting GNOME Display Manager...
May 15 21:25:38 harrisl-desktop systemd[1]: Started GNOME Display Manager.
May 15 21:25:40 harrisl-desktop gdm-launch-environment][1188]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-processes=1', ignoring
May 15 21:26:20 harrisl-desktop systemd[1]: Stopping GNOME Display Manager...
May 15 21:26:20 harrisl-desktop gdm[1177]: GLib: g_hash_table_find: assertion 'version == hash_table->version' failed
May 15 21:26:20 harrisl-desktop gdm[1177]: (gdm-display.c:1141):gdm_display_dispose: runtime check failed: (self->priv->status != GDM_DISPLAY_PREPARED)


Any ideas?
Comment 10 Harris Landgarten 2015-05-16 15:14:19 UTC
I did some debugging of the gdm failures. This is a complete as I have gotten so far. Everything seems to be working with users being found etc until the gdm user is authorized and then the gnome-display-manager has some issue:

GdmLocalDisplayFactory: display status changed: 2

and then gdm starts shutting down.


I enabled autologin and that works as expected:

GdmDisplayStore: Adding display /org/gnome/DisplayManager/Displays/16356352 to store

So the question is why can't gdm get a display when autologin is disabled?
Comment 11 Harris Landgarten 2015-05-16 23:43:30 UTC
This is the debug output of gdm leading to the failure:

May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: authenticating user gdm
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: state AUTHENTICATED
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: attempting to change state to AUTHORIZED
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: determining if authenticated user (password required:0) is authorized to session
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: state AUTHORIZED
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: attempting to change state to ACCREDITED
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'LOGNAME=gdm'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'USER=gdm'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'USERNAME=gdm'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'HOME=/var/lib/gdm'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'SHELL=/sbin/nologin'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: state ACCREDITED
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: user harrisl is now loaded
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: user harrisl was not yet known, adding it
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: tracking user 'harrisl'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: not yet loaded, so not emitting user-added signal
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: no pending users, trying to set loaded property
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: Seat loaded, so now setting loaded property
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: sending user-changed signal for user harrisl
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: sent user-changed signal for user harrisl
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: updating user harrisl
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: session display mode set to new-vt
May 16 17:01:44 harrisl-desktop gdm[1236]: GdmSession: type (null), program? yes, seat seat0
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'XDG_SESSION_TYPE=x11'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: attempting to change state to ACCOUNT_DETAILS_SAVED
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: user gdm, not fully loaded yet, will save account details later
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: trying to track new user with username gdm
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: finding user 'gdm' state 1
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: finding user 'gdm' state 2
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: Looking for user 'gdm' in accounts service
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: new user in accounts service with object path /org/freedesktop/Accounts/User112
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: tracking new user with object path /org/freedesktop/Accounts/User112
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: Found object path of user 'gdm': /org/freedesktop/Accounts/User112
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: finding user 'gdm' state 3
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: user 'gdm' fetched
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: finished handling request for user 'gdm'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: unrefing manager owned by fetch user request
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: user gdm is now loaded
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: user gdm was not yet known, adding it
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: tracking user 'gdm'
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: loaded, so emitting user-added signal
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: no pending users, trying to set loaded property
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: already loaded, so not setting loaded property
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: sending user-changed signal for user gdm
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: sent user-changed signal for user gdm
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: updating user gdm
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: user gdm is now loaded
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: sessions changed (user gdm) num=0
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: no pending users, trying to set loaded property
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: ActUserManager: already loaded, so not setting loaded property
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionSettings: saved session is
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionSettings: saved language is
May 16 17:01:44 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: saving account details for user gdm
May 16 17:01:46 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: Error calling GetAll() when retrieving properties for /org/freedesktop/Accounts/User112: Operation was cancelled
May 16 17:01:46 harrisl-desktop gdm-session-worker[1538]: <7>AccountsService: Error calling GetAll() when retrieving properties for /org/freedesktop/Accounts/User112: Operation was cancelled
May 16 17:01:46 harrisl-desktop gdm-launch-environment][1538]: pam_systemd(gdm-launch-environment:session): Unknown parameter 'kill-session-processes=1', ignoring
May 16 17:01:46 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: attempting to change state to SESSION_OPENED
May 16 17:01:46 harrisl-desktop gdm-session-worker[1538]: <7>GdmSessionWorker: Set PAM environment variable: 'XDG_VTNR=7'
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: Emitting 'session-opened' signal
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmDisplay: Greeter session opened
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmDisplay: session id: c1
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: Stopping all conversations except for gdm-launch-environment
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: type (null), program? yes, seat seat0
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: getting session command for file 'gnome.desktop'
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: getting session command for file 'gnome.desktop'
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: getting session command for file 'gnome.desktop'
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: getting session command for file 'gnome.desktop'
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: getting desktop names for file 'gnome.desktop'
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: type (null), program? yes, seat seat0
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmSession: Emitting 'session-started' signal with pid '1598'
May 16 17:01:46 harrisl-desktop gdm[1236]: GdmDisplay: Greeter started
May 16 17:01:50 harrisl-desktop gdm[1236]: GdmManager: trying to register new display
May 16 17:01:50 harrisl-desktop gdm[1236]: GdmLocalDisplayFactory: display status changed: 2