Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 546920 - sys-apps/portage-2.2.18: slot conflict with -k, no slot conflict without -k
Summary: sys-apps/portage-2.2.18: slot conflict with -k, no slot conflict without -k
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
Depends on:
Blocks: 300071
  Show dependency tree
Reported: 2015-04-17 13:26 UTC by Kobboi
Modified: 2015-04-20 17:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

output.txt (output.txt,9.45 KB, text/plain)
2015-04-17 13:28 UTC, Kobboi

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2015-04-17 13:26:53 UTC
# emerge -kuDNv world --with-bdeps=y --complete-graph=y

(leaving out the last two options does not make any difference)

Reproducible: Always

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

These are the packages that would be merged, in order:

Calculating dependencies  . ... ...... . ... .... done!
[ebuild     U  ] sys-process/lsof-4.88-r1::gentoo [4.88::gentoo] USE="examples ipv6 -rpc (-selinux) -static" 0 KiB
[binary   R    ] media-libs/fdk-aac-0.1.4:0/1::gentoo  USE="examples* -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] media-libs/libpng-1.6.17:0/16::gentoo [1.6.16:0/16::gentoo] USE="apng (-neon) -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] sys-libs/cracklib-2.9.4::gentoo [2.9.2-r1::gentoo] USE="nls zlib -python -static-libs {-test}" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7" 0 KiB
[ebuild     U  ] sci-physics/lammps-20150411::gentoo [20150406::gentoo] USE="examples -doc -gzip -lammps-memalign -mpi -python -static-libs" PYTHON_TARGETS="python2_7 python3_3%*" 0 KiB
[ebuild     U  ] sys-apps/iproute2-4.0.0::gentoo [3.19.0::gentoo] USE="berkdb iptables ipv6 -atm -minimal (-selinux)" 0 KiB
[ebuild     U  ] dev-tex/latexdiff-1.1.0::gentoo [1.0.4::gentoo] 0 KiB
[binary  rR    ] dev-lisp/sbcl-1.2.9:0/1.2.9::gentoo  USE="threads unicode zlib -debug -doc -pax_kernel -source" 0 KiB
[ebuild  r  U  ] dev-lisp/sbcl-1.2.10:0/1.2.10::gentoo [1.2.9:0/1.2.9::gentoo] USE="threads unicode zlib -debug -doc -pax_kernel -source" 0 KiB
[ebuild     U  ] dev-db/sqlite-3.8.9:3::gentoo [] USE="readline -debug -doc -icu -secure-delete -static-libs -tcl {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] dev-lang/ruby-2.0.0_p645:2.0::gentoo [2.0.0_p643:2.0::gentoo] USE="berkdb examples gdbm ipv6 ncurses rdoc readline ssl -debug -doc -rubytests -socks5 -xemacs" CPU_FLAGS_X86="sse2" 0 KiB
[ebuild     U  ] dev-lang/ruby-1.9.3_p551-r1:1.9::gentoo [1.9.3_p551:1.9::gentoo] USE="berkdb examples gdbm ipv6 ncurses rdoc readline ssl yaml -debug -doc -rubytests -socks5 -xemacs" 0 KiB
[ebuild  N     ] dev-ruby/rexical-1.0.5-r3::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 0 KiB
[ebuild  N     ] dev-ruby/rake-compiler-0.9.5::gentoo  USE="{-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 0 KiB
[ebuild  N     ] dev-ruby/hoe-3.13.1::gentoo  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 0 KiB
[ebuild     U  ] sys-apps/pciutils-3.3.1::gentoo [3.3.0-r2::gentoo] USE="kmod udev zlib -dns -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] sys-apps/gptfdisk-1.0.0::gentoo [0.8.10::gentoo] USE="ncurses -static" 0 KiB
[ebuild     U  ] net-libs/libmbim-1.12.2::gentoo [1.10.0::gentoo] USE="-static-libs" 0 KiB
[binary  rR    ] sci-mathematics/fricas-1.2.5::gentoo  USE="X -clisp -clozurecl (-cmucl) -ecls -emacs -gcl -gmp -sbcl" 0 KiB
[ebuild   R    ] dev-lang/python-3.3.5-r1:3.3::gentoo  USE="examples gdbm ipv6 ncurses readline sqlite ssl threads tk* xml -build -doc -hardened -wininst" 0 KiB
[ebuild  N     ] dev-ruby/nokogiri-  USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22" 0 KiB
[ebuild     U  ] app-editors/nano-2.4.1::gentoo [2.4.0::gentoo] USE="magic ncurses nls spell unicode -debug -justify -minimal -slang" 0 KiB
[ebuild     U  ] dev-ruby/rgen-0.6.6-r2::gentoo [0.6.6-r1::gentoo] USE="-doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21 -ruby22%" 0 KiB
[ebuild     U  ] app-admin/puppet-4.0.0::gentoo [3.7.4::gentoo] USE="ldap -augeas -diff -doc -emacs -minimal -rrdtool (-selinux) -shadow -sqlite3 {-test} -vim-syntax -xemacs" RUBY_TARGETS="ruby20 -ruby21% (-ruby19%*)" 2,736 KiB
[ebuild     U  ] net-ftp/lftp-4.6.2::gentoo [] USE="gnutls nls ssl -convert-mozilla-cookies -idn -openssl -socks5 -verify-file" LINGUAS="-cs -de -es -fr -it -ja -ko -pl -pt_BR -ru -uk -zh_CN -zh_HK -zh_TW" 0 KiB
[ebuild     U  ] www-plugins/adobe-flash- [] USE="(-debug) -kde (-selinux)" ABI_X86="64 -32 (-x32)" CPU_FLAGS_X86="sse2" 0 KiB
[ebuild   R    ] dev-util/cmake-3.2.1::gentoo  USE="ncurses qt4 -doc -emacs -internal-jsoncpp% -qt5 {-test}" 0 KiB
[ebuild     U  ] www-client/google-chrome-42.0.2311.90_p1::gentoo [41.0.2272.118_p1::gentoo] USE="plugins" LINGUAS="am ar bg bn ca cs da de el en_GB es es_LA et fa fi fil fr gu he hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt_BR pt_PT ro ru sk sl sr sv sw ta te th tr uk vi zh_CN zh_TW" 0 KiB
[ebuild     U  ] media-gfx/fotoxx-15.04.1::gentoo [15.02::gentoo] 0 KiB
[ebuild     U  ] sci-mathematics/maxima-5.36.0::gentoo [5.35.1-r1::gentoo] USE="X nls unicode -clisp -clozurecl (-cmucl) -ecls -emacs -gcl -latex -sbcl -tk -xemacs" LINGUAS="-es -pt -pt_BR" 0 KiB
[ebuild     U  ] sci-mathematics/wxmaxima-15.04.0::gentoo [14.12.0::gentoo] 0 KiB
[ebuild   R    ] games-simulation/flightgear-3.4.0::gentoo  USE="dbus examples* jsbsim udev utils yasim -debug -oldfdm -qt5 {-test} -vim-syntax" 0 KiB
[ebuild     U  ] gnome-extra/evolution-data-server-3.16.1:0/52::gnome [3.16.0:0/52::gnome] USE="gnome-online-accounts gtk introspection ipv6 ldap vala weather -api-doc-extras -kerberos {-test}" 0 KiB
[ebuild     U  ] mail-client/evolution-3.16.1:2.0::gnome [3.16.0:2.0::gnome] USE="bogofilter crypt ldap spell ssl weather -highlight -map -spamassassin" 0 KiB
[ebuild     U  ] net-wireless/bluedevil-2.1.1:4::gentoo [2.1:4::gentoo] USE="(-aqua) -debug" LINGUAS="-ar -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -fr -ga -gl -hu -it -ja -kk -km -ko -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@Latn -sr@ijekavian -sr@ijekavianlatin -sv -th -tr -ug -uk -zh_CN -zh_TW" 0 KiB

Total: 35 packages (25 upgrades, 4 new, 6 reinstalls, 3 binaries), Size of downloads: 2,736 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


  (dev-lisp/sbcl-1.2.10:0/1.2.10::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lisp/sbcl-1.2.9:0/1.2.9::gentoo, binary scheduled for merge) pulled in by
    dev-lisp/sbcl:0/1.2.9= required by (sci-mathematics/fricas-1.2.5:0/0::gentoo, binary scheduled for merge)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

!!! The following binary packages have been ignored due to non matching USE:

    =app-emulation/virtualbox-bin- -python_targets_python2_7
    =games-simulation/flightgear-3.4.0 -examples
    =dev-lang/python-3.3.5-r1 -tk
    =dev-util/cmake-3.2.1 -internal-jsoncpp

NOTE: The --binpkg-respect-use=n option will prevent emerge
      from ignoring these binary packages if possible.
      Using --binpkg-respect-use=y will silence this warning.
Comment 1 Kobboi 2015-04-17 13:28:18 UTC
Created attachment 401456 [details]
Comment 2 Kobboi 2015-04-17 13:29:10 UTC
(14:36:05) Kobboi: is it an issue with portage or with the tree that with -k I get a slot conflict and without I don't?
(14:39:18) floppym: That seems like a portage bug.
(14:45:05) floppym: Kobboi: Maybe save a tarball of /var/db/pkg in case someone wants to look at it later.

So, /var/db/pkg/ available on request (82MB tarball)
Comment 3 Zac Medico gentoo-dev 2015-04-19 04:20:51 UTC
Does it solve if you try it with --backtrack=30 as suggested in the emerge message?
Comment 4 Kobboi 2015-04-20 17:50:48 UTC
On one setup, where I am not using binary packages, I was also getting the sbcl-1.2.9 vs sbcl-1.2.10, but I worked around it because I really needed to.

On the original setup, where I am using binary packages and I for sure was not getting the conflict when not using binaries (as opposed to using the first setup), setting a backtrace value of 50 worked (did not try any other value).

So I guess, I am now in a situation where I can no longer give any useful feedback...